Closed Bug 1619317 Opened 8 months ago Closed 8 months ago

Substantial increase in 32 bit users on 64 bit OS around the first week of Decemeber

Categories

(Core :: Widget: Win32, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla76
Tracking Status
firefox-esr68 --- unaffected
firefox73 --- wontfix
firefox74 --- wontfix
firefox75 --- fixed
firefox76 --- fixed

People

(Reporter: jrmuizel, Assigned: emalysz)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: regression)

Attachments

(1 file)

In the first week of December 2019 we seem to have had a bunch of users move from 32 bit Windows to 64 bit Windows.

You can see this in this chart of isWow64:
https://datastudio.google.com/s/lIAvPpsI2m0

It also showed up here:
https://firefoxgraphics.github.io/telemetry/#view=trends in the "Firefox CPU Architecture" section.

and here: https://data.firefox.com/dashboard/hardware in the "Operating Systems by Architecture" table.

We've also noticed an uptick in OOMs on 32 bit lately, like in bug 1617730 and an omtp bug which perhaps started around the same time.

Blocks: 1617730
Summary: Substantial increase in 32 bit users on 64 bit OS around → Substantial increase in 32 bit users on 64 bit OS around the first week of Decemeber

It looks like this switch only happened on Win7: https://datastudio.google.com/open/181GE2_2Y2J8YoN1z8sfJqCbflircwSN-

It seems like this could've been caused by Firefox 71 perhaps by bug 1553546.

Flags: needinfo?(emalysz)
Flags: needinfo?(emalysz)

Looking into it more now!

Assignee: nobody → emalysz

Yeah, I confirmed the big switch happened in Firefox 71

Depends on: 1553546

(In reply to Jeff Muizelaar [:jrmuizel] from comment #2)

It seems like this could've been caused by Firefox 71 perhaps by bug 1553546.

Can you elaborate? That bug only touched measurements, not what people actually run, right? I don't see anything using the iswow64 data from the sysinfo service besides telemetry, so I wouldn't have expected this to e.g. affect updates (and even if it did, it wouldn't make sense for this to start with the release that first included these changes; the code would need to be there first, for it to start affecting updates...)

Flags: needinfo?(jmuizelaar)

My current theory is that bug 1553546 or another change Firefox 71 introduced a measurement change and we're now reporting different values for IsWow64. It seems unlikely that an actual change in user's system would produce a graph like the above that aligns with the update to 71.

It's likely possible to check what proportion of users that switched from IsWow64=false to IsWow64=true when updating to 71 vs not but that requires a sql query that's beyond my skills.

Flags: needinfo?(jmuizelaar)

I have a patch up right now that I believe will fix this issue (still testing). I think the problem is that I set info.isWow64 in the incorrect place

Pushed by aiakab@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/13d991470822
ensure we set isWow64 to the correct value after taking it off the main thread r=aklotz
Status: NEW → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla76

Emma, can we uplift this to 75?

Flags: needinfo?(emalysz)

Comment on attachment 9130458 [details]
Bug 1619317, ensure we set isWow64 to the correct value after taking it off the main thread

Beta/Release Uplift Approval Request

  • User impact if declined: We will be collecting incorrect telemetry numbers for our 32 bit users on 64 bit OS.
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): This implements a check that was missed in bug 1553546 when we moved this information off the main thread.
  • String changes made/needed: None
Flags: needinfo?(emalysz)
Attachment #9130458 - Flags: approval-mozilla-beta?
Type: task → defect

Comment on attachment 9130458 [details]
Bug 1619317, ensure we set isWow64 to the correct value after taking it off the main thread

approved for 75.0b2

Attachment #9130458 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
You need to log in before you can comment on or make changes to this bug.