Closed Bug 1619318 Opened 5 months ago Closed 5 months ago

The "X" button inside the cards is not focused while navigation with Tab key

Categories

(Firefox :: Protections UI, defect, P2)

75 Branch
defect

Tracking

()

VERIFIED FIXED
Firefox 76
Tracking Status
firefox-esr68 --- unaffected
firefox73 --- unaffected
firefox74 --- unaffected
firefox75 --- wontfix
firefox76 --- verified

People

(Reporter: ciprian_georgiu, Assigned: gaurijove)

References

(Blocks 1 open bug)

Details

(Keywords: access)

Attachments

(2 files)

Affected versions

  • latest Nightly 75.0a1

Affected platforms

  • Windows 10 x64
  • macOS 10.15
  • Ubuntu 18.04 x64

Steps to reproduce

  1. Launch Firefox and navigate to "about:protections".
  2. Navigate using the Tab key to the “X” button from the “Take your passwords everywhere” or “Block ad trackers across more devices” cards (to enable this last card you need to change the browser.contentblocking.report.show_mobile_app to true)

Expected result

  • The “X” button is focused.

Actual result

  • The “X” button cannot be focused; when reaching the iOS link from the card, it goes to the next button/link, skipping the close button.

Regression range

  • This doesn’t seem to be a regression, I was able to reproduce this on an older Nightly build as well, e.g 75.0a1 (2020-02-25); one of the first builds with these banners implemented.
Keywords: access

https://searchfox.org/mozilla-central/rev/2fd8ffcf087bc59a8e5c962965bbb7bf230bcd28/browser/components/protections/content/protections.html#226 and https://searchfox.org/mozilla-central/rev/2fd8ffcf087bc59a8e5c962965bbb7bf230bcd28/browser/components/protections/content/protections.html#119 should probably be a button, not a span. It should also get a localized string as the aria-label, or if these are trying to point to an element for a label, should use aria-labelledby.

Erica, is this something you could work on or perhaps mentor as a good first bug?

Flags: needinfo?(ewright)

Hi! May I submit a patch for this?

Assignee: nobody → gaurijove
Status: NEW → ASSIGNED
Attached image After the fix
Flags: needinfo?(ewright)

The priority flag is not set for this bug.
:ewright, could you have a look please?

For more information, please visit auto_nag documentation.

Flags: needinfo?(ewright)
Flags: needinfo?(ewright)
Priority: -- → P2

Bugbug thinks this bug is a regression, but please revert this change in case of error.

Keywords: regression

:gaurijove, since this bug is a regression, could you fill (if possible) the regressed_by field?
For more information, please visit auto_nag documentation.

Flags: needinfo?(gaurijove)
Keywords: regression
Flags: needinfo?(gaurijove)
Attachment #9132992 - Attachment description: Bug 1619318- Ensures "X" button is focused when navigating using Tab key. r=prathiksha → Bug 1619318- Ensures "X" button is focused when navigating using Tab key. r=Gijs
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/12948ea92335
Ensures "X" button is focused when navigating using Tab key. r=Gijs,fluent-reviewers
Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 76

The patch landed in nightly and beta is affected.
:gaurijove, is this bug important enough to require an uplift?
If not please set status_beta to wontfix.

For more information, please visit auto_nag documentation.

Flags: needinfo?(gaurijove)

Erica should make the call on that :)

Flags: needinfo?(gaurijove) → needinfo?(ewright)

Yes, let's uplift this. The mobile promotion has been pushed back, so we don't need to worry about that one for 75, however this patch also addresses the same issue for the Lockwise card, and that will be visible in 75.
On second thought, I realize there is a string in this, so it would be unfair to l10n to uplift. I'll let this ride the trains.

Flags: needinfo?(ewright)

I've managed to reproduce this issue on an affected Firefox nightly from 2020-03-02 on Ubuntu 18.04x64.
This issue is verified fixed on Firefox 76.0b4 using Windows 10x64, Ubuntu 18.04x64 and macOS 10.15.4.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.