Closed Bug 1619320 Opened 4 months ago Closed 28 days ago

[Form Autofill] Trying to save Credit Card details without having a Saved Address beforehand might lead to user confusion

Categories

(Toolkit :: Form Autofill, defect, P1)

defect

Tracking

()

VERIFIED FIXED
mozilla79
Tracking Status
firefox-esr68 --- wontfix
firefox75 --- wontfix
firefox76 --- disabled
firefox77 --- disabled
firefox78 --- disabled
firefox79 --- verified

People

(Reporter: emilghitta, Assigned: zbraniecki)

References

(Blocks 2 open bugs, Regression)

Details

(Keywords: regression, Whiteboard: [cc-autofill-mvp])

Attachments

(2 files)

Affected versions

  • Firefox 75.0a1 (BuildId:20200302094818)
    ( I think that this goes way back to the original implementation)

Affected platforms

  • Windows 10 64bit.
  • Ubuntu 18.04 64bit
  • macOS 10.14

Preconditions

  1. Launch Firefox and set the following prefs:
    extensions.formautofill.available pref to on
    extensions.formautofill.creditCards.available pref to true
  2. Make sure that you don’t have any Saved Addresses.

Steps to reproduce

  1. Access the about:preferences page.
  2. Click the Saved Credit Cards button.
  3. Populate the required fields and click the “Billing Address” option.

Expected result
At first glance, users might get confused of why they are not able to proceed with saving Credit Cards details. I’m not sure that there is enough information for users (The Learn More link doesn’t contain any information regarding the Saved Credit Cards option) to realize that they need to have a Saved Address beforehand.

I think that if no Billing Address is found, users should be pointed (somehow) to create/save one before trying to save credit card details.

Actual result

  • An empty dropdown menu is displayed. Dismissing the dropdown menu and clicking the “Save” button displays the “Please select an item in the list” tooltip for the Billing Address dropdown menu.

Regression Range

Luckily credit card autofill is off by default everywhre. Can we please stop testing it regularly? It's not useful for either of us to be spending time on these bugs.

The billing address shouldn't be required when adding via preferences IIRC. I think this may be a regression.

Type: enhancement → defect
Flags: needinfo?(emil.ghitta)
Priority: -- → P2

We've reassessed he CC autofill tests and de-preoritised them, so, in conclusion, we won't test them regularly anymore. Thanks Matt for your feedback!

Yes, you are right Matthew. This seems to be a regression.

I've ran mozregression in order to point out the exact regressor but mozregression kept skipping builds.

Pushlog: https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=221c18ebe962f68358b4cba927df9099ea935b40&tochange=2e3e89c9c68cd6b09d1853dc5426df3c04971c29

Possible regressor from the list: Bug 1480717

Also, as Cornel said in Comment 2 we have reassessed credit card autofill and removed it from our build validation radar for now.

Thanks!

Has Regression Range: --- → yes
Has STR: --- → yes
Flags: needinfo?(emil.ghitta)
Keywords: regression
Regressed by: 1480717

Won't fix for 75 because credit card autofill is off by default and won't impact normal users.

Blocks: 1527746

UX decided that for now we will hide this field from the management UI. Hiding it and adding the disabled attribute to the <select> should work.

Duplicate of this bug: 1390674
Assignee: nobody → gandalf
Status: NEW → ASSIGNED
Priority: P2 → P1
Attachment #9153983 - Attachment description: Bug 1619320 - Disable address field in Credit Card Entry. r?abr → Bug 1619320 - Disable address field in Credit Card Entry. r?abr,mattn
Pushed by zbraniecki@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/94f2fb2c3a94
Disable address field in Credit Card Entry. r=abr,MattN
Pushed by zbraniecki@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/9e5656ce62bc
Disable address field in Credit Card Entry. r=abr,MattN
Status: ASSIGNED → RESOLVED
Closed: 28 days ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla79
Flags: needinfo?(gandalf)
Whiteboard: [cc-autofill-mvp]

Verified - Fixed in latest Nightly 79.0a1 (build id: 20200615214838) using Windows 10 and Ubuntu 18.04. The Billing Address field is not displayed anymore.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.