Closed Bug 1619840 Opened 1 year ago Closed 11 months ago

Remove `fix_{linux,macosx}_stack.py` and `fix_stack_using_bpsyms.py`

Categories

(Toolkit :: Crash Reporting, task)

task
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla77
Tracking Status
firefox77 --- fixed

People

(Reporter: n.nethercote, Assigned: n.nethercote)

References

Details

Attachments

(1 file)

Once all uses are removed (in other bugs) the scripts themselves can be removed.

Depends on: 1177545
Depends on: 1604095
No longer depends on: 1604095
Summary: Remove `fix_{linux,macosx}_stack.py` → Remove `fix_{linux,macosx}_stack.py` and `fix_stack_using_bpsyms.py`
Duplicate of this bug: 1621467
Depends on: 1621468, 1622701

This commit removes test_fix_stack_using_bpsyms.py. That test can't easily be
modified to work with fix_stacks.py because it relies on internal
implementation details of fix_stack_using_bpsym.py. The unit testing done in
the fix-stacks repo provides test coverage that is as good or better.

Depends on D66918

Assignee: nobody → n.nethercote
Status: NEW → ASSIGNED
Pushed by nnethercote@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/94eb0aee220a
Remove `fix_{linux,macosx}_stack.py` and `fix_stack_using_bpsyms.py`. r=erahm
Status: ASSIGNED → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla77
You need to log in before you can comment on or make changes to this bug.