Closed Bug 1620102 Opened 2 years ago Closed 2 years ago

Add support for media.eme.require-app-approval

Categories

(GeckoView :: General, enhancement)

Unspecified
All
enhancement
Not set
normal

Tracking

(firefox76 fixed)

RESOLVED FIXED
mozilla76
Tracking Status
firefox76 --- fixed

People

(Reporter: rbarker, Assigned: rbarker)

References

Details

Attachments

(1 file)

When the pref media.eme.require-app-approval is enabled, gecko will prompt for permission before allowing access to EME media keys. GeckoView PermissionDelegate needs to be updated to handle this permission request.

Assignee: nobody → rbarker

Add GeckoSession.PermissionDelegate.PERMISSION_MEDIA_KEY_SYSTEM_ACCESS
for when media.eme.require-app-approval=true

Duplicate of this bug: 1524091
Pushed by rbarker@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/2b7446e9eca4
Add GeckoView support for EME Media key permissions r=geckoview-reviewers,agi,snorp
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla76
Regressions: 1640795
You need to log in before you can comment on or make changes to this bug.