Closed Bug 1620133 Opened 8 months ago Closed 2 months ago

Lack of parallelism when running MIDL in accessible/interfaces/ia1

Categories

(Firefox Build System :: General, task, P3)

task

Tracking

(firefox82 fixed)

RESOLVED FIXED
82 Branch
Tracking Status
firefox82 --- fixed

People

(Reporter: glandium, Assigned: glandium)

References

(Blocks 1 open bug)

Details

Attachments

(2 files)

There are two manual loops in accessible/interfaces/ia2/Makefile.in that make the MIDL calls serialized.

https://searchfox.org/mozilla-central/rev/c79c0d65a183d9d38676855f455a5c6a7f7dadd3/accessible/interfaces/ia2/Makefile.in#94-96,102-104

Maybe it's time to bite the bullet and try to move all the MIDL-related stuff out of Makefiles.

Priority: -- → P3
Blocks: 1646939

Bug 1645986 solved the problem for most generated files by moving their
rules to the top-level, but we're going to add rules that will end up in
subdirectories, so we have to solve the same problem again, in the
subdirectories.

Assignee: nobody → mh+mozilla
Status: NEW → ASSIGNED

The register rules are dropped at the same time because nothing
actually uses them.

Pushed by mh@glandium.org:
https://hg.mozilla.org/integration/autoland/rev/3f6d140abf16
Allow generated file rules to run in parallel in a given directory. r=firefox-build-system-reviewers,rstewart
https://hg.mozilla.org/integration/autoland/rev/478edcb2dc6e
Move MIDL handling to moz.build. r=firefox-build-system-reviewers,rstewart

Interestingly, this doesn't move the needle at all on native Windows builds...

Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → 82 Branch
Regressions: 1661739
You need to log in before you can comment on or make changes to this bug.