Open Bug 1620520 Opened 8 months ago Updated 3 days ago

Perma [tier 2] /webaudio/the-audio-api/the-pannernode-interface/panner-rolloff-clamping.html | X Panner distanceModel: "linear", rolloffFactor: 2 expected to be equal to the array [0,0.009438801556825638,0.02810869924724102,0.03424321487545967,0.

Categories

(Core :: Web Audio, defect, P5)

defect

Tracking

()

REOPENED

People

(Reporter: intermittent-bug-filer, Assigned: jgraham, NeedInfo)

References

(Regressed 1 open bug, Regression)

Details

(Keywords: intermittent-failure, leave-open, Whiteboard: [retriggered][stockwell unknown])

Attachments

(4 files)

Filed by: rmaries [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=291948180&repo=mozilla-central
Full log: https://firefox-ci-tc.services.mozilla.com/api/queue/v1/task/G83F74p4SJuq9iqKuP6-Cg/runs/0/artifacts/public/logs/live_backing.log


[task 2020-03-06T07:28:35.278Z] 07:28:35 INFO - TEST-START | /webaudio/the-audio-api/the-pannernode-interface/panner-rolloff-clamping.html
[task 2020-03-06T07:28:35.299Z] 07:28:35 INFO - Closing window 50
[task 2020-03-06T07:28:35.711Z] 07:28:35 INFO -
[task 2020-03-06T07:28:35.711Z] 07:28:35 INFO - TEST-PASS | /webaudio/the-audio-api/the-pannernode-interface/panner-rolloff-clamping.html | # AUDIT TASK RUNNER STARTED.
[task 2020-03-06T07:28:35.712Z] 07:28:35 INFO - TEST-PASS | /webaudio/the-audio-api/the-pannernode-interface/panner-rolloff-clamping.html | Executing "linear-clamp-high"
[task 2020-03-06T07:28:35.713Z] 07:28:35 INFO - TEST-PASS | /webaudio/the-audio-api/the-pannernode-interface/panner-rolloff-clamping.html | Audit report
[task 2020-03-06T07:28:35.714Z] 07:28:35 INFO - TEST-PASS | /webaudio/the-audio-api/the-pannernode-interface/panner-rolloff-clamping.html | > [linear-clamp-high] rolloffFactor clamping for linear distance model
[task 2020-03-06T07:28:35.715Z] 07:28:35 INFO - TEST-UNEXPECTED-FAIL | /webaudio/the-audio-api/the-pannernode-interface/panner-rolloff-clamping.html | X Panner distanceModel: "linear", rolloffFactor: 2 expected to be equal to the array [0,0.009438801556825638,0.02810869924724102,0.03424321487545967,0.049286145716905594,0.06121714785695076,0.07480449229478836,0.08126655220985413,0.10326724499464035,0.10609924048185349,0.12179718166589737,0.1385885775089264,0.14151552319526672,0.16106882691383362,0.1722015142440796,0.18278823792934418...] but differs in 2047 places:
[task 2020-03-06T07:28:35.715Z] 07:28:35 INFO - Index Actual Expected
[task 2020-03-06T07:28:35.716Z] 07:28:35 INFO - [1] 1.8877602769862278e-6 9.4388015568256378e-3
[task 2020-03-06T07:28:35.717Z] 07:28:35 INFO - [2] 5.6217400015157182e-6 2.8108699247241020e-2
[task 2020-03-06T07:28:35.717Z] 07:28:35 INFO - [3] 6.8486433519865386e-6 3.4243214875459671e-2
[task 2020-03-06T07:28:35.718Z] 07:28:35 INFO - [4] 9.8572290880838409e-6 4.9286145716905594e-2
[task 2020-03-06T07:28:35.719Z] 07:28:35 INFO - ...and 2043 more errors. - assert_true: expected true got false
[task 2020-03-06T07:28:35.720Z] 07:28:35 INFO - _logFailed/<@http://web-platform.test:8000/webaudio/resources/audit.js:52:18
[task 2020-03-06T07:28:35.721Z] 07:28:35 INFO - Test.prototype.step@http://web-platform.test:8000/resources/testharness.js:1956:25
[task 2020-03-06T07:28:35.722Z] 07:28:35 INFO - test@http://web-platform.test:8000/resources/testharness.js:548:30
[task 2020-03-06T07:28:35.722Z] 07:28:35 INFO - _logFailed@http://web-platform.test:8000/webaudio/resources/audit.js:51:9
[task 2020-03-06T07:28:35.723Z] 07:28:35 INFO - _finalize@http://web-platform.test:8000/webaudio/resources/audit.js:217:19
[task 2020-03-06T07:28:35.724Z] 07:28:35 INFO - _assert@http://web-platform.test:8000/webaudio/resources/audit.js:230:12
[task 2020-03-06T07:28:35.725Z] 07:28:35 INFO - beEqualToArray@http://web-platform.test:8000/webaudio/resources/audit.js:762:19
[task 2020-03-06T07:28:35.725Z] 07:28:35 INFO - runTest/<@http://web-platform.test:8000/webaudio/the-audio-api/the-pannernode-interface/panner-rolloff-clamping.html:91:35
[task 2020-03-06T07:28:35.727Z] 07:28:35 INFO - promise callbackrunTest@http://web-platform.test:8000/webaudio/the-audio-api/the-pannernode-interface/panner-rolloff-clamping.html:82:41
[task 2020-03-06T07:28:35.727Z] 07:28:35 INFO - @http://web-platform.test:8000/webaudio/the-audio-api/the-pannernode-interface/panner-rolloff-clamping.html:26:20
[task 2020-03-06T07:28:35.728Z] 07:28:35 INFO - run/<@http://web-platform.test:8000/webaudio/resources/audit.js:1195:27
[task 2020-03-06T07:28:35.729Z] 07:28:35 INFO - run@http://web-platform.test:8000/webaudio/resources/audit.js:1192:14
[task 2020-03-06T07:28:35.730Z] 07:28:35 INFO - run/<@http://web-platform.test:8000/webaudio/resources/audit.js:1341:34
[task 2020-03-06T07:28:35.731Z] 07:28:35 INFO - Test.prototype.step@http://web-platform.test:8000/resources/testharness.js:1956:25
[task 2020-03-06T07:28:35.732Z] 07:28:35 INFO - promise_test/tests.promise_tests</<@http://web-platform.test:8000/resources/testharness.js:605:36
[task 2020-03-06T07:28:35.732Z] 07:28:35 INFO - promise_test/tests.promise_tests<@http://web-platform.test:8000/resources/testharness.js:604:20
[task 2020-03-06T07:28:35.733Z] 07:28:35 INFO - promise callback
promise_test@http://web-platform.test:8000/resources/testharness.js:603:51
[task 2020-03-06T07:28:35.734Z] 07:28:35 INFO - run@http://web-platform.test:8000/webaudio/resources/audit.js:1341:21
[task 2020-03-06T07:28:35.736Z] 07:28:35 INFO - @http://web-platform.test:8000/webaudio/the-audio-api/the-pannernode-interface/panner-rolloff-clamping.html:95:13

Status: NEW → RESOLVED
Closed: 6 months ago
Resolution: --- → INCOMPLETE
Status: RESOLVED → REOPENED
Resolution: INCOMPLETE → ---
Regressed by: 1629065
Whiteboard: [retriggered]

Paul, this failed its two Linux 32-bit central runs and also a Try run which requested them: https://treeherder.mozilla.org/logviewer.html#?job_id=300819525&repo=mozilla-central
Can you check if this an actual issue with Linux 32-bit audio? https://hg.mozilla.org/mozilla-central/rev/1e43d1f6abdedc8fa02443c3d5c27deea5bcf428#l148.1 removed the expectation to see this failure but other platforms are unaffected.

Flags: needinfo?(padenot)
Summary: Perma tier 2 /webaudio/the-audio-api/the-pannernode-interface/panner-rolloff-clamping.html | X Panner distanceModel: "linear", rolloffFactor: 2 expected to be equal to the array [0,0.009438801556825638,0.02810869924724102,0.03424321487545967,0. → Perma Linux32 /webaudio/the-audio-api/the-pannernode-interface/panner-rolloff-clamping.html | X Panner distanceModel: "linear", rolloffFactor: 2 expected to be equal to the array [0,0.009438801556825638,0.02810869924724102,0.03424321487545967,0.
Flags: needinfo?(padenot)
Status: REOPENED → RESOLVED
Closed: 6 months ago4 months ago
Resolution: --- → INCOMPLETE
Summary: Perma Linux32 /webaudio/the-audio-api/the-pannernode-interface/panner-rolloff-clamping.html | X Panner distanceModel: "linear", rolloffFactor: 2 expected to be equal to the array [0,0.009438801556825638,0.02810869924724102,0.03424321487545967,0. → Perma [tier 2] /webaudio/the-audio-api/the-pannernode-interface/panner-rolloff-clamping.html | X Panner distanceModel: "linear", rolloffFactor: 2 expected to be equal to the array [0,0.009438801556825638,0.02810869924724102,0.03424321487545967,0.
Status: REOPENED → RESOLVED
Closed: 4 months ago3 months ago
Resolution: --- → INCOMPLETE
Status: RESOLVED → REOPENED
Resolution: INCOMPLETE → ---
Assignee: nobody → aryx.bugmail
Pushed by archaeopteryx@coole-files.de:
https://hg.mozilla.org/integration/autoland/rev/444e9c56eb28
set some webaudio wpt tests to fail on Linux 32-bit. r=karlt DONTBUILD
Status: REOPENED → RESOLVED
Closed: 3 months ago2 months ago
Resolution: --- → FIXED
Target Milestone: --- → 81 Branch
Status: RESOLVED → REOPENED
Keywords: leave-open
Resolution: FIXED → ---
Target Milestone: 81 Branch → ---
Pushed by csabou@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/605798bedb1b
Set some more webaudio wpts to fail. r=jgraham DONTBUILD
Backout by btara@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/b566377dad41
Backed out changeset 605798bedb1b for osc-basic-waveform related wpt failures DONTBUILD CLOSED TREE
Pushed by csabou@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/230239284bc2
Set some more webaudio wpts to fail. r=jgraham DONTBUILD
Whiteboard: [retriggered] → [retriggered][stockwell needswork:owner]
Regressions: 1660219

Please update the Linux 32-bit expectations for these webaudio failures.

Assignee: aryx.bugmail → nobody
Flags: needinfo?(james)

Argh these tests. They're still putting the actual failure in the test title. I've made an attempt at actually fixing things (somewhat) properly rather than just fixing up the metadata https://treeherder.mozilla.org/#/jobs?repo=try&tier=1%2C2%2C3&revision=29bc001f035912825897e3815a1a5cae2f23e361

The tests using audit.js were creating a test for each task, and then
a test for each assertion with the actual failure used as the test
name. This isn't really compatible with the design of testharness.js
which assumes that we get a consistent set of tests with invariant
titles.

This patch changes things so that asserts are run in the context of
the test for the top-level task, rather than as their own test. This
means each task provides one consistently-named subtest and we see
failures as assert failures in that task.

The compromise is that whereas before we would continue running later
asserts after the first failure we now no longer record results in the
same task.

Assignee: nobody → james

The expectation data for these linux1804-32-shippable test results was added and removed alternately across multiple wpt updates.

e.g.
removed https://hg.mozilla.org/integration/autoland/rev/a1b61f473ae085da625733319de5f1849408b02c#l131.12
added https://hg.mozilla.org/integration/autoland/rev/8692f8ad44b3ca14d0a7ef839af156b170fb5869#l48.12
[some other attempts to manually change data]
removed https://hg.mozilla.org/integration/autoland/rev/3f1068b2fb00a3e22c72d5d36c67e1749daeaf73#l126.12
added https://hg.mozilla.org/integration/autoland/rev/fd1885d37aa5171e6a9f12e09cc67c5617fede49#l162.12

This seems to suggest the update logic might not be idempotent.

Presumably the logic added to handle this kind of case for bug 1569559 is not kicking in because the expectations were not conditional on os == 'linux' and bits == 32. Manual attempts added the condition but didn't have the full correct test name string.

I wonder whether the wpt updates are adding the expectation data, when it doesn't exist, for all platforms rather than just linux1804-32-shippable because there were no results for the same test name on other platforms.

You need to log in before you can comment on or make changes to this bug.