Windows: non-admin user can't associate Mozilla with HTML files

VERIFIED DUPLICATE of bug 106933

Status

VERIFIED DUPLICATE of bug 106933
16 years ago
14 years ago

People

(Reporter: mentin, Assigned: bugs)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Windows: non-admin user can't associate Mozilla with his HTML files. 
When I tell Mozilla to associate itself with HTML files, Mozilla tries to write
to HKEY_CLASSES_ROOT registry. If I don't have admin rights, this silently fails.
Mozilla should instead write to user's registry -
HKEY_CURRENT_USER\Software\Classes. 

It would also be nice to have a check box that tells Mozilla do use user
registry instead of system one even when user has rights to change preferences
for all users.

Repro:
Start with IE as default browser.
Run Mozilla without admin priveleges. 
Open Edit\Preferences\Advances\System.
Check HTML documents.
Close Mozilla.
Double click HTML file

Result:
IE opens

Expected:
Mozilla opens
Bill, this looks like it should be yours....

Comment 2

16 years ago
Dup of bug 106933?
Related: bug 106933
looks like its the same bug

*** This bug has been marked as a duplicate of 106933 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 4

16 years ago
yep, see also bug 156383

v.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.