Closed Bug 1620688 Opened 2 years ago Closed 2 years ago

Restrict number of rebuilds when --all is passed

Categories

(Firefox Build System :: Try, enhancement)

enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1629039

People

(Reporter: catlee, Unassigned)

Details

When mach try is used with any "all" parameter, we should limit the number of rebuilds requested to 3. Right now developers are allowed to request up to 20 rebuilds, which is generally an abuse of the system.

we should also restrict total number of jobs we schedule on limited hardware (android-hw, osx, *-hw)

Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1629039
You need to log in before you can comment on or make changes to this bug.