biltema.se - pressing back button twice messes up menu frame

RESOLVED WORKSFORME

Status

()

Core
Document Navigation
RESOLVED WORKSFORME
16 years ago
10 years ago

People

(Reporter: Per Ångström, Assigned: Radha on family leave (not reading bugmail))

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1b) Gecko/20020809
BuildID:    20020809

After having used the dynamic menus to open a few different product categories,
pressing the back button twice will mess up the menu frame.

Reproducible: Always
Steps to Reproduce:
1. Open the home page.
2. Select "BIL" from the menu in the left column.
3. In the menu that unfolds, select "Bilreservdelar".
4. Select "Biltillbehör".
5. Press back button, and wait for the page to display.
6. Press back button again.

Actual Results:  The menu frame will lose its formatting, and non-US-ASCII
characters will display weirdly. The menu will not react on mouse clicks.

Expected Results: In Internet Explorer, pressing the back button a second time
will only update the menu frame, moving the bullet to the category that was
redisplayed after pressing the button the first time. I suppose Mozilla should
do the same.

See also: bug #132569, which covers a related problem that has now been solved.
-> History
Assignee: Matti → radha
Component: Browser-General → History: Session
QA Contact: asa → claudius
(Reporter)

Comment 2

16 years ago
I have made the observation that the broken menu frame looks similar to that in
bug #136336.

I'm setting OS to "All", since I can reproduce the problem in NS 7.0 on Windows 98.
OS: Linux → All
(Reporter)

Comment 3

16 years ago
I have found another web site that has the same problem with pressing the back
button after having used the menu: http://www.aeg.se/ 

Seen in 1.1b, build 20020830, and in Netscape 7.0.
shanjian, can you provide some input on the non-ascii charaters showing up?
(Reporter)

Comment 5

16 years ago
This looks more or less fixed in recent builds, at least the visual aspect. The
menu will still not react after using the Back button a couple of times, but
that might be another bug.

Resolving to WORKSFORME.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 6

16 years ago
It looks as if I was too hasty in resolving the bug. The minimal font-size made
me overlook the fact that the menu frame seems to switch from UTF-8 to some
other charset, making some extended-ASCII characters look weird (e.g. "ä" and "ö").

For an example, see VERKTYG, which has sub-items "Träarbete" and
"Verktygsförvaring", which turn into "Träarbete" and "Verktygsförvaring" upon
going back in history a couple of times.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
(Reporter)

Comment 7

11 years ago
When I revisit the Biltema site a few years later, I can't find the above-mentioned problem, although the site hasn't changed much. Resolving as FIXED.

Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.9a7pre) Gecko/2007072004 Minefield/3.0a7pre
Status: REOPENED → RESOLVED
Last Resolved: 16 years ago11 years ago
Resolution: --- → FIXED

Comment 8

11 years ago
If the actual fix is unknown, this should still be WORKSFORME.
Resolution: FIXED → WORKSFORME

Updated

10 years ago
Component: History: Session → Document Navigation
QA Contact: claudius → docshell
You need to log in before you can comment on or make changes to this bug.