Closed Bug 162108 Opened 18 years ago Closed 18 years ago

Saving complete webpage for offline viewing does not take account of imported style sheets

Categories

(SeaMonkey :: General, defect, minor)

x86
Windows XP
defect
Not set
minor

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 126309

People

(Reporter: tsewen, Assigned: Matti)

References

()

Details

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.1b) Gecko/20020721
BuildID:    2002072104

When saving a complete webpage, Mozilla seems to look for all constructs
containing a filename.  However, Mozilla does not look into the CSS, which may
inherit or import another stylesheet.  The resulting saved page, therefore, may
look drastically different from the original.

Reproducible: Always
Steps to Reproduce:
1.Go to http://www.westciv.com/style_master/academy/css_tutorial/
2.Save it as Web Page, Complete
3.Open the HTML file

Actual Results:  The resulting page looks nothing like the original.

Expected Results:  It should take account of the inherited stylesheet.

Within the HTML file...
<link rel="stylesheet" type="text/css" href="../../house/house.css" />

Within house.css.  Note @import.
/* Created using Style Master from Western Civilisation CSS1 { 47 379 708 448 } */
@import "real_house.css";

body {background-color: #f3f1f4;
font-family: Verdana, Helvetica, Arial, sans-serif;}
Note that all CSS pages should be scanned recursively for @import or similar
constructs.

*** This bug has been marked as a duplicate of 126309 ***
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.