incorrect characters shown (charset=SEN_850200_B)

VERIFIED WONTFIX

Status

MailNews Core
Internationalization
VERIFIED WONTFIX
16 years ago
10 years ago

People

(Reporter: Brant Gurganus, Assigned: Frank Tang)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.1b) Gecko/20020802
BuildID:    20020802

The incorrect charachers are shown in an email from mimetest@imc.org with a subject of "EM1.1.1" without the quotation marks.

Reproducible: Always

Steps to Reproduce:
1. Send an email to mimetest@imc.org with a subject of "EM1.1.1" or use the URL.
Actual Results:  
The message received displays incorrect characters.

Expected Results:  
The message should display the correct characters.

Sample message source:
From - Sun Aug 11 00:30:01 2002
X-UIDL: B0001717176.MSG
X-Mozilla-Status: 0001
X-Mozilla-Status2: 00000000
Return-path: <daemon@above.proper.com>
Received: from above.proper.com (unverified [208.184.76.45]) by UV-SERVER02.ultravision.net
 (Vircom SMTPRS 5.1.202) with ESMTP id <B0001717176@UV-SERVER02.ultravision.net> for <brantgurganus2001@cherokeescouting.org>;
 Sun, 11 Aug 2002 00:29:43 -0500
Received: by above.proper.com (8.11.6/8.11.3) id g7B5TWI10892;
	Sat, 10 Aug 2002 22:29:32 -0700 (PDT)
Date: Sat, 10 Aug 2002 22:29:32 -0700 (PDT)
Message-Id: <200208110529.g7B5TWI10892@above.proper.com>
From: mimetest-human@imc.org
To: Brant Langer Gurganus <brantgurganus2001@cherokeescouting.org>
MIME-Version: 1.0
Content-Type: text/plain; charset=SEN_850200_B
Subject: EM1.1.1

  EM1.1.1
	When receiving a MIME-message with character set SEN_850200_B the
	correct glyphs must be shown.


       This is swedish characters:

        LATIN CAPITAL LETTER A WITH RING ABOVE     ]
        LATIN CAPITAL LETTER A WITH DIAERESIS      [
        LATIN CAPITAL LETTER O WITH DIAERESIS      \
        LATIN SMALL LETTER A WITH RING ABOVE       }
        LATIN SMALL LETTER A WITH DIAERESIS        {
        LATIN SMALL LETTER O WITH DIAERESIS        |
To intl.  I don't see "SEN_850200_B" in the charset alias file, so we likely
have no support for that charset.

Brant, what is the canonical name for this charset?
Assignee: mscott → nhotta
Component: Attachments → Internationalization
QA Contact: trix → marina

Comment 2

16 years ago
  &charset SEN_850200_B
  &rem source: ECMA registry
  &alias iso-ir-10
  &alias FI
  &alias ISO646-FI
  &alias ISO646-SE
  &alias se

http://www.faqs.org/rfcs/rfc1345.html

http://www.nada.kth.se/~paf/MIME-tester.html

SEN_850200_B is a 7-bit version of ASCII, adapted for Swedish (three extra chars
in respective case). It is pretty obsolete (1980s) and is replaced by ISO-8859-1
since the mid 1990s.

http://www.nada.kth.se/sunet-mime/info-1.html (Swedish only) describes the 1994
recommendation to use 8-bit Latin-1 exclusively for Swedish internet messages.
Of course this is somewhat obsolete as well (Unicode will eventually replace
Latin-1), but reflects today's general usage.
(Reporter)

Comment 3

16 years ago
From the IANA registry at http://www.iana.org/assignments/character-sets:

Name: SEN_850200_B                                      [RFC1345,KXS2]
MIBenum: 35
Source: ECMA registry
Alias: iso-ir-10
Alias: FI
Alias: ISO646-FI
Alias: ISO646-SE
Alias: se
Alias: csISO10Swedish

Comment 4

16 years ago
Reassign to ftang.
Assignee: nhotta → ftang
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: incorrect characters shown → incorrect characters shown (charset=SEN_850200_B)
(Assignee)

Comment 5

16 years ago
this is a legecy charset which we don't and should not support. markt his bug as
won'tfix
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WONTFIX

Comment 6

15 years ago
verified
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.