Right-click Save As... on link ignores Content-Disposition header

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
16 years ago
13 years ago

People

(Reporter: justdave, Assigned: bugzilla)

Tracking

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

RFC2616 lists a Content-Disposition header which can be used to suggest a
filename for a downloaded file that might not necessarily match the filename on
the end of the URL used to retrieve it.  A good example of this is in Bugzilla
for attachments, since the URL used to access it is attachment.cgi.  When you
click a link normally, Mozilla honors the suggested filename from the
Content-Disposition header.  It you right-click on the link and choose Save As,
it's ignored, and you get a file save dialog with "attachment.cgi.html" in it
instead of the name of the attachment.  This Bugzilla doesn't have this feature,
this was discovered in a test installation trying out the implementation of bug
63601 for Bugzilla.  You can try it at
http://landfill.bugzilla.org/bz63601/show_bug.cgi?id=365 using the gzip
attachment on that bug.

Mac OS X CFM 2002071608

Comment 1

16 years ago
This is related to bug 65827, and probably a duplicate of that bug.
QA Contact: sairuh → petersen
I'll be ripping out all attempts to contact the server from the "save link as"
code; this will include our abortive (and doomed) attempt to do
content-disposition filenames.

If you can suggest a workable way of doing it, please do and it'll be considered.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WONTFIX
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.