Closed Bug 1621608 Opened 9 months ago Closed 9 months ago

The onboarding tip is quickly dismissed if about:newtab page is on focus and the browser is restarted

Categories

(Firefox :: Address Bar, defect, P1)

74 Branch
Desktop
All
defect

Tracking

()

RESOLVED WONTFIX
Tracking Status
firefox74 --- wontfix
firefox75 --- unaffected
firefox76 --- unaffected

People

(Reporter: vvalentina, Unassigned)

References

Details

Attachments

(1 file)

Attached image onboarding-tip.gif

[Affected versions]:

  • Firefox Release 74 Build ID 20200309095159;

[Affected Platforms]:

  • Windows 10;
  • Mac 10.14;
  • Linux Mint 18.03;

[Prerequisites]:

  • Have an “en-US” Firefox Release 74 build installed;
  • Have a profile created in the last 24 hours;
  • Firefox is opened and wasn't updated in the last 24 hours;
  • Have a Normandy testing recipe created and published for the Quantumbar V1 experiment;
  • “user.js” file is saved in the profile directory;
  • Google is the default search engine;
  • Be enrolled in the “treatment” branch;

[Steps to reproduce]:

  1. Open the Firefox browser with the profile from prerequisites.
  2. Navigate to about:newtab page and leave it on focus.
  3. Restart the browser.
  4. Observe the onboarding tip.

[Expected result]:

  • Onboarding tip is displayed. The tip is dismissed only after a direct interaction.

[Actual result]:

  • The onboarding tip is displayed for a moment and it's auto-dismissing without interacting with it.

[Notes]:

  • Issue is also reproducible if about:home, bing.com, google.com, duckduckgo.com and start.duckduckgo.com pages are in focus and corresponding search engines are set as default.
  • Issue is also reproducible for a Firefox 74 “de” locale build.
  • Issue is NOT reproducible on Firefox 75.0b1 and Nightly 76.0a1.
Points: --- → 3
Priority: -- → P1

We did some in depth investigations on this issue and it seems that it is only reproducible when restarting the browser using browser console. We haven't managed to reproduce the issue by closing the browser normally (using the "X" button).

However, this lead to another issue: the onboarding tip is displayed only after the Address Bar is clicked.
Considering this we will lower the severity of the bug and we will log a new issue for the described behavior.

Severity: critical → normal

not blocking 74 experiment. will be fixed for 75

I suspect this is not reproducible in 75 because bug 1619547 fixed the root cause. We're going to WONTFIX this for 74.

Status: NEW → RESOLVED
Closed: 9 months ago
Depends on: 1619547
Resolution: --- → WONTFIX
Points: 3 → ---
You need to log in before you can comment on or make changes to this bug.