Closed Bug 1621634 Opened 7 months ago Closed 5 months ago

Close/Restore buttons in full screen do not work

Categories

(Firefox :: Toolbars and Customization, defect)

74 Branch
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1631229

People

(Reporter: mvocom, Unassigned)

Details

Attachments

(2 files)

User Agent: Mozilla/5.0 (Windows NT 6.1; rv:74.0) Gecko/20100101 Firefox/74.0

Steps to reproduce:

Press F11.
Hover over the top to show the Close/Restore buttons.

Actual results:

Press Close or Restore.

Expected results:

The window is not closed or restored.

This is a regression in 74.

Steps to reproduce:

Press F11.
Hover over the top to show the Close/Restore buttons.
Press Close or Restore.

Actual results:

The window is not closed or restored.

This is a regression in 74.

Hi,
I was not able to reproduce this issue on Win7x64 with Firefox 74x64 and Win7x32 with Firefox 74x32.

Please test if the issue occurs in safe mode. Here is a link that can help you do that:
https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode

If the issue still persists, please test it using a new profile, you can find the steps to do that below:
https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles?redirectlocale=en-US&redirectslug=Managing-profiles#w_starting-the-profile-manager

If you still reproduce this issue can you please detail more:

  1. Did you use a Laptop or PC?
  2. What is your screen resolution?
  3. You were on a specific page with fullscreen?
Flags: needinfo?(mvocom)

Hello,

Testing it a bit more - the buttons do work intermittently.

Start FF.
Press F11.
Do NOT press the Minimize button but either Close or Restore.
If you do not encounter the problem, please close FF and try again.

New profile - the same behavior.
PC, 1360x768.
Any page.

Thank you.

Flags: needinfo?(mvocom)

This issue does not repro on my machines Win7 or Win10 on Firefox Release 74.
I am assigning a component to this issue in order to involve the development team and get an opinion on this. If it's not the correct component please feel free to change it to an appropriate one.

Thanks for the report.

Component: Untriaged → Toolbars and Customization

What Windows theme do you use? Can you provide a screenshot?

If you open the browser console before this happens, clear it, then reproduce the issue - after clicking these buttons and them not doing anything, do new errors appear in the browser console? Is there any visual feedback when clicking the buttons (do they appear pressed while the mouse button is pressed down) or no?

Flags: needinfo?(mvocom)

Gijs,

I could not have replied earlier.

I use Windows Classic theme but it happens with any theme.
No errors in the browser console.
On hovering, I get the expected hover state. On pressing, the Tabs and Navigation bars disappear; - back to full screen with no bars at the top.

Thank you.

Flags: needinfo?(mvocom)

I have no idea why these buttons would break intermittently. :-(

Can you provide a copy of your about:support info?

Flags: needinfo?(mvocom)
Attached file aboutSupport.txt
Flags: needinfo?(mvocom)

I'm very sorry, but can you post the raw data (use the "copy raw data" button) ? I don't speak Hebrew, so I cannot read most of the contents...

Flags: needinfo?(mvocom)
Attached file aboutSupport.txt

Sorry. :)

Thank you.

Flags: needinfo?(mvocom)

Itiel, any idea if this is anything to do with RTL-ness? You mentioned these buttons recently as needing to have the restore button inverted, but presumably this does not affect functionality?

Flags: needinfo?(itiel_yn8)

(In reply to :Gijs (he/him) from comment #11)

Itiel, any idea if this is anything to do with RTL-ness? You mentioned these buttons recently as needing to have the restore button inverted, but presumably this does not affect functionality?

It doesn't for me.
I tried testing on Windows 7 VM with Basic and Classic themes and couldn't reproduce.

Yaron, a few questions:

  1. Is that Windows the same you had in bug 1308674?
  2. Is the title bar enabled on your Firefox setup?
  3. How about drag space?
  4. Any Firefox theme installed?
  5. Is your Windows 7 in Hebrew?
  6. When press F11, is Firefox already maximized?
  7. Can you reproduce the same issue on a new profile?
  8. If so, can you run moz-regression[1] to check for a potential regressor?

[1] https://mozilla.github.io/mozregression/install.html

Flags: needinfo?(itiel_yn8) → needinfo?(mvocom)

Yaron, a few questions:

  1. Is that Windows the same you had in bug 1308674?

Yes, it is.

  1. Is the title bar enabled on your Firefox setup?
  2. How about drag space?

The title bar and drag space are usually not enabled, but the problem exists if they are.

  1. Any Firefox theme installed?
  2. Can you reproduce the same issue on a new profile?

No, but I use userChrome.css which is not the cause as I can reproduce the issue in a new profile.

  1. Is your Windows 7 in Hebrew?

Yes, it is.

  1. When press F11, is Firefox already maximized?

I can reproduce the issue in both states.

  1. If so, can you run moz-regression[1] to check for a potential regressor?

[1] https://mozilla.github.io/mozregression/install.html

This is a minor issue and I'd rather run moz-regression sometime in the future. Please don't mind. :)

Thank you for looking into it.

Flags: needinfo?(mvocom)

So, I have worked with Yaron on this privately to try and find ways to reproduce this and here it is:

  1. Don't be on Windows 10. See bug 1631229 comment 1 for why. Both Yaron and I managed to reproduce this on 2 different Windows 7, both were tested with Classic and Basic themes (although this may not have to be a factor).
  2. Hover the Restore window control button, wait for the "Restore" tooltip to appear.
  3. Click the Restore button.

Gijs, I feel like this should be duped over to bug 1631229 as the root for that bug is probably the cause for this one. Your call.

Flags: needinfo?(gijskruitbosch+bugs)

Yeah, that seems right. Thanks for digging into this!

Status: UNCONFIRMED → RESOLVED
Closed: 5 months ago
Flags: needinfo?(gijskruitbosch+bugs)
Resolution: --- → DUPLICATE
Duplicate of bug: 1631229
You need to log in before you can comment on or make changes to this bug.