Closed Bug 1621659 Opened 8 months ago Closed 5 months ago

[rel=preload] Remove preloads that have not been used after a timeout

Categories

(Core :: DOM: Core & HTML, enhancement)

enhancement
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1618921

People

(Reporter: mayhemer, Unassigned)

References

(Blocks 1 open bug)

Details

Part of Design documentation for rel=preload

Preloads that have not been used by any actual consumer (a tag or fetch) should be removed after timeout. Let's use a preferable timeout of 5 minutes, this is what Chrome is allegedly using.

Usage is marked by resource loaders by calling PreloadBase::NotifyUsage() method, as documented for PreloaderBase class.

Status: NEW → RESOLVED
Closed: 5 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1618921
You need to log in before you can comment on or make changes to this bug.