Import of a tab file doesn't match fields too good

VERIFIED WORKSFORME

Status

P3
major
VERIFIED WORKSFORME
19 years ago
14 years ago

People

(Reporter: esther, Assigned: chuang)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
While verifying Feature bug 10868, and using 19991012m11 builds on win32 the
import of a tab file doesn't match fields very well.
On windows when I saved a tab delimited file that was attached to a mail message
it Saved As a .txt file.  When I imported with 4.x I was prompted with
questions on how I want to map the Text values to the Communicator fields before
importing.  When imported the First Name (FN), Last Name (LN), Display Namd
(DN) and e-mail address appeared in the right place for the 4.7 abook.  In 5.0
the FN imported in the Display field, the LN imported in Last Name field (so
only the FN shows up in the Name column of the Address Book and the e-mail
address lands in the "Other" tab under Notes.
1. Launch Messenger
2. Select Address Book from the Tasks menu item
3. Select Import from the File menu item
4. Select the tab file that you want to import and click OK
5. Close Address Book
6. Reopen Address book
7. Select the Address book you just imported.

Result:  FN is listed under Name column and that's all you see in the results
pane.  If you select a card and click Edit, you will see that the FN landed in
the Display field, LN landed in the LN field and the e-mail landed in the Notes
field of the Options tab.
(Reporter)

Updated

19 years ago
QA Contact: lchiang → esther
(Reporter)

Comment 1

19 years ago
Whoops  forgot the Expected:
Expected the FN to map to the FN field, LN to map to LN field, FN+LN to map to
Display field and e-mail to map to e-mail field.
Maybe we need the same dialog that 4.x prompts asking how we want the text
values mapped.

Updated

19 years ago
Assignee: hangas → chuang

Comment 2

19 years ago
Sending to Candice

Comment 3

19 years ago
Move chuang bugs to after her sabbatical

Updated

19 years ago
Target Milestone: M13 → M15
(Reporter)

Comment 4

19 years ago
Using build 20000104 on win98, mac and linux this is fixed.  This bug was very
similiar to 10868, so it may have been fixed when that was fixed.  This bug was
tested by viewing an imported abook card (using Tab Delimited (.txt) exporting
format with 4.7) and checking the mapping of field entries.  I had filled in all
fields for the 4.7 card and the mapping to the new and different 5.0 card was
correct except URL was not mapped to Web Page.  This can be resolved as
duplicate of 10868 or as worksforme.
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WORKSFORME
(Assignee)

Comment 5

19 years ago
Mark it Workforme.
(Reporter)

Comment 6

19 years ago
Verified
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.