corrupted icon (of the first mozilla navigator window) in taskbar

VERIFIED DUPLICATE of bug 165744

Status

SeaMonkey
UI Design
--
minor
VERIFIED DUPLICATE of bug 165744
16 years ago
13 years ago

People

(Reporter: y_a_nickname, Assigned: jag (Peter Annema))

Tracking

Trunk
x86
Windows NT
Bug Flags:
blocking1.4a -
blocking1.5 -

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: DUPEME)

Attachments

(4 attachments)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.1b) Gecko/20020809
BuildID:    2002080918

The icon of my first mozilla navigator window is corrupted/incorrectly displayed.

Reproducible: Always
Steps to Reproduce:
1. Start mozilla 
2. compare the icon of the window (upper left corner of the display, correctly
shown) with the icon in the taskbar of Windows.
(Reporter)

Comment 1

16 years ago
Created attachment 94834 [details]
screen shot showing the problem

Updated

16 years ago
Whiteboard: DUPEME
do you only have a 256 color desktop? (looks like)
(Reporter)

Comment 3

16 years ago
256 colors: no, I just saved the screen shot at reduced color depth (to save
your download time). All other bitmaps, icons etc. are perfectly shown/drawn.

Comment 4

16 years ago
*** Bug 165134 has been marked as a duplicate of this bug. ***

Comment 5

16 years ago
a truecolor problem? See bug 164919

Comment 6

16 years ago
*** Bug 164919 has been marked as a duplicate of this bug. ***
Bug 164919 has a fix for this problem. See attachment 96870 [details]

Comment 8

16 years ago
resolving as new based on dups
Status: UNCONFIRMED → NEW
Ever confirmed: true
Created attachment 97596 [details]
This icon fixes this problem

This icon uses 256 colors instead of 16M. It fixes this problem under WinNT and
looks the same as the original one on other variants of Windows.

This file should be copied to
<MozillaHome>\chrome\icons\default\main-window.ico

Could someone please review it ?
(Reporter)

Comment 10

16 years ago
works perfectly for me, WinNT 4.0SP6, Gecko/20020826

Thanks a lot!

Comment 11

16 years ago
*** Bug 165382 has been marked as a duplicate of this bug. ***

Comment 12

16 years ago
*** Bug 165048 has been marked as a duplicate of this bug. ***

Comment 13

15 years ago
*** Bug 167904 has been marked as a duplicate of this bug. ***

Comment 14

15 years ago
The problem still exists for the final 1.2
Please fix this in 1.2.1
This bug has a fix. Attachment 97596 [details] fixes this problem (see comment #9 ). Can
we request a review for cheq-in ?

Comment 16

15 years ago
Bug still present in Mozilla 1.2.1
The above attached icon fixes the problem.

Comment 17

15 years ago
The problem is *not* solved by attachment 97596 [details].  The icons in the task-switch
bar (the one that appears under Windows when you press Alt-Tab) are still
corrupted.  I think that's because they are larger than the taskbar icons.

Comment 18

15 years ago
Forgot to mention: I have TrueColor.  The problem never occurs with the first
Navigator window.  It increases (more "speckles" in the icon) for each Navigator
window I open, also if I first close the other Navigator windows.  For example,
start Mozilla with browser and mailer.  Browser has perfect icon when
Alt-Tabbing.  Close browser.  Press Control-1 in mailer to open new browser. 
Icon of new browser has three corrupted pixels.  Close browser.  Press Control-1
in mailer to open new browser.  Icon of new browser has five corrupted pixels. 
And so on, and so on, ever more corrupted pixels.  I've tested this up to 25
corrupted pixels.  Don't know if I can get more.
Rotaluclac

Icons on Windows usually contain multiple image definitions embedded into the
same file. For example, the icon on attachment 97596 [details] has 32x32(256 clrs) and
16x16(256 clrs) images. Are you sure this icon does not solve the problem? It
did for me, and also for other people (see comment #10 )

You have to:

1) Download attachment 97596 [details]
2) Copy it over <MozillaHome>\chrome\icons\default\main-window.ico
3) Restart Mozilla

Also you can download and install an improved (more icons, and better
resolutions) version of mozilla Icons from 
http://grayrest.com/moz/resources/icons.shtml 

Comment 20

15 years ago
Yes, this icon fixes the original problem for me too.

The problem described in Comment #17 doesn't seem to be the same one to me.

It's a shame we missed release 1.3 for this: it's so ugly and so simple... I
should have found this bug page earlier. Please check it in ASAP! Thank you!
Flags: blocking1.4a?

Comment 21

15 years ago
Build 2003031808 on WinNT 4.0 SP5 (true color, show icons with highest possible
color)

Task bar icon for the first Mozilla Navigator window is still corrupted. But the
icons in the task-switch bar (the one that appears under Windows when you press
Alt-Tab) are all ok. 

Are there any reasons why this simple "patch" is not applied? (except lack of
time/manpower)

Comment 22

15 years ago
Daniel Mario (#19),

I downloaded the icons from grayrest.com, and now my problems have disappeared.
 Thanks.

(BTW, I added this comment, but I do not know whether buggiquette allows to use
a bug-reporting system as a discussion forum.)

Updated

15 years ago
Flags: blocking1.4a? → blocking1.4a-

Comment 23

15 years ago
Created attachment 118264 [details]
Icon with True color and 256 color in 32*32 and 16*16 versions.

The regular icon sems to have some sort of error in it, I haven't looked well
yet, but here's a version with 16 and 32 pixel versions in 256 AND true color
formats.

Comment 24

15 years ago
This new icon is fine for me (16 bits display). It works for both the taskbar
and the alt-tab menu. I have replaced the main-window icon by the one from the
download manager and the reported issue doesn't occur in that case either. I
mean that the main-window.ico *could* be the only broken one.

Comment 25

15 years ago
The new icon from comment 23 works perfectly for me (1600x1200 32 bit
TrueColor). It's the only one I've replaced. So please review it and check this in.

Comment 26

15 years ago
Reporter, can you also check if the last icon is also working as expected for you?
Thanks in advance!
The only problem I see with the last icon ( Attachment 118264 [details] ) is that its
format is different from the other mozilla icons.

Mozilla Icons are:

3638 bytes long with two images
16x16-256clr + 32x32-256clr

But the last icon ( Attachment 118264 [details] ) is

7782 bytes long with four images
16x16-256clr + 16x16-TrueColor + 32x32-356clr + 32x32-TrueColor

The first icon ( Attachment 97596 [details] ) has the same format as the ones thar come
with Mozilla

Comment 28

15 years ago
Grey Hodge,

Since you created the icon, can you please reply to comment #27? I hope you
don't mind I put your address in the Cc: list. (Is there another way I'd better
have used?)

Thank you again for your help!

Patrick

Comment 29

15 years ago
Created attachment 119911 [details]
Same as last icon, minus the true color formats. 256 color only

Thanks actually, I meant to CC myself previously.

Ok, I actually meant to include a true color version, as there was a slight
improvement, but here's a version without true color icons. It's the same byte
size, but there are binary differences. This one is 100% valid, to be perfectly
safe. Reporter: Try this, see if the problem persists.

Comment 30

15 years ago
I am still seeing this on 1.4RC1.  However, the icon in attachment 97596 [details] fixes
the problem for me.  Looks like it didn't get checked in.
Attachment #97596 - Flags: review?(sgehani)

Comment 31

15 years ago
Still happens on:

Mozilla 1.5b
Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.5b) Gecko/20030827

Solution described in Comment 19 fixes the problem.  Is there a reason that this
isn't getting checked in?
Flags: blocking1.5?

Comment 32

15 years ago
We need someone to make a quick review here and check it. Jag, can you help us
out? This won't block the release but drivers would consider an approval request. 
Assignee: sgehani → jag
Flags: blocking1.5? → blocking1.5-
Attachment #97596 - Flags: review?(sgehani) → review?(cls)

Updated

15 years ago
Attachment #97596 - Flags: review?(cls)

Comment 33

14 years ago
Ben, can you help with this?

Comment 34

14 years ago
WFM ... long time not noticed, tested with Mozilla 1.6 final and Mozilla 1.8a
build 2004042009 on WinNT 4.0 SP6 (true color, show icons with highest possible
color)
I think this this problem was solved with the checking for Bug 165744 . 

See
http://bonsai.mozilla.org/cvsquery.cgi?file=main-window.ico&who=neil%25parkwaycc.co.uk&date=all
Neil, could you please close this bug ? It was fixed by a patch you checked in
for bug 165744

Comment 37

14 years ago

*** This bug has been marked as a duplicate of 165744 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE

Updated

14 years ago
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.