Closed Bug 1621897 Opened 4 months ago Closed 4 months ago

Intermittent ValueError on mach try fuzzy

Categories

(Firefox Build System :: General, defect, P3)

defect

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: sg, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: in-triage)

Error running mach:

    ['try', 'fuzzy', '-q', 'linux', 'dom/localstorage/', 'dom/base/crashtests/']

The error occurred in code that was called by the mach command. This is either
a bug in the called code itself or in the way that mach is calling it.
You can invoke |./mach busted| to check if this issue is already on file. If it
isn't, please use |./mach busted file| to report it. If |./mach busted| is
misbehaving, you can also inspect the dependencies of bug 1543241.

If filing a bug, please include the full output of mach, including this error
message.

The details of the failure are as follows:

ValueError: Unterminated string starting at: line 1 column 864239 (char 864238)

  File "/home/simon/work/mozilla-unified/tools/tryselect/mach_commands.py", line 307, in try_fuzzy
    return self.run(**kwargs)
  File "/home/simon/work/mozilla-unified/tools/tryselect/mach_commands.py", line 177, in run
    return mod.run(**kwargs)
  File "/home/simon/work/mozilla-unified/tools/tryselect/selectors/fuzzy.py", line 397, in run
    push=push, closed_tree=closed_tree)
  File "/home/simon/work/mozilla-unified/tools/tryselect/push.py", line 144, in push_to_try
    display_push_estimates(try_task_config)
  File "/home/simon/work/mozilla-unified/tools/tryselect/push.py", line 119, in display_push_estimates
    make_trimmed_taskgraph_cache(graph_cache, dep_cache, target_file=target_file)
  File "/home/simon/work/mozilla-unified/tools/tryselect/util/manage_estimates.py", line 106, in make_trimmed_taskgraph_cache
    target_task_set = set(json.load(f).keys())
  File "/usr/lib64/python2.7/json/__init__.py", line 291, in load
    **kw)
  File "/usr/lib64/python2.7/json/__init__.py", line 339, in loads
    return _default_decoder.decode(s)
  File "/usr/lib64/python2.7/json/decoder.py", line 364, in decode
    obj, end = self.raw_decode(s, idx=_w(s, 0).end())
  File "/usr/lib64/python2.7/json/decoder.py", line 380, in raw_decode
    obj, end = self.scan_once(s, idx)

Re-running the same command worked again, though.

Keywords: in-triage

I can't reproduce unfortunately.

Is this intermittent or can you reliably produce this (and then fix it by running the same command again a second time)? If you can reliably reproduce this can you provide any more information? e.g. is this Linux, can you reproduce at central or only on some local changes you have, what file is that bit of the code trying to read from and what are the contents of that file, etc.

Status: NEW → RESOLVED
Closed: 4 months ago
Product: Firefox Build System → Taskcluster
Resolution: --- → WORKSFORME
Priority: -- → P3
Product: Taskcluster → Firefox Build System

(In reply to Ricky Stewart from comment #1)

I can't reproduce unfortunately.

Is this intermittent or can you reliably produce this (and then fix it by running the same command again a second time)? If you can reliably reproduce this can you provide any more information? e.g. is this Linux, can you reproduce at central or only on some local changes you have, what file is that bit of the code trying to read from and what are the contents of that file, etc.

As I wrote, it's intermittent and happened two or three times to me, and just retrying the same command made it go away. So unfortunately, I cannot reproduce it either.

You need to log in before you can comment on or make changes to this bug.