Closed Bug 1621953 Opened 5 months ago Closed 5 months ago

Chat button in tab toolbar has no disabled appearance

Categories

(Thunderbird :: Instant Messaging, defect)

Unspecified
macOS
defect
Not set
normal

Tracking

(thunderbird_esr68 fixed, thunderbird75 fixed)

RESOLVED FIXED
Thunderbird 76.0
Tracking Status
thunderbird_esr68 --- fixed
thunderbird75 --- fixed

People

(Reporter: clokep, Assigned: Paenglab)

Details

(Keywords: regression)

Attachments

(3 files)

The chat button in my toolbar doesn't seem to work. Clicking it does nothing. Clicking the calendar icon (to the right of it) brings up the calendar tab.

There's no errors in the console or anything else.

This is with 75b1, but I think it was broke in 74 also.

So how do people open the chat then? EDIT: I mean, looking at chat is part of testing. And we had chat broken on Mac for a while during TB 74 beta.

(In reply to Jorg K (GMT+1) from comment #1)

So how do people open the chat then? EDIT: I mean, looking at chat is part of testing. And we had chat broken on Mac for a while during TB 74 beta.

For me...I always leave the chat tab open so it is always just there.

It is also possible that I've customized / moved buttons or something and that has broken it. I find that to probably be unlikely though.

Magnus -- could we get someone to look at this?

Flags: needinfo?(mkmelin+mozilla)

Seems WFM for me, at least on trunk but also a 75a1 from 10 days back I tested. Tested linux. Could it be mac only?

Flags: needinfo?(mkmelin+mozilla)

Hmm, well, on Windows in TB 75 beta 1 the chat button opens the chat tab. I could also connect to Freenode's chat (since Mozilla's IRC is down).

Ah, there's more to this that I didn't notice. It seems to work fine unless you're on the calendar tab.

Hmm, when you're on the Calendar tab, there is no chat button by default that you can click.

When the main tab isn't active the Chat button is disabled. Something I already noted since long time. It's not visible when the button is in the main toolbar but, like I have too, when it's in the tab bar it's visible. Unfortunately because it's a badge-button the disable rule doesn't work on Mac.

Assignee: nobody → richard.marti

Removed the direct children selector > to let the rule apply also on badge-button toolbarbuttons which have additional layers. This is a Mac only issue.

Attachment #9133621 - Flags: review?(alessandro)
Attachment #9133621 - Flags: approval-comm-beta?

The same patch but for ESR.

Attachment #9133622 - Flags: approval-comm-esr68?

Richard -- first, thank you for taking a look at this! Do you know if this has always been an issue or did it regress at some point? (Feel free to rename this bug if I was wrong in the title!)

I can't say when this regressed. Maybe when the button was changed to a badge-button.

Summary: Chat button in toolbar no longer works → Chat button in tab toolbar has no disabled appearance
OS: Unspecified → macOS
Comment on attachment 9133621 [details] [diff] [review]
1621953-disabled-button.patch

Review of attachment 9133621 [details] [diff] [review]:
-----------------------------------------------------------------

I think this is fine as it disables the calendar button when necessary.
We might land this to quickly fix this issue, but the real issue is "why the chat button doesn't work when not in the main tab?"
Is there any technical reason behind the decision of not allowing users to access the chat if not from the main tab?
Maybe I'm missing something obvious, but it seems odd.
Attachment #9133621 - Flags: review?(alessandro) → review+

(In reply to Alessandro Castellani (:aleca) from comment #13)

We might land this to quickly fix this issue, but the real issue is "why the
chat button doesn't work when not in the main tab?"
It works when not in the main toolbar. The button disables when switching away from main tab. I asked a long time ago how to fix and found no solution. If you find it, great.

Status: NEW → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 76.0

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/eb262dce2275
Remove a direct children selector on the disabled toolbarbutton rule to make the chat button in tab toolbar look properly disabled. r=aleca DONTBUILD

Attachment #9133621 - Flags: approval-comm-beta? → approval-comm-beta+
Comment on attachment 9133622 [details] [diff] [review]
1621953-disabled-button-ESR.patch

Approved for ESR
Attachment #9133622 - Flags: approval-comm-esr68? → approval-comm-esr68+
You need to log in before you can comment on or make changes to this bug.