entering "p" or "t" in location bar makes moz think it's a protocol

RESOLVED DUPLICATE of bug 197990

Status

--
trivial
RESOLVED DUPLICATE of bug 197990
16 years ago
14 years ago

People

(Reporter: zarco.zwier, Assigned: hewitt)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1b)
Gecko/20020809 MultiZilla/v1.1.18
BuildID:    2002080918

when entering a "p" "p://www.pabo.nl/" is shown in the location bar or when
entering a "t"
ttp://tpl1.realtracker.com/netpoll/BannerLookup.asp?BannerID=-90053) is shown in
the location bar.

Reproducible: Always
Steps to Reproduce:
1.Go to the location bar
2.enter the letter t
or
1.Go to the location bar
2.enter the letter p


Actual Results:  letter p: "p://www.pabo.nl/"
letter t: ttp://tpl1.realtracker.com/netpoll/BannerLookup.asp?BannerID=-90053

Expected Results:  an url without the leading protocol

Comment 1

16 years ago
Confirming with a current CVS-trunk-build under Debian Linux. Couldn't find a
dupe, so marking NEW.

-> XP Apps:Autocomplete
Assignee: sgehani → hewitt
Status: UNCONFIRMED → NEW
Component: XP Apps → XP Apps: Autocomplete
Ever confirmed: true
OS: Windows 2000 → All
QA Contact: paw → claudius
Hardware: PC → All

Comment 2

16 years ago
This doesn't happen with Mac OS X.

Comment 3

16 years ago
i often mistakenly paste in a link as 
ttp://mozilla.org 
instead of 
htttp://mozilla.org

it would be great if mozilla could be a little bit smarter about handling
unknown protocols.  

Comment 4

15 years ago
looks like a dupe of bug 197990

When marking as dupe, comment that it works for "p" "p://www.pabo.nl/" too.
197990 only talks about "t" but the comments are more advance (discussion of
which pref options are needed to reproduce).

Comment 5

15 years ago

*** This bug has been marked as a duplicate of 197990 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.