Chatzilla doesnt start maximized

RESOLVED FIXED

Status

RESOLVED FIXED
17 years ago
14 years ago

People

(Reporter: aeroman10, Assigned: rginda)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: cz-patch)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.1) Gecko/20020810
BuildID:    2002081008

Chatzilla doesnt remember the window settings. It always starts with a small
window. Even after maximizing the window, the next time you open Chatzilla the
window is small again. Chatzilla should be modified to remember the window settings.

Reproducible: Always
Steps to Reproduce:
1. Open up chatzilla. The window is not maximized
2. Maximize the window
3. Close chatzilla
4. Open chatzilla. The window goes back to its original state.

Actual Results:  The window doesnt remember the maximized setting and goes back
to its original size.

Expected Results:  Window should stay the way it was before it was closed.

Comment 1

17 years ago
confirming, chatzilla saves all previous window sizes BUT maximized
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 2

16 years ago
Is there any updates on this. I understand that this is not really a problem but
its very annoying to keep maximizing the screen when you just want it to start
maximized in the first place.

Comment 3

16 years ago
But only on Windows.  It works fine on Linux.  What's the difference?
(Assignee)

Comment 4

16 years ago
http://lxr.mozilla.org/mozilla/source/xpfe/browser/resources/content/navigator.xul#57

Perhaps we need to add "sizemode" to our persist attribute.

Comment 6

16 years ago
Comment on attachment 117711 [details] [diff] [review]
patch

This patch works with 2003031714-trunk/WinXP.
Attachment #117711 - Flags: review?(rginda)
(Assignee)

Comment 7

16 years ago
Comment on attachment 117711 [details] [diff] [review]
patch

r=rginda
Attachment #117711 - Flags: review?(rginda) → review+
(Assignee)

Updated

16 years ago
Whiteboard: cz-patch
(Reporter)

Comment 8

16 years ago
Just downloaded version 1.4a Build: 2002040105 and the problem seems to be
fixed. The window now stays maximized every time chatzilla is opened.

Comment 9

16 years ago
-> FIXED
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
Product: Core → Other Applications
You need to log in before you can comment on or make changes to this bug.