Hyperlinks shown as plain text

VERIFIED DUPLICATE of bug 58917

Status

SeaMonkey
General
VERIFIED DUPLICATE of bug 58917
15 years ago
13 years ago

People

(Reporter: William Chi, Assigned: Matti)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0rc2)
Gecko/20020512 Netscape/7.0b1
BuildID:    20020512

There are links which fail to be rendered as links. Instead they are just shown
as plain text.

This can be reproduced by using HTML code as described below.

Reproducible: Always
Steps to Reproduce:
1. Create a hyper link.
2. Inside the <a></a> tags open a <font> section
3. Do not close the <font> with a </font>
4. Repeat 1-3 over 200 times.

The section would look like <a href="some link"><font>some text</a>
After 197 such links, further links will fail to be shown as links.

Actual Results:  As explained above, the links after the 197th link fail to be
shown as links.

Expected Results:  Previous version of netscape shwo all links properly.
important reminder : this markup is *totally* invalid anyway... For my personal
perspective, this bug is clearly INVALID or WONTFIX.

Comment 2

15 years ago
Right, and wrong.
Mozilla's Page Source displays the last working link and the next plain text as
the following:
<a href="ref_h-l.htm#91598" _base_target="display">
<font size="-1" face="Helvetica,Arial"> lowsrc
</font></a><font size="-1" face="Helvetica,Arial"><br>
<a href="ref_m-q.htm#175987" _base_target="display">
</a><font size="-1" face="Helvetica,Arial"> Math
<br>
</font>

Note that the a tag is closed before the font declaration. Now, the source of
that part _really_ is the following (confirmed using wget and IE):

<a href="ref_h-l.htm#91598">
<FONT SIZE=-1 FACE="Helvetica,Arial"> lowsrc
</a><BR>
<a href="ref_m-q.htm#175987">
<FONT SIZE=-1 FACE="Helvetica,Arial"> Math
</a><BR>

Looks like Mozilla breaks it itself and lies about the source. Tested using
trunk build 20002080807 on WinXP.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 3

15 years ago
Created attachment 94899 [details]
Very simple test case

This is a very simple html file I used to confirm the behaviour.

I agree that it is not valid markup and I find it ironic that I found it on a
netscape page. 

However the behaviour is inconsistent, either they should all be links, or none
of them should be, that is why I consider it a bug.

The other thing which is an issue is that rival browsers do not exhibit such
behaviour, and it would be a shame to have to use any other browser so that I
can view that page.
Dupe of bug 58917 via bug 145168 (which is this exact page)

*** This bug has been marked as a duplicate of 58917 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 5

15 years ago
Verified.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.