Plug-in not read correctly

RESOLVED DUPLICATE of bug 19118

Status

()

Core
Plug-ins
--
major
RESOLVED DUPLICATE of bug 19118
16 years ago
15 years ago

People

(Reporter: Byron, Assigned: rubydoo123)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
When viewing the url using Mozilla build 2002080108 the midi plug-in does not
work. Am using Cresendo 5.1 plug-in. The previous browser version that I was
using everything worked fine. The following shows a difference in how the HTML
source code is reads in Netscape Navigator 4.79 and Mozilla build 2002080108.

Netscape Navigator 4.79 source code up to the sound part shows:
<BASE HREF="http://www.ishaah.com/">
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">

<html>
<head>
        <title>~{ The Bonds of Friendship }~</title>
        <link rel="SHORTCUT ICON" href="http://www.ishaah.com/favicon.ico">
        <META HTTP-EQUIV="imagetoolbar" CONTENT="no">
        <SCRIPT LANGUAGE="JavaScript">

 
<!-- 
  function random() { 
    randomseed = (randomseed * randoma + randomc) % randomm; 
    return randomseed / randomm;
  } 
  var randomm = 714025; 
  var randoma = 4096; 
  var randomc = 150889; 
  randomseed = Date.parse(new Date()); 
  randomNumber = random() + ""; 

  var not_ns2 = false;
  if ((navigator.appVersion.indexOf ("2.0") == -1) 
       || (navigator.appName.indexOf("Netscape") == -1)) {
    not_ns2 = true;
  }
   var page = "www.ishaah.com";
  // var page = "www.ishaah.com" + window.location.pathname;
  var oasurl = "http://ads.euniverseads.com/RealMedia/ads/";
  var imageurl = oasurl + "adstream_jx.cgi/" + page + "/1"; 
  var clickurl = oasurl + "click_nx.cgi/" + page + "/1"; 

  function oas_ad(pos) {
    var rand = randomNumber.substring(2,11);
    document.write ("<SCRIPT language='JavaScript1.1' SRC='" + imageurl + '@' +
pos + '?' + rand + "'></XMP><PRE><B>&lt;<FONT SIZE=+0
COLOR="#551A8B">/SCRIPT</FONT>&gt;</B>");

  }
// --> 
<B>&lt;<FONT SIZE=+0 COLOR="#551A8B">/SCRIPT</FONT>&gt;</B> 
 <B>&lt;<FONT SIZE=+0 COLOR="#551A8B">SCRIPT</FONT> SRC=</B><FONT SIZE=+0
COLOR="003E98">"/artis1.js"</FONT><B>&gt;</B></PRE><XMP>

</SCRIPT>
 <style>
<!--
BODY{
scrollbar-face-color:#D3CA7D;
scrollbar-arrow-color:#EFCE6D;
scrollbar-track-color:#D3CA7D;
scrollbar-shadow-color:#EFCE6D;
scrollbar-highlight-color:#DEAB33;
scrollbar-3dlight-color:#DEAB33;
scrollbar-darkshadow-Color:#EFCE6D;
}
-->
</style>
<script language="VBScript" src="cres.vb">

</script>
<script language="JavaScript" src="cres.js">

</script>
</head>
<body ondragstart="return false" onselectstart="return false"
background="/backgrounds/yellowbudbkg.jpg" bgcolor="#639969" text="#E3B33A"
link="#63BC9B" alink="#EFA367" vlink="#DEAB33"> 
<img src="http://www2.flowgo.com/images/bt/trans.gif?page_id=38230" width="1"
height="1"> 
<EMBED SRC='/Sound/epologue.mid'PLUGINSPAGE='http://www.liveupdate.com/dl.html'
HEIGHT=16 WIDTH=16></P><BR><BR>
<DIV align="center"><UL>
<TABLE width="630" background="/backgrounds/goldgradbkg4.jpg" bgcolor="#D3CA7D"
border="1" bordercolor="#000000" cellpadding="15" cellspacing="0">
        <TR>
                <TD align="center">
                        <TABLE width="600"
background="/backgrounds/yellowbudbkg3.jpg" bgcolor="#FFFFFF" border="0"
cellpadding="0" cellspading="0">
                                <TR>
                                        <TD align="center">
******************************************************************************

The Mozilla source code up to the sound part shows:
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">

<html>
<head>
	<title>~{ The Bonds of Friendship }~</title>
	<link rel="SHORTCUT ICON" href="http://www.ishaah.com/favicon.ico">
	<meta HTTP-EQUIV="imagetoolbar" CONTENT="no">
	<script LANGUAGE="JavaScript"> 
<!-- 
  function random() { 
    randomseed = (randomseed * randoma + randomc) % randomm; 
    return randomseed / randomm;
  } 
  var randomm = 714025; 
  var randoma = 4096; 
  var randomc = 150889; 
  randomseed = Date.parse(new Date()); 
  randomNumber = random() + ""; 

  var not_ns2 = false;
  if ((navigator.appVersion.indexOf ("2.0") == -1) 
       || (navigator.appName.indexOf("Netscape") == -1)) {
    not_ns2 = true;
  }
   var page = "www.ishaah.com";
  // var page = "www.ishaah.com" + window.location.pathname;
  var oasurl = "http://ads.euniverseads.com/RealMedia/ads/";
  var imageurl = oasurl + "adstream_jx.cgi/" + page + "/1"; 
  var clickurl = oasurl + "click_nx.cgi/" + page + "/1"; 

  function oas_ad(pos) {
    var rand = randomNumber.substring(2,11);
    document.write ("<SCRIPT language='JavaScript1.1' SRC='" + imageurl + '@' +
pos + '?' + rand + "'></SCRIPT>");

  }
// --> 
</SCRIPT> 
 <script SRC="/artis1.js"></SCRIPT>
 <style>
<!--
BODY{
scrollbar-face-color:#D3CA7D;
scrollbar-arrow-color:#EFCE6D;
scrollbar-track-color:#D3CA7D;
scrollbar-shadow-color:#EFCE6D;
scrollbar-highlight-color:#DEAB33;
scrollbar-3dlight-color:#DEAB33;
scrollbar-darkshadow-Color:#EFCE6D;
}
-->

</style>
<script language="VBScript" src="cres.vb"></script>
<script language="JavaScript" src="cres.js"></script>
</head>
<body ondragstart="return false" onselectstart="return false"
background="/backgrounds/yellowbudbkg.jpg" bgcolor="#639969" text="#E3B33A"
link="#63BC9B" alink="#EFA367" vlink="#DEAB33"> 
<img src="http://www2.flowgo.com/images/bt/trans.gif?page_id=38230" width="1"
height="1"> 
<script LANGUAGE="JavaScript">
<!-- 
PlaySong("/Sound/epologue.mid")
//--> 
</script></p><br><br>
<div align="center"><ul>
<table width="630" background="/backgrounds/goldgradbkg4.jpg" bgcolor="#D3CA7D"
border="1" bordercolor="#000000" cellpadding="15" cellspacing="0">
	<tr>
		<td align="center">
			<table width="600" background="/backgrounds/yellowbudbkg3.jpg"
bgcolor="#FFFFFF" border="0" cellpadding="0" cellspading="0">

				<tr>
					<td align="center">
 You will notice that in the Mozilla source code it reads everything the same
except when it comes to the sound. Netscape reads it as
"<EMBED SRC='/Sound/epologue.mid'PLUGINSPAGE='http://www.liveupdate.com/dl.html'
HEIGHT=16 WIDTH=16></P><BR><BR>" 
where Mozilla reads it as just
 "<!-- PlaySong("/Sound/epologue.mid")//--> "
I am using the same plug-in on both browsers. Like I said on a pervious Mozilla
build this plug-in worked fine. What has changed....??? Anyone have a
clue.....?? The only difference I see is how the sound source code is read.

Comment 1

16 years ago
WFM 2002-08-10-11 Mac OS X / Quicktime 6.

Netscape (but not Mozilla) loads the file http://www.ishaah.com/cres.js, which
contains the embed statement.

Comment 2

16 years ago
not a blocker
Severity: blocker → major

Comment 3

16 years ago
wfm using build 2002080908 on Win2k (trunk) + QT6. btw, the broken Java applet
is a known JRE 1.4.x bug.
(Assignee)

Comment 4

16 years ago
WFM using QT6.0 and a current build.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 5

16 years ago
The works for me solution is OK....However I found a solution that allows me to
use the Cresendo Plug-in too. Upon looking at the dlls in the Plug-in folder I
found one that was in conflict with the Cresendo plug-in. In previous builds I
installed most of the Plug-in dlls from Netscape 4.79 plug-in folder. No
conflicts occured til build 2002080108 was installed. It seems that the
npaudio.dll (which can play midi & wav files) was overridding the Cresendo
dll(npMidi32.dll). Once I removed the npaudio.dll the Cresendo plug-in worked
fine. So taking a step from the last WFM I added the Quicktime 6.0 to the
browser plug-ins. Using the mime settings I set QT to play only wav files that
way Cresendo still works. So in esense either way works. The main reason for
using Cresendo is you can detach(float) the song playing. This allows you to
listen to the song while closing the web page you're viewing. Something that is
not possible with QT 6.0 or Netscape Audio plug-in. Another reason is you can
also set the Cresendo plug-in to play MP3's the same way so that you don't need
a file association with QT or any other plug-in to play them. So there are two
solutions to this problem now. Hopefully in the future someone can come up with
a solution to where any and all plug-ins work together without conflicts.
If you want to see how this works with the Cresendo plug-in installed go to this
 URL :  http://www.ishaah.com/Friendship.htm  (note this will play the midi) You
can also try this with the QT 6.0 installed with the mime setting set to play
midi's.
If you want to see how this works with the QT 6.0 plug-in installed go to this
URL :  http://www.coachb.net/igiveyou.htm  ( note this will play a wav )

A Note for Olivier: 
When I view http://www.ishaah.com/Friendship.htm I didn't get a broken applet
either with the previous build(2002080108) or the current build (2002081209)
that I'm using now. So there must be something else wrong with your build. It
may also be working for me cause I'm using the Java Plug-in 1.3.1_02 for
Netscape Navigator.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
(Assignee)

Comment 6

16 years ago
Hi Byron -- I do not understand your comment in regards to QT not being able to
work as a helper app -- I have been able to get that to happen, but it seems to
be dependent upon how the author constructs the object instance. Also, if the
mime type is not specificall picked for a particular plug-in, then I get the
open with dialog and the audio plays in a helper window.

I am unclear as to why you reopened the bug report, is it because there was a
conflict? That is something that is out of our control, especially if users
install plug-ins that our beyond the ones that are installed by default.
(Reporter)

Comment 7

16 years ago
Ok beppe. I guess you didn't read what I wrote close enough.  I didn't mention
that QT didn't work. It's just the function that Cresendo provides is missing
with QT. OQ 6.0 can play midi's and wav's but you have no ability to keep the
music that is playing once you close the viewed page. One thing I didn't mention
was that with this function you can save the music being play with Cresendo but
not QT. This was also a function you could get with Netscape 4.79 that used the
npaudio(LiveAudio) plug-in (it too can play both midi's and wav's). As it is now
I am using the QT plug-in to play audio/wav mimes and Cresendo to play
audio/midi mimes since there is now a conflict between the npaudio(LiveAudio)
and Cresendo plug-ins. Cresendo does provide a way to change this when using
Netscape 4.79 but for some reason it does not work for Mozilla. However since
installing the QT 6.0 plug-in the npaudio plug-in is completely disabled in
Netscape 4.79 so I lost the save function for audio/wav's. So I guess what I'm
trying to say it that the one gain (adding QT 6.0 plug-in)to make it work caused
a loss in the ability to save (a function provided by the npaudio(LiveAudio)
plug-in & Cresendo) music from web pages. If you have any suggestions let me know.

Comment 8

16 years ago
Disable LiveAudio and make sure Quicktime doesn't handle MIDI files (in the MIME
type section of the Quicktime prefs).

All downloaded Quicktime files reside in the cache folder, although it can be
hard to find (cache files are numbered and lack extensions).
(Assignee)

Comment 9

16 years ago
Byron: thank you very much, yes I indeed missed your point, but your most recent
post put sit all together. Let us do a bit more investigation to see what in the
heck is going on.
(Assignee)

Comment 10

16 years ago
Ok, I did some testing on this with win2K. I have QT6 installed and Cresendo 5.1
installed (http://www.liveupdate.com/freedownload.asp -- and selected the free
install). It works great! I even got the detach thing. Then, I uninstalled both
plug-ins and installed cresendo and then QT6. What is happening, at least from
my testing, is if I install cresendo first, making sure that I had both
checkmarks checked on the install (of associated mimetypes). Then installing
QT6, the defaults for QT walked over the cresendao install. So, I went to the QT
properties and unchecked the mimetypes I wanted cresendo to own, and again it
worked fine. So, it seems that the order of install is important (which I think
you already knew) and verifying that plug-ins installed after cresendo are not
in competition for the mimetypes. Some plug-ins, like QT6, are very aggresive in
grabbing mimetypes. At this point in time, the only resolution is to view About
Plugins and ensure that any plug-ins installed after cresendo are not in
conflict. If they are, then you will need to access the properties of that
plug-in and deselect the mimetype mapping (or even the opportunity during
install, unselect the options).

Specifying a particular mimetype to a particular plug-in is part of the plug-in
manager work that we will be doing. 

Byron: would this mapping function resolve your issue?
(Reporter)

Comment 11

16 years ago
Hi beppe...All I can say is WOW...!!! You did your homework for sure. Yes it's
very true as to how the order of the plug-ins are installed. Crescendo does a
good job explaining how to correct this by uninstalling and re-installing
certain dlls to make sure Cresendo becomes the default plug-in for the mime
types you want. 
http:/www.liveupdate.com/atlashelp.html (Making Crescendo the default plug-in
with Netscape) 
Yes it does resolve the mapping issue at this time. However as mentioned in my
last comment, the one function (saving the music to your hardrive)can not be
done when using QT 6.0. You can do this with the Crescendo(midi's, mp3's etc..or
whatever mime you choose to be associated with it upon installation) just fine
once you detach. In my comments I mentioned that you could do this when the
npaudio.dll(LiveAudio plug-in for playing the audio/wav & audio/midi mimes) was
installed. I know this is an old plug-in but it does provided that function. The
main problem with installing it in Mozilla(works fine in Netscape 4.79) is that
it no matter what you do it over takes the midi mime function from Crescendo. So
in order to be able to play the midi mime you have to unstall it in Mozilla and
have QT 6.0 take over the audio/wav mimes function. Now I'm not sure if there
was a separate install for the LiveAudio plug-in cause Netscape no longer lists
it as being available. So I can't see if it could be installed so that the
Cresecendo works like it should. In other words making sure which plug-in
handles the proper mimetypes. Now not to add any fuel to the fire but it seems
that the save music function is available for audio/wav mimes when
you...uhhhhhhhh.....use IE 5.0. It uses Windows Media player to accomplish this
even thou it is installed in Mozilla too it doesn't work with audio wav mimes
cause QT6.0 takes over. My problem is I hate IE to death except to view certain
pages cause Mozilla nor Netscape can handle them the way IE does. However this
is totally different problem that may have already been addressed or report as a
bug to Bugzilla.  

So to sum it all up it looks like the plug-in manager has some work to do.
Again thanks for your imput I hope that in the future the plug-in problem can be
solved in a logical manner. 
(Assignee)

Comment 12

16 years ago
At the risk of sounding really stupid -- I just need to focus on this one part,
and  if you can help walk me through it, then I think I'll get it. Are you
saying, that if you have a audio file playing in QT, using mozilla, you are not
given the obtion to save the audio to disk via the QT menu? This is where I got
lost. Since I have cresendo installed, QT6 does not get launched. So are you
saying to uninstall cresendo and play the audio via QT6 and while it is in QT6
try to save it?

To make this really easy on me and keep you from getting too frustrated, can you
give me step by step instructions? kind of like:
1. uninstall cresendo
2. access the web page
3. select the audio file (upper-left corner of page) and play in QT6
blah blah blah

if I can replicate your steps, then I can better annotate what we need to do in
our plug-in manager (which does not exsit yet by the way)
(Assignee)

Comment 13

16 years ago
So, I looked at this again. QT does not have the same feature set as cresendo,
so it wouldn't have the same function as to save to disk. The absence or
presence of features in a plug-in is up to the plug-in vendor.

However, being able to map a particular mimetype to a particular plug-in is
something we can control via the plug-in manager work (see bug 19118). I think
this bug should be duped against that one.
(Reporter)

Comment 14

16 years ago
Ut Oh..ok beppe. Am not getting frustrated just trying to tell you my observations.
I think I explained too much. I'll try to put in simple step so you understand
what I mean.

1.In Mozilla 1.1b with the Crescendo plug-in and QT 6.0 installed here is what
you can and can not do.
   A. You can save music(audio/midi's) with Crescendo being the default midi
mime player.
   B. You can listen but not save music (audio/wav's) with QT 6.0 being the
default audio/wav mime player. With it installed there is no function when you
right click on it to detach like Crescendo. Let alone save. 

2. In Netscape 4.79 with Crescendo plug-in(to play audio/midi mimes) installed
and the LiveAudio-npaudio.dll plug-in(to play audio/wav mimes) a function to
save is available with a right click on the player( which is displayed on the
page usually at or near the bottom).
   A. When using both plug-ins the order they are in determines how they
function since LiveAudio can also play audio/midi mimes.
   B. If there is a conflict Crescendo provides you with a way to correct it.
   C. QT 6.0 is installed too but the above functions(mime settings)are disabled.
   D. LiveAudio was included with the plug-ins that came with Netscape 4.x
3. In Mozilla 1.1b with Crescendo and LiveAudio plug-ins installed and QT 6.0
diabled so that it doesn't play audio/midi or aduio/wav mimes (cause you still
need QT to view QT moives).
   A. LiveAudio takes over all play back...overridding Crescendo no matter what
you try to do. 
   B. You can uninstall and re-install like is says on the page I sent in the
last comment all you want. LiveAudio still takes over.

4. In Mozilla 1.1b with Crescendo, QT 6.0 plug-ins installed and LiveAudio
installed.
    A. You can play audio/midi mimetypes and save thru Crescendo.
    B. You can not play audio/wav mimetypes period. Let alone try to save.
    C. In order to correct this you have to remove the LiveAudio                    
    npaudio.dll(from the plug-ins folder) so that audio/wav mimetypes 
    can be played by QT6.0.
    D. Once this is done you can listen audio/wav mimes thru QT 6.0 but no save
function available.
    E. Since there is no way to separately install the LiveAudio plug-in I could
       not see if I could disable it to just play audio/wav mimetypes.

5. An observation was made using IE 5.0. with all it's cute toys installed
(Windows Media player in particular)
    A. You can listen audio/midi mimetypes but not save.
    B. You can listen to audio/wav mime types and save them thru a right click.
    C. If you want to see how this works just go to these web pages:
       http://www.coachb.net/igiveyou.htm  (for the wav mime)
       http://www.ishaah.com/Friendship.htm (for the midi mime)
So I hope this little step by step explaination helps. Let me know ok.

Oh boy I wonder if the person who gets the assignment as plug-in manager knows
what he/she is walking into.
(Reporter)

Comment 15

16 years ago
Hi beppe..Your comment came in just as I was answering the last one. I looked at
the bug you mentioned and somewhat agree. The original report did mention some
of the same problems we have been looking at but almost 3 yrs ago. It is a
discussion about a Plug-in Manager. I think some of them went off in many
diverse directions when addressing it. It boils down to who has control over how
the plug-ins are managed and how they function. You or the vendor. In that case
then a Plug-in Manager would work great. Although that would leave the plug-in
vendors off the hook. They could develop products and then let the end user play
with how it functions leaving the browser developer a long list of problems to
solve. Or they could develop products where the end user only had to follow a
required setup procedure allowing the user the opportunity to go back and make
changes. QT 6.0 does in a sense do this to a point. Once this is done the amount
of plug-ins required might be reduced to just a few instead of a few dozen to
allow a browser to do or view many things. Let's see where this goes and leave
this bug open. Maybe someone will read this and have a clear cut way to resolve
this type of problem while waiting for someone to come up with a plug-in
manager. OK 
(Assignee)

Comment 16

15 years ago
the remaining issue here will be easily resolved witht he plug-in manager, so I
am marking this as a dup of bug 19118 -- the user will be able to map a media
type to a particular plug-in

*** This bug has been marked as a duplicate of 19118 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.