Closed Bug 1622642 Opened 5 months ago Closed 2 months ago

Cannot edit existing Contact info when selecting a contact from All Address Books.

Categories

(Thunderbird :: Address Book, defect)

x86_64
All
defect
Not set
normal

Tracking

(thunderbird75 affected, thunderbird78 fixed)

RESOLVED FIXED
Thunderbird 76.0
Tracking Status
thunderbird75 --- affected
thunderbird78 --- fixed

People

(Reporter: NoJoyInDelay, Assigned: darktrojan)

References

Details

(Keywords: regression)

Attachments

(2 files)

User Agent: Mozilla/5.0 (Windows NT 6.1; rv:75.0) Gecko/20100101 Firefox/75.0

Steps to reproduce:

  1. Create a Contact, and save - this works
  2. Open Contact and attempt to make a change in the Contact info
  3. Close
  4. Reopen the Contact and the modifications are missing

Actual results:

Any changes to the Contact info are not updated after closing and re-opening Contact.

Expected results:

As in previous versions, any changes or modifications should be saved.

I cannot reproduce this using 75 beta.

Do you see anything in tools > error console?

Flags: needinfo?(NoJoyInDelay)

Thanks for the reply. When open an existing Contact, any edits are NOT saved. From my Error Console...

Error #1 --- On opening TB, I received the following error ...

[Exception... "Component returned failure code: 0x80520001 (NS_ERROR_FILE_UNRECOGNIZED_PATH) [nsIXPCComponents_Utils.readUTF8URI]" nsresult: "0x80520001 (NS_ERROR_FILE_UNRECOGNIZED_PATH)" location: "JS frame :: resource://gre/modules/L10nRegistry.jsm :: L10nRegistry.loadSync :: line 761" data: no] L10nRegistry.jsm:761:19

Error #2 --- When I open a Contact and edit the any Contact info, such as telephone, other field, etc, I receive the following error ...

TypeError: directory is null abCard.js:326:11
OnLoadEditCard chrome://messenger/content/addressbook/abCard.js:326
onload chrome://messenger/content/addressbook/abEditCardDialog.xhtml:1
goEditCardDialog chrome://messenger/content/addressbook/abCommon.js:796
AbEditCard chrome://messenger/content/addressbook/abCommon.js:533
AbEditSelectedCard chrome://messenger/content/addressbook/abResultsPane.js:302
doCommand chrome://messenger/content/addressbook/abResultsPane.js:522
goDoCommand chrome://global/content/globalOverlay.js:101
oncommand chrome://messenger/content/addressbook/addressbook.xhtml:1

[Learn More] on error code # 2147942487 === https://developer.mozilla.org/en-US/docs/Web/JavaScript/Reference/Errors/Unexpected_type?utm_source=mozilla&utm_medium=firefox-console-errors&utm_campaign=default

Thanks again for your reply.

Flags: needinfo?(NoJoyInDelay)

Recent update to TB 75.0b2 still does not save edit changes to Contact info. And it now only produced one error message on TB startup, no errors after a change attempt. Here is the single error...

[Exception... "Component returned failure code: 0x80520001 (NS_ERROR_FILE_UNRECOGNIZED_PATH) [nsIXPCComponents_Utils.readUTF8URI]" nsresult: "0x80520001 (NS_ERROR_FILE_UNRECOGNIZED_PATH)" location: "JS frame :: resource://gre/modules/L10nRegistry.jsm :: L10nRegistry.loadSync :: line 761" data: no]
L10nRegistry.jsm:761:19
loadSync resource://gre/modules/L10nRegistry.jsm:761
fetchFile resource://gre/modules/L10nRegistry.jsm:676
generateResourceSetSync resource://gre/modules/L10nRegistry.jsm:581
map self-hosted:251
generateResourceSetSync resource://gre/modules/L10nRegistry.jsm:576
generateResourceSetsForLocaleSync resource://gre/modules/L10nRegistry.jsm:412
InterpretGeneratorResume self-hosted:1156
next self-hosted:1111
generateBundlesSync resource://gre/modules/L10nRegistry.jsm:174
InterpretGeneratorResume self-hosted:1156
next self-hosted:1111
touchNext resource://gre/modules/Localization.jsm:167
onChange resource://gre/modules/Localization.jsm:500
Localization resource://gre/modules/Localization.jsm:227
<anonymous> chrome://messenger/content/mailWidgets.js:40
<anonymous> chrome://messenger/content/customElements.js:34
<anonymous> chrome://messenger/content/customElements.js:37
observe resource://gre/modules/MailGlue.jsm:200

Thank you for the follow up.

Component: Untriaged → Address Book

I can't reproduce using 75.0b1 or after updating to 75.0b2.

Name Thunderbird
Version 75.0b2
Build ID 20200325160228
OS Linux 4.15.0-91-generic
Ubuntu 18.04.4 LTS

I was able to reproduce this in 75.0beta on Windows 10 and Linux with the following steps.

  1. Select All Address Books in the Directory Pane.
  2. Open a contact and do some editing.
  3. Close the contact and the changes don't appear in the contacts Contact Pane view or when reopening the contact.

I don't see any error messages in my Error Console after doing this procedure.

I was successfully able to edit and save the changes by selecting the address book the contact is in from the Directory Pane.
I can successfully edit and see the changes in the Contact Pane view using All Address Books in Thunderbird 68.6.0.

Reporter do you have All Address Books selected? Does it work for you if you select the address book the contact is in?

Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(NoJoyInDelay)
Keywords: regression
OS: Unspecified → All
Hardware: Unspecified → x86_64

Thanks WaltS48 [:walts48], it works as follows.

  1. Open Contact pane with "All Address Books"

  2. Select "Personal Address Book"

  3. Open Contact, edit contact info, close and reopen --- Yes, edits correctly appear.

It is a good work around. Thanks

BTW, I running Windows7 Ultimate 32-bit.

Flags: needinfo?(NoJoyInDelay)

I selected "all".

Duplicate of this bug: 1626039
Summary: Cannot edit existing Contact info, any info → Cannot edit existing Contact info when selecting a contact from All Address Books.

This code was passing the selected address book to the dialog, instead of the contact's actual address book. When the selected address book is completely imaginary, of course it's going to break. :-/

Assignee: nobody → geoff
Status: NEW → ASSIGNED
Attachment #9136941 - Flags: review?(mkmelin+mozilla)
Comment on attachment 9136941 [details] [diff] [review]
1622642-edit-card-uri-1.diff

Review of attachment 9136941 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM, r=mkmelin
Attachment #9136941 - Flags: review?(mkmelin+mozilla) → review+

Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/d723075a0454
Pass correct address book URI to edit card dialog. r=mkmelin

Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 76.0

Same Address Book issue now with TB 77.0b3 (32-bit), here is the Error Report ...

[Exception... "Component returned failure code: 0x80520001 (NS_ERROR_FILE_UNRECOGNIZED_PATH) [nsIXPCComponents_Utils.readUTF8URI]" nsresult: "0x80520001 (NS_ERROR_FILE_UNRECOGNIZED_PATH)" location: "JS frame :: resource://gre/modules/L10nRegistry.jsm :: L10nRegistry.loadSync :: line 658" data: no] L10nRegistry.jsm:658:19
loadSync resource://gre/modules/L10nRegistry.jsm:658
fetchFile resource://gre/modules/L10nRegistry.jsm:573
generateResourceSetSync resource://gre/modules/L10nRegistry.jsm:478
map self-hosted:240
generateResourceSetSync resource://gre/modules/L10nRegistry.jsm:473
generateResourceSetsForLocaleSync resource://gre/modules/L10nRegistry.jsm:415
InterpretGeneratorResume self-hosted:1151
next self-hosted:1099
generateBundlesSync resource://gre/modules/L10nRegistry.jsm:177
InterpretGeneratorResume self-hosted:1151
next self-hosted:1099
touchNext resource://gre/modules/Localization.jsm:167
regenerateBundles resource://gre/modules/Localization.jsm:552
activate resource://gre/modules/Localization.jsm:243
<anonymous> chrome://messenger/content/mailWidgets.js:37
<anonymous> chrome://messenger/content/customElements.js:34
<anonymous> chrome://messenger/content/customElements.js:37
observe resource://gre/modules/MailGlue.jsm:208
[Exception... "Component returned failure code: 0x80520001 (NS_ERROR_FILE_UNRECOGNIZED_PATH) [nsIXPCComponents_Utils.readUTF8URI]" nsresult: "0x80520001 (NS_ERROR_FILE_UNRECOGNIZED_PATH)" location: "JS frame :: resource://gre/modules/L10nRegistry.jsm :: L10nRegistry.loadSync :: line 658" data: no] L10nRegistry.jsm:658:19
loadSync resource://gre/modules/L10nRegistry.jsm:658
fetchFile resource://gre/modules/L10nRegistry.jsm:573
generateResourceSetSync resource://gre/modules/L10nRegistry.jsm:478
map self-hosted:240
generateResourceSetSync resource://gre/modules/L10nRegistry.jsm:473
generateResourceSetsForLocaleSync resource://gre/modules/L10nRegistry.jsm:415
InterpretGeneratorResume self-hosted:1151
next self-hosted:1099
generateBundlesSync resource://gre/modules/L10nRegistry.jsm:177
InterpretGeneratorResume self-hosted:1151
next self-hosted:1099
touchNext resource://gre/modules/Localization.jsm:167
regenerateBundles resource://gre/modules/Localization.jsm:552
activate resource://gre/modules/Localization.jsm:243
<anonymous> resource:///modules/calendar/calCalendarDeactivator.jsm:10
<anonymous> chrome://calendar/content/calendar-chrome-startup.js:25
[Exception... "Component returned failure code: 0x80520001 (NS_ERROR_FILE_UNRECOGNIZED_PATH) [nsIXPCComponents_Utils.readUTF8URI]" nsresult: "0x80520001 (NS_ERROR_FILE_UNRECOGNIZED_PATH)" location: "JS frame :: resource://gre/modules/L10nRegistry.jsm :: L10nRegistry.loadSync :: line 658" data: no] L10nRegistry.jsm:658:19
loadSync resource://gre/modules/L10nRegistry.jsm:658
fetchFile resource://gre/modules/L10nRegistry.jsm:573
generateResourceSetSync resource://gre/modules/L10nRegistry.jsm:478
map self-hosted:240
generateResourceSetSync resource://gre/modules/L10nRegistry.jsm:473
generateResourceSetsForLocaleSync resource://gre/modules/L10nRegistry.jsm:415
next self-hosted:1099
generateBundlesSync resource://gre/modules/L10nRegistry.jsm:177
next self-hosted:1099
touchNext resource://gre/modules/Localization.jsm:167
regenerateBundles resource://gre/modules/Localization.jsm:552
activate resource://gre/modules/Localization.jsm:243
<anonymous> resource:///modules/OTR.jsm:15
<anonymous> resource:///modules/OTRUI.jsm:8
connectedCallback chrome://messenger/content/chat/chat-conversation-info.js:116
<anonymous> chrome://global/content/customElements.js:217
[Exception... "Component returned failure code: 0x80520001 (NS_ERROR_FILE_UNRECOGNIZED_PATH) [nsIXPCComponents_Utils.readUTF8URI]" nsresult: "0x80520001 (NS_ERROR_FILE_UNRECOGNIZED_PATH)" location: "JS frame :: resource://gre/modules/L10nRegistry.jsm :: L10nRegistry.loadSync :: line 658" data: no] L10nRegistry.jsm:658:19
loadSync resource://gre/modules/L10nRegistry.jsm:658
fetchFile resource://gre/modules/L10nRegistry.jsm:573
generateResourceSetSync resource://gre/modules/L10nRegistry.jsm:478
map self-hosted:240
generateResourceSetSync resource://gre/modules/L10nRegistry.jsm:473
generateResourceSetsForLocaleSync resource://gre/modules/L10nRegistry.jsm:415
next self-hosted:1099
generateBundlesSync resource://gre/modules/L10nRegistry.jsm:177
next self-hosted:1099
touchNext resource://gre/modules/Localization.jsm:167
regenerateBundles resource://gre/modules/Localization.jsm:552
activate resource://gre/modules/Localization.jsm:243
<anonymous> resource:///modules/OTRUI.jsm:10
connectedCallback chrome://messenger/content/chat/chat-conversation-info.js:116
<anonymous> chrome://global/content/customElements.js:217
2020-06-08 10:12:12 autosyncActivities ERROR OnDownloadError: Inbox of nojoyindelay@charter.net

Log4moz.jsm:766
append resource:///modules/gloda/Log4moz.jsm:766
log resource:///modules/gloda/Log4moz.jsm:416
error resource:///modules/gloda/Log4moz.jsm:424
onDownloadError resource:///modules/activity/autosync.jsm:388
_timerCallback resource:///modules/AppIdleManager.jsm:30
2020-06-08 10:12:12 autosyncActivities ERROR OnDownloadError: Inbox of nojoyindelay@charter.net

uncaught exception: 2147746065 autosync.jsm:244:30
2147942487
2147942487 contentAreaClick.js:230
TypeError: tabmail is null mailCore.js:732:3

Thank You for the follow up.

Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Please do not reopen closed bugs – that is not your decision to make. If you think there is a new issue (this one was fixed) open a new bug.

FWIW I have just tried the steps to reproduce in 77.0b3 and it is working.

Status: REOPENED → RESOLVED
Closed: 4 months ago2 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.