Reflow with table + fieldset every time a <input type="submit"> is clicked

RESOLVED WORKSFORME

Status

()

Core
Layout
P3
normal
RESOLVED WORKSFORME
16 years ago
13 years ago

People

(Reporter: Tobias Burnus, Assigned: John Keiser (jkeiser))

Tracking

({testcase})

Trunk
Future
x86
Linux
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
This is Mozilla 1.1b; Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1b)
Gecko/20020809.

I have a <fieldset> which is embedded in <table>. If the window width is smalle
than the maximum size needed, then the formset size shrinks causing a reflow
every time I click 'submit'. (If I cancel the submit by moving the mouse cursor
out of the button I can repeat this several times)

Testcase + instruction to come.
(Reporter)

Comment 1

16 years ago
Created attachment 94905 [details]
Testcase with instructions
To layout.  This is not submission.

Comment 3

16 years ago
-> Layout (per comment #2)
Component: Form Submission → Layout
reassign for real
Assignee: alexsavulov → attinasi
QA Contact: vladimire → petersen

Comment 5

16 years ago
Dupe of bug 149734?

pi
-> jkeiser
Assignee: attinasi → jkeiser
Priority: -- → P3
Target Milestone: --- → Future

Comment 7

15 years ago
*** Bug 208855 has been marked as a duplicate of this bug. ***

Comment 8

14 years ago
I had a look at this bug and the best I could get without getting confused was

/layout/html/forms/src/nsFieldSetFrame.cpp line #475~

The call to ReflowChild returns a different value for kidDesiredSize.width, I'm
presuming that this ends up with the wrong MEW being reported to the parent.

I tried bz's patch in http://bugzilla.mozilla.org/show_bug.cgi?id=129346 just in
case.
Blocks: 250345

Updated

14 years ago
No longer blocks: 250345

Comment 9

13 years ago
Created attachment 166538 [details]
Testcase exhibiting fieldset growth

User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5)
Gecko/20041107 Firefox/1.0

I think the behaviour exhibited by this test case fits this bug - the fieldset
will expand if you change the selected option or click on the button (which
causes expansion on both mousedown and mouseup). On my machine, this expansion
only happens twice, after which the width of the table cell containing "Cell 2"
has become as small as possible.

This behaviour doesn't occur if:
- You don't specify a width for the table.
or
- You specify a width for the fieldset in pixels.

Comment 10

13 years ago
This is wfm with a current trunk build winxp 2004111204.

Jonathan could you please retest with a current trunk build. ( I think, I did
fix this on trunk)

Comment 11

13 years ago
Retested with trunk build 2004111904 on winxp.

It does appear to be fixed - both test cases wfm.

Comment 12

13 years ago
Definately fixed on trunk.
WFM, 2004-12-29-05 trunk Linux.

-> WORKSFORME
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Keywords: testcase
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.