Closed Bug 1622709 Opened 2 years ago Closed 2 years ago

Re-enable RecycleAllocator at ImageContainer for RDD process

Categories

(Core :: Graphics: Layers, enhancement)

enhancement
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla76
Tracking Status
firefox76 --- fixed

People

(Reporter: sotaro, Assigned: sotaro)

References

Details

Attachments

(1 file)

RecycleAllocator at ImageContainer for RDD process was disabled by Bug 1622142 because of av1 video rendering regression. To reduce video frame copy, we want to re-enable it again.

Assignee: nobody → sotaro.ikeda.g

Regression happened, because BufferTextureHost::UpdatedInternal() was not called when BufferTextureHost was wrapped by GPUVideoTextureHost.

Depends on: 1618429
See Also: → 1621986, 1622142, 1622324
Pushed by sikeda.birchill@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/7b750f674098
Re-enable RecycleAllocator at ImageContainer for RDD process r=nical
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla76
Regressions: 1645579
You need to log in before you can comment on or make changes to this bug.