Closed Bug 1622726 Opened 7 months ago Closed 7 months ago

Crash in [@ mozilla::CheckCheckedUnsafePtrs<T>::Check | mozilla::detail::SupportCheckedUnsafePtrImpl<T>::~SupportCheckedUnsafePtrImpl | mozilla::dom::MessagePortParent::~MessagePortParent]

Categories

(Core :: DOM: postMessage, defect)

x86_64
All
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1622924

People

(Reporter: gsvelto, Unassigned)

Details

(Keywords: crash)

Crash Data

This bug is for crash report bp-039eff3d-1e31-429a-b381-09aa00200313.

Top 10 frames of crashing thread:

0 XUL mozilla::CheckCheckedUnsafePtrs<mozilla::CrashOnDanglingCheckedUnsafePtr>::Check dom/quota/CheckedUnsafePtr.h:237
1 XUL mozilla::detail::SupportCheckedUnsafePtrImpl<mozilla::CrashOnDanglingCheckedUnsafePtr,  dom/quota/CheckedUnsafePtr.h:285
2 XUL mozilla::dom::MessagePortParent::~MessagePortParent dom/messagechannel/MessagePortParent.cpp:26
3 XUL mozilla::dom::MessagePortParent::~MessagePortParent dom/messagechannel/MessagePortParent.cpp:23
4 XUL mozilla::ipc::BackgroundParentImpl::DeallocPMessagePortParent ipc/glue/BackgroundParentImpl.cpp:1025
5 XUL <name omitted> ipc/glue/ProtocolUtils.cpp:249
6 XUL mozilla::ipc::PBackgroundParent::RemoveManagee ipc/ipdl/PBackgroundParent.cpp
7 XUL mozilla::dom::PMessagePortParent::Send__delete__ ipc/ipdl/PMessagePortParent.cpp:148
8 XUL mozilla::dom::MessagePortService::CloseAll dom/messagechannel/MessagePortParent.cpp:138
9 XUL mozilla::dom::MessagePortService::CloseAll dom/messagechannel/MessagePortService.cpp:303

This started with buildid 20200313095322 on Windows, and buildid 20200313095322 on macOS. The stack is short and consistent in all reports and the raw reason is: MOZ_CRASH(Found dangling CheckedUnsafePtr)

Component: IPC → DOM: postMessage

It looks like Yaron added this check. Maybe you'd be interested in looking at these crashes?

Flags: needinfo?(ytausky)
Status: NEW → RESOLVED
Closed: 7 months ago
Flags: needinfo?(ytausky)
Resolution: --- → DUPLICATE
Duplicate of bug: 1622924
You need to log in before you can comment on or make changes to this bug.