Closed Bug 1622830 Opened 5 months ago Closed 4 months ago

Download in progress Window never finishes

Categories

(SeaMonkey :: Download & File Handling, defect, P5)

defect

Tracking

(seamonkey2.49esr unaffected, seamonkey2.53 affected, seamonkey2.57esr affected)

RESOLVED FIXED
Tracking Status
seamonkey2.49esr --- unaffected
seamonkey2.53 --- affected
seamonkey2.57esr --- affected

People

(Reporter: jlayoj3121968, Assigned: frg)

References

(Regression)

Details

Attachments

(1 file, 1 obsolete file)

User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:60.0) Gecko/20100101 Firefox/60.0 SeaMonkey/2.53.1

Steps to reproduce:

(Does the same on other download sites, but this is perhaps the most important for this application at the moment.)

  1. Go to https://www.wg9s.com/comm-253/
  2. Right-click on an file name, click Save Link Target As, etc. to start download.
  3. Let download progress.

Actual results:

Download gets to 100% and sits there with status 'downloading'

I started the example download last night and found it still sitting like that this morning.
I also tried downloads from other sites and get the same result.
I also tried simply clicking on the link instead of 'save ... as' and got the same result.

Expected results:

Download should finish.

If I am guessing correctly you are probably using the Progress window and not the Download Manager. Confirmed there.

Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Download never finishes → Download in progress Window never finishes
Version: SeaMonkey 2.53 Branch → Trunk

Btw. The download should finish ok. Just cosmetic.

Priority: -- → P5
Duplicate of this bug: 1624522

Fully works. Just want to move the copied stuff to DownloadsComman.jsm before asking for r?.
TimeElapsed is not much good any more with jsdownloads so switched to TimeLeft which was previously appended here to the text status.
The removed stringbundle is/was unused and does not exist. The 2 strings can go out or stay in 2.53+ but no longer needed.

Should be in tomorrows unofficial 2.53.3 b1 pre and later in 2.53.2 Beta 1 if found worthy.

Assignee: nobody → frgrahl
Status: NEW → ASSIGNED
Attachment #9135516 - Flags: feedback?(iann_bugzilla)
Regressed by: 888915

Just saw that the window title might still show downloading when finished. Fixing it in the next iteration.

[Approval Request Comment]
Regression caused by (bug #): 888915
User impact if declined: useless values in progress dialog
Testing completed (on m-c, etc.): 2.53
Risk to taking this patch (and alternatives if risky): already broken for the progress dialog and no functional change for the DM
String changes made by this patch: 2 removals only so should go into 2.53.2

Attachment #9135516 - Attachment is obsolete: true
Attachment #9135516 - Flags: feedback?(iann_bugzilla)
Attachment #9135838 - Flags: review?(iann_bugzilla)
Attachment #9135838 - Flags: approval-comm-release?
Attachment #9135838 - Flags: approval-comm-esr60?
See Also: → 1562537
Comment on attachment 9135838 [details] [diff] [review]
1622830-downloadprogress.patch

>+++ b/suite/components/downloads/DownloadsCommon.jsm
>+    // Some local files saves e.g. from attachments also have no size.
>+    // They only have a target in downloads.json but no target.path.
>+    // FIX ME later.
Is this logged as a bug, if so mention the bug number?

r/a=me either way.
Attachment #9135838 - Flags: review?(iann_bugzilla)
Attachment #9135838 - Flags: review+
Attachment #9135838 - Flags: approval-comm-release?
Attachment #9135838 - Flags: approval-comm-release+
Attachment #9135838 - Flags: approval-comm-esr60?
Attachment #9135838 - Flags: approval-comm-esr60+

Pushed by frgrahl@gmx.net:
https://hg.mozilla.org/comm-central/rev/3f7c4b34b66b
Calculate download values in progress window the same as in the DM. r=IanN

Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED

Is this logged as a bug, if so mention the bug number?

Forgot to answer. No I didn't file a bug yet. It seems to occur for files which are loaded from the cache or from an uncommon scheme like txt files or imap://
Wanted to look at it first. Won't forget because this occurs every time you "download" a mail attachment from an imap account.

You need to log in before you can comment on or make changes to this bug.