Closed Bug 1622889 Opened 5 months ago Closed 5 months ago

Preview does not show up on expression with optional chaining

Categories

(DevTools :: Debugger, defect)

defect
Not set
normal

Tracking

(firefox76 verified)

VERIFIED FIXED
Firefox 76
Tracking Status
firefox76 --- verified

People

(Reporter: nchevobbe, Assigned: jlast)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

Steps to reproduce

  1. Navigate to data:text/html,<meta charset=utf8><script>x = {y: {z: {a: 1}}}; x?.y?.z; debugger;</script>
  2. Open devtools
  3. Reload the page to pause at the debugger statement
  4. Hover the y in x?.y?.z

Expected results

I get a tooltip showing the z property

Actual results

The tooltip is never displayed.

Assignee: nchevobbe → jlaster
Depends on: 1624966
Pushed by jlaster@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/082f545dff2b
Preview does not show up on expression with optional chaining. r=nchevobbe
Blocks: 1625024
Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 76
Flags: qe-verify+

Reproduced the issue using Firefox 76.0a1 (20200316154314) on Windows 10x64.
The issue is verified fixed with Firefox 76.0b4 (20200412214314) on Windows 10x64, macOS 10.12 and Ubuntu 18.04.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.