Closed Bug 1623015 Opened 5 months ago Closed 5 months ago

Bookmarks menu widget dropdown scroll arrow icon seem to have inverted enabled/disabled state icons with Dark Theme

Categories

(Toolkit :: Themes, defect, P3)

defect
Points:
3

Tracking

()

VERIFIED FIXED
mozilla76
Iteration:
76.2 - Mar 23 - Apr 5
Tracking Status
firefox-esr68 --- wontfix
firefox74 --- wontfix
firefox75 --- wontfix
firefox76 --- verified

People

(Reporter: alice0775, Assigned: dao)

References

(Depends on 1 open bug, Blocks 2 open bugs)

Details

(Keywords: nightly-community)

Attachments

(2 files, 1 obsolete file)

Attached image screenshot (obsolete) —

The two scroll arrow icon of bookmarks menu widget dropdown seems to have inverted icons

Reproducible: always

Steps to reproduce:

  1. Customize and put Bookmarks menu widget
  2. Enable Dark theme from about:addons
  3. Bookmark a lot
  4. Open the bookmarks menu widget, Observe behavior

Actual results:

  • the two icons are inverted

Expected results:

  • the two buttons are displayed correctly
Attached image screenshot
Attachment #9133807 - Attachment is obsolete: true
Assignee: nobody → dao+bmo
Status: NEW → ASSIGNED
Points: --- → 3
OS: Windows 10 → Windows
Priority: -- → P3
OS: Windows → All
Hardware: Desktop → All
Blocks: png-cleanup
Component: Theme → Themes
Product: Firefox → Toolkit
Iteration: --- → 76.2 - Mar 23 - Apr 5
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/cdc5571c2d7c
Modernize scrollbox arrows. r=ntim
Blocks: 1624596
See Also: → 1624598
Blocks: 1624599

Alexander or Jamie, do you have any clue why this patch fails accessible/tests/mochitest/hittest/test_menu.xhtml and accessible/tests/mochitest/states/test_visibility.xhtml? I'm having a hard time even understanding the failure messages such as wrong state bits for 'mi_file1.2.1' !got '0', expected 'invisible' or state bits should not be present in ID 'mi_file1.2.1' !got 'offscreen', expected '0'...

Flags: needinfo?(surkov.alexander)
Flags: needinfo?(jteh)
Flags: needinfo?(dao+bmo)

Apparently the size of the arrow makes both tests fail. This is weird because the menus are small and shouldn't be overflowing anyway. This seems to be some kind of bug in the tests or arrowscrollbox.js or both...

I'll land this with arrow-dropdown-12.svg instead of arrow-dropdown-16.svg for now.

Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/c5112a7573ac
Modernize scrollbox arrows. r=ntim
Blocks: 1624598
See Also: 1624598
Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla76

(In reply to Dão Gottwald [::dao] from comment #6)

Apparently the size of the arrow makes both tests fail. This is weird because the menus are small and shouldn't be overflowing anyway. This seems to be some kind of bug in the tests or arrowscrollbox.js or both...

not sure about the test, since apparently all the test does is checking whether menuitem is visible; perhaps this arrowscrollbox.js issue: a menuitem might appear scrolled out which will make it 'offscreen' - having a screenshot would be helpful.

Anyway, I suppose no ni? request since the bug is fixed?

Flags: needinfo?(surkov.alexander)
Blocks: 1624919

(In reply to alexander :surkov (:asurkov) from comment #10)

Anyway, I suppose no ni? request since the bug is fixed?

The problem still exists, I landed this with a workaround for now -- see comment 6 and comment 7.

Depends on: 1624951
Depends on: 1624953
Flags: needinfo?(jteh)

This now looks MUCH better. Thank you!

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.