Closed Bug 1623278 Opened 5 months ago Closed 1 month ago

Prototype reduction of raw pointer usage

Categories

(Core :: Storage: IndexedDB, task, P2)

task

Tracking

()

RESOLVED FIXED
mozilla79
Tracking Status
firefox79 --- fixed

People

(Reporter: sg, Assigned: sg)

References

Details

Attachments

(18 files)

47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review

In preparation of the raw pointer guideline, prototype applying the rules and defining new support types (such as SafeRefPtr) in IndexedDB code.

Priority: -- → P2
Pushed by sgiesecke@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/7fdf38a403bb
Use SafeRefPtr for FullDatabaseMetadata. r=dom-workers-and-storage-reviewers,asuth
https://hg.mozilla.org/integration/autoland/rev/bb094a6084b3
Use SafeRefPtr for FileManager. r=dom-workers-and-storage-reviewers,asuth
https://hg.mozilla.org/integration/autoland/rev/ad7b08acadd6
Use SafeRefPtr for FileInfo. r=dom-workers-and-storage-reviewers,asuth
https://hg.mozilla.org/integration/autoland/rev/8b03993a9234
Use SafeRefPtr for Database. r=dom-workers-and-storage-reviewers,asuth
https://hg.mozilla.org/integration/autoland/rev/50c0e58dd654
Use SafeRefPtr for TransactionBase and its subclasses. r=dom-workers-and-storage-reviewers,asuth

Steve, could you give this a look? The hazard build is busted, but for reasons that seem unrelated to the hazard analysis. The regular builds, including the gcc toolchain builds, are fine though.

Flags: needinfo?(sgiesecke) → needinfo?(sphink)

Which are the gcc toolchain builds? I'm guessing they're using a different version of gcc.

I get the problem using the gcc 8.3.0 that the hazard analysis uses, just using a straight gcc compile without the hazard analysis included. That file compiles successfully with my system's gcc 9.2.1.

It seems to be getting the wrong type for the mTransaction field. I guess it must be some bizarre gcc bug involving template instantiations (maybe) and using Class::fieldName declarations (probably).

I'm checking to see what happens if I try to recompile the plugin for gcc 9 right now, but that'll probably involve additional effort.

(In reply to Steve Fink [:sfink] [:s:] from comment #14)

Which are the gcc toolchain builds? I'm guessing they're using a different version of gcc.

These are the builds shown as Bb (not Bbc, these are builds using an older clang version) in a try build. They use gcc 7.4.0 at the moment.

I get the problem using the gcc 8.3.0 that the hazard analysis uses, just using a straight gcc compile without the hazard analysis included. That file compiles successfully with my system's gcc 9.2.1.

It seems to be getting the wrong type for the mTransaction field. I guess it must be some bizarre gcc bug involving template instantiations (maybe) and using Class::fieldName declarations (probably).

I'm checking to see what happens if I try to recompile the plugin for gcc 9 right now, but that'll probably involve additional effort.

I will check if I can manage to get a gcc 8.3.0 to reproduce this and make some workaround for now. But in general it would be great to update the hazard analysis to a newer gcc version (when we move to C++20 at some point it will be inevitable).

I found a workaround for this and a follow-up issue which is even weirder since the code didn't change near that at all. Thanks for checking!

Keywords: leave-open
Attachment #9135927 - Attachment description: Bug 1623278 - Eliminate output and raw pointer input parameters on ... r=#dom-workers-and-storage → Bug 1623278 - Eliminate output and raw pointer input parameters on some ActorsParent functions. r=#dom-workers-and-storage
Pushed by sgiesecke@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/1e1e3972a3bd
Workaround to make gcc 8.3.0 happy. r=jstutte
https://hg.mozilla.org/integration/autoland/rev/a753c018a4a8
Use SafeRefPtr for FullDatabaseMetadata. r=dom-workers-and-storage-reviewers,asuth
https://hg.mozilla.org/integration/autoland/rev/7e9d56eb485e
Use SafeRefPtr for FileManager. r=dom-workers-and-storage-reviewers,asuth
https://hg.mozilla.org/integration/autoland/rev/7c9ee023c8cc
Use SafeRefPtr for FileInfo. r=dom-workers-and-storage-reviewers,asuth
https://hg.mozilla.org/integration/autoland/rev/eed2355c442c
Use SafeRefPtr for Database. r=dom-workers-and-storage-reviewers,asuth
https://hg.mozilla.org/integration/autoland/rev/337f5e9f4070
Use SafeRefPtr for TransactionBase and its subclasses. r=dom-workers-and-storage-reviewers,asuth
https://hg.mozilla.org/integration/autoland/rev/4c6d84346900
Use SafeRefPtr for IDBFactory. r=dom-workers-and-storage-reviewers,asuth
https://hg.mozilla.org/integration/autoland/rev/0e6f9a56563c
Replace GetStorageConnection by HasStorageConnection and MutableStorageConnection accessors. r=dom-workers-and-storage-reviewers,janv

Which are the gcc toolchain builds? I'm guessing they're using a different version of gcc.

These are the builds shown as Bb (not Bbc, these are builds using an older clang version) in a try build. They use gcc 7.4.0 at the moment.

Sadly, gcc 7 had a bug that broke the plugin. I would rather be running the same version as other gcc builds, to avoid exactly this sort of situation.

I found a workaround for this and a follow-up issue which is even weirder since the code didn't change near that at all. Thanks for checking!

Probably a new warning in gcc 8 or something. I had to fix 3 different random minor issues to be able to compile with gcc 9.

This bug has [leave-open]. Can it be closed?

Flags: needinfo?(sphink)

(In reply to Steve Fink [:sfink] [:s:] from comment #19)

Which are the gcc toolchain builds? I'm guessing they're using a different version of gcc.

These are the builds shown as Bb (not Bbc, these are builds using an older clang version) in a try build. They use gcc 7.4.0 at the moment.

Sadly, gcc 7 had a bug that broke the plugin. I would rather be running the same version as other gcc builds, to avoid exactly this sort of situation.

Well, the purpose of the Bb builds is to check build with the oldest gcc version we claim to support. I am not sure if there are any builds with a more up-to-date gcc version. Probably we should have them if we claim to support them.

I found a workaround for this and a follow-up issue which is even weirder since the code didn't change near that at all. Thanks for checking!

Probably a new warning in gcc 8 or something. I had to fix 3 different random minor issues to be able to compile with gcc 9.

This bug has [leave-open]. Can it be closed?

It's leave-open for reasons unrelated to this issue: only parts of the patches have been reviewed and landed.

(In reply to Simon Giesecke [:sg] [he/him] from comment #21)

(In reply to Steve Fink [:sfink] [:s:] from comment #19)

Which are the gcc toolchain builds? I'm guessing they're using a different version of gcc.

These are the builds shown as Bb (not Bbc, these are builds using an older clang version) in a try build. They use gcc 7.4.0 at the moment.

Sadly, gcc 7 had a bug that broke the plugin. I would rather be running the same version as other gcc builds, to avoid exactly this sort of situation.

Well, the purpose of the Bb builds is to check build with the oldest gcc version we claim to support. I am not sure if there are any builds with a more up-to-date gcc version. Probably we should have them if we claim to support them.

Agreed. I didn't mean to imply that the gcc builds should be using a newer gcc. I don't think we probably want to support any more compilers than we have to, and sticking to one of the older versions that is still in active use makes sense. In practice, I think we end up supporting some version of clang, an older version of gcc, plus whatever version of gcc the analysis needs which we would hope would be the same older version of gcc but sometimes needs to be newer.

Pushed by sgiesecke@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/272e82616218
Create SafeRefCounted base class that is initialized with a refcount of 1 and can only be instantiated via MakeSafeRefPtr. r=dom-workers-and-storage-reviewers,janv
Pushed by sgiesecke@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/d65dd19b8a16
Use SafeRefPtr for IDBTransaction. r=dom-workers-and-storage-reviewers,ttung,janv
https://hg.mozilla.org/integration/autoland/rev/9a6271146478
Eliminate output parameters on GetOrCreateConnection. r=dom-workers-and-storage-reviewers,janv
https://hg.mozilla.org/integration/autoland/rev/a09556b2333b
Eliminate output and raw pointer input parameters on some ActorsParent functions. r=dom-workers-and-storage-reviewers,ttung

Also replace output parameters by use of mozilla::Result.

Depends on D72605

Attachment #9143589 - Attachment description: Bug 1623278 - Use mozilla::Span instead of pointer/length pair. r=#dom-workers-and-storage → Bug 1623278 - Use mozilla::Span instead of pointer/length pair in Read* functions. r=#dom-workers-and-storage
Depends on: 1633719
Pushed by sgiesecke@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/6efa98635cf4
Make transaction actors refcounted. r=dom-workers-and-storage-reviewers,nika,janv
https://hg.mozilla.org/integration/autoland/rev/74d93e32c149
Use SafeRefCounted in ActorsParent. r=dom-workers-and-storage-reviewers,janv
https://hg.mozilla.org/integration/autoland/rev/296b2617fceb
Make Factory derive from SafeRefCounted. r=dom-workers-and-storage-reviewers,janv
Pushed by sgiesecke@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/8a21ea441fc7
Use MovingNotNull in ActorsParent. r=dom-workers-and-storage-reviewers,janv

Backed out 2 changesets (bug 1623278, bug 1633719) for assertion failure on NotNull.h

Push with failures: https://treeherder.mozilla.org/#/jobs?repo=autoland&resultStatus=testfailed%2Cbusted%2Cexception&fromchange=8a21ea441fc78be36c13f78fc3da9fb41985ed3a&tochange=1ef46cc7df73f0018df3c318f762441142342978&selectedTaskRun=HhhcGcn_Td-sIVxY81mYqA-0

Backout link: https://hg.mozilla.org/integration/autoland/rev/1ef46cc7df73f0018df3c318f762441142342978

Failure log: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=302222662&repo=autoland&lineNumber=4623

...
[task 2020-05-14T08:30:42.671Z] 08:30:42     INFO - Application command: /builds/worker/workspace/build/application/firefox/firefox -marionette -foreground -profile /tmp/tmprFNcy4.mozrunner
[task 2020-05-14T08:30:42.687Z] 08:30:42     INFO - runtests.py | Application pid: 3685
[task 2020-05-14T08:30:42.688Z] 08:30:42     INFO - TEST-INFO | started process GECKO(3685)
[task 2020-05-14T08:30:42.711Z] 08:30:42     INFO - GECKO(3685) | ### XPCOM_MEM_BLOAT_LOG defined -- logging bloat/leaks to /tmp/tmprFNcy4.mozrunner/runtests_leaks.log
[task 2020-05-14T08:30:42.712Z] 08:30:42     INFO - GECKO(3685) | [3685, Main Thread] WARNING: XPCOM_MEM_BLOAT_LOG is set, disabling native allocations.: file /builds/worker/checkouts/gecko/tools/profiler/core/platform.cpp, line 225
[task 2020-05-14T08:30:43.918Z] 08:30:43     INFO - GECKO(3685) | 1589445043914	Marionette	TRACE	Marionette enabled
[task 2020-05-14T08:30:44.086Z] 08:30:44     INFO - GECKO(3685) | 1589445044083	Marionette	TRACE	Received observer notification toplevel-window-ready
[task 2020-05-14T08:30:44.122Z] 08:30:44     INFO - GECKO(3685) | [3685, Main Thread] WARNING: NS_ENSURE_TRUE(rootFrame) failed: file /builds/worker/checkouts/gecko/dom/base/nsGlobalWindowOuter.cpp, line 4265
[task 2020-05-14T08:30:44.782Z] 08:30:44     INFO - GECKO(3685) | [3685, Main Thread] WARNING: NS_ENSURE_TRUE(presShell) failed: file /builds/worker/checkouts/gecko/dom/base/nsGlobalWindowOuter.cpp, line 4263
[task 2020-05-14T08:30:45.063Z] 08:30:45     INFO - GECKO(3685) | [Parent 3685, GMPThread] WARNING: Failed to delete GMP storage directory: file /builds/worker/checkouts/gecko/dom/media/gmp/GMPServiceParent.cpp, line 1568
[task 2020-05-14T08:30:45.079Z] 08:30:45     INFO - GECKO(3685) | ### XPCOM_MEM_BLOAT_LOG defined -- logging bloat/leaks to /tmp/tmprFNcy4.mozrunner/runtests_leaks_tab_pid3813.log
[task 2020-05-14T08:30:45.079Z] 08:30:45     INFO - GECKO(3685) | [3813, Main Thread] WARNING: XPCOM_MEM_BLOAT_LOG is set, disabling native allocations.: file /builds/worker/checkouts/gecko/tools/profiler/core/platform.cpp, line 225
[task 2020-05-14T08:30:45.115Z] 08:30:45     INFO - GECKO(3685) | LoadPlugin() /usr/lib/mozilla/plugins/libgnome-shell-browser-plugin.so returned 7f0acc7fe130
[task 2020-05-14T08:30:45.116Z] 08:30:45     INFO - GECKO(3685) | LoadPlugin() /tmp/tmprFNcy4.mozrunner/plugins/libnpsecondtest.so returned 7f0acc7fe1c0
[task 2020-05-14T08:30:45.116Z] 08:30:45     INFO - GECKO(3685) | LoadPlugin() /tmp/tmprFNcy4.mozrunner/plugins/libnptest.so returned 7f0acc7fe2e0
[task 2020-05-14T08:30:45.116Z] 08:30:45     INFO - GECKO(3685) | LoadPlugin() /tmp/tmprFNcy4.mozrunner/plugins/libnpthirdtest.so returned 7f0acc7fe3a0
[task 2020-05-14T08:30:45.117Z] 08:30:45     INFO - GECKO(3685) | LoadPlugin() /tmp/tmprFNcy4.mozrunner/plugins/libnpswftest.so returned 7f0acc7fe3d0
[task 2020-05-14T08:30:45.398Z] 08:30:45     INFO - GECKO(3685) | [Parent 3685, Main Thread] WARNING: Need BrowserChild to get the nativeWindow from!: file /builds/worker/checkouts/gecko/widget/PuppetWidget.cpp, line 1086
[task 2020-05-14T08:30:45.405Z] 08:30:45     INFO - GECKO(3685) | [Parent 3685, Main Thread] WARNING: Need BrowserChild to get the nativeWindow from!: file /builds/worker/checkouts/gecko/widget/PuppetWidget.cpp, line 1086
[task 2020-05-14T08:30:45.408Z] 08:30:45     INFO - GECKO(3685) | [Parent 3685, Main Thread] WARNING: Need BrowserChild to get the nativeWindow from!: file /builds/worker/checkouts/gecko/widget/PuppetWidget.cpp, line 1086
[task 2020-05-14T08:30:45.416Z] 08:30:45     INFO - GECKO(3685) | [Parent 3685, Main Thread] WARNING: Need BrowserChild to get the nativeWindow from!: file /builds/worker/checkouts/gecko/widget/PuppetWidget.cpp, line 1086
[task 2020-05-14T08:30:45.416Z] 08:30:45     INFO - GECKO(3685) | ### XPCOM_MEM_BLOAT_LOG defined -- logging bloat/leaks to /tmp/tmprFNcy4.mozrunner/runtests_leaks_tab_pid3829.log
[task 2020-05-14T08:30:45.416Z] 08:30:45     INFO - GECKO(3685) | [3829, Main Thread] WARNING: XPCOM_MEM_BLOAT_LOG is set, disabling native allocations.: file /builds/worker/checkouts/gecko/tools/profiler/core/platform.cpp, line 225
[task 2020-05-14T08:30:45.417Z] 08:30:45     INFO - GECKO(3685) | [Parent 3685, Main Thread] WARNING: Need BrowserChild to get the nativeWindow from!: file /builds/worker/checkouts/gecko/widget/PuppetWidget.cpp, line 1086
[task 2020-05-14T08:30:45.549Z] 08:30:45     INFO - GECKO(3685) | [Child 3813, Main Thread] WARNING: could not set real-time limit at process startup: file /builds/worker/checkouts/gecko/dom/ipc/ContentChild.cpp, line 1640
[task 2020-05-14T08:30:45.785Z] 08:30:45     INFO - GECKO(3685) | [Child 3829, Main Thread] WARNING: could not set real-time limit at process startup: file /builds/worker/checkouts/gecko/dom/ipc/ContentChild.cpp, line 1640
[task 2020-05-14T08:30:45.813Z] 08:30:45     INFO - GECKO(3685) | [Child 3829, Main Thread] WARNING: Fallback to BasicLayerManager: file /builds/worker/checkouts/gecko/dom/ipc/BrowserChild.cpp, line 2663
[task 2020-05-14T08:30:45.829Z] 08:30:45     INFO - GECKO(3685) | [Child 3829, Main Thread] WARNING: Fallback to BasicLayerManager: file /builds/worker/checkouts/gecko/dom/ipc/BrowserChild.cpp, line 2663
[task 2020-05-14T08:30:45.836Z] 08:30:45     INFO - GECKO(3685) | [Child 3829, Main Thread] WARNING: Fallback to BasicLayerManager: file /builds/worker/checkouts/gecko/dom/ipc/BrowserChild.cpp, line 2663
[task 2020-05-14T08:30:45.843Z] 08:30:45     INFO - GECKO(3685) | [Child 3829, Main Thread] WARNING: Fallback to BasicLayerManager: file /builds/worker/checkouts/gecko/dom/ipc/BrowserChild.cpp, line 2663
[task 2020-05-14T08:30:45.851Z] 08:30:45     INFO - GECKO(3685) | [Child 3829, Main Thread] WARNING: Fallback to BasicLayerManager: file /builds/worker/checkouts/gecko/dom/ipc/BrowserChild.cpp, line 2663
[task 2020-05-14T08:30:47.034Z] 08:30:47     INFO - GECKO(3685) | [Parent 3685, Main Thread] WARNING: NS_ENSURE_TRUE(rootFrame) failed: file /builds/worker/checkouts/gecko/dom/base/nsGlobalWindowOuter.cpp, line 4265
[task 2020-05-14T08:30:47.092Z] 08:30:47     INFO - GECKO(3685) | [Parent 3685, Main Thread] WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x80004005 (NS_ERROR_FAILURE): file /builds/worker/checkouts/gecko/dom/base/ThirdPartyUtil.cpp, line 440
[task 2020-05-14T08:30:48.281Z] 08:30:48     INFO - GECKO(3685) | [Parent 3685, Main Thread] WARNING: Suboptimal indexes for the SQL statement 0x7f0ac7f02d90 (http://mzl.la/1FuID0j).: file /builds/worker/checkouts/gecko/storage/mozStoragePrivateHelpers.cpp, line 106
[task 2020-05-14T08:30:48.668Z] 08:30:48     INFO - GECKO(3685) | [Parent 3685, Main Thread] WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x80004005 (NS_ERROR_FAILURE): file /builds/worker/checkouts/gecko/dom/base/ThirdPartyUtil.cpp, line 440
[task 2020-05-14T08:30:48.668Z] 08:30:48     INFO - GECKO(3685) | [Parent 3685, Main Thread] WARNING: Failed to retarget HTML data delivery to the parser thread.: file /builds/worker/checkouts/gecko/parser/html/nsHtml5StreamParser.cpp, line 1131
[task 2020-05-14T08:30:49.808Z] 08:30:49     INFO - GECKO(3685) | ### XPCOM_MEM_BLOAT_LOG defined -- logging bloat/leaks to /tmp/tmprFNcy4.mozrunner/runtests_leaks_tab_pid3897.log
[task 2020-05-14T08:30:49.810Z] 08:30:49     INFO - GECKO(3685) | [3897, Main Thread] WARNING: XPCOM_MEM_BLOAT_LOG is set, disabling native allocations.: file /builds/worker/checkouts/gecko/tools/profiler/core/platform.cpp, line 225
[task 2020-05-14T08:30:50.175Z] 08:30:50     INFO - GECKO(3685) | [Child 3897, Main Thread] WARNING: could not set real-time limit at process startup: file /builds/worker/checkouts/gecko/dom/ipc/ContentChild.cpp, line 1640
[task 2020-05-14T08:30:50.239Z] 08:30:50     INFO - GECKO(3685) | 1589445050225	Marionette	TRACE	Received observer notification marionette-startup-requested
[task 2020-05-14T08:30:50.240Z] 08:30:50     INFO - GECKO(3685) | 1589445050226	Marionette	TRACE	Waiting until startup recorder finished recording startup scripts...
[task 2020-05-14T08:30:50.317Z] 08:30:50     INFO - GECKO(3685) | [Parent 3685, QuotaManager IO] WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x80630001 (NS_ERROR_STORAGE_BUSY): file /builds/worker/checkouts/gecko/storage/mozStorageConnection.cpp, line 700
[task 2020-05-14T08:30:50.317Z] 08:30:50     INFO - GECKO(3685) | [Parent 3685, QuotaManager IO] WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x80630001 (NS_ERROR_STORAGE_BUSY): file /builds/worker/checkouts/gecko/storage/mozStorageService.cpp, line 638
[task 2020-05-14T08:30:50.317Z] 08:30:50     INFO - GECKO(3685) | Assertion failure: aBasePtr, at /builds/worker/workspace/obj-build/dist/include/mozilla/NotNull.h:324
[task 2020-05-14T08:30:50.320Z] 08:30:50     INFO -  Initializing stack-fixing for the first stack frame, this may take a while...
[task 2020-05-14T08:30:59.540Z] 08:30:59     INFO - GECKO(3685) | #01: mozilla::dom::indexedDB::(anonymous namespace)::StorageOpenTraits<nsIFileURL>::Open(mozIStorageService&, nsIFileURL&) [dom/indexedDB/ActorsParent.cpp:4015]
[task 2020-05-14T08:30:59.541Z] 08:30:59     INFO - GECKO(3685) | #02: mozilla::Result<mozilla::MovingNotNull<nsCOMPtr<mozIStorageConnection> >, nsresult> mozilla::dom::indexedDB::(anonymous namespace)::OpenDatabaseAndHandleBusy<nsIFileURL>(mozIStorageService&, nsIFileURL&) [dom/indexedDB/ActorsParent.cpp:4055]
[task 2020-05-14T08:30:59.542Z] 08:30:59     INFO - GECKO(3685) | #03: mozilla::dom::indexedDB::(anonymous namespace)::CreateStorageConnection(nsIFile&, nsIFile&, nsTSubstring<char16_t> const&, nsTSubstring<char> const&, long, unsigned int) [dom/indexedDB/ActorsParent.cpp:4123]
[task 2020-05-14T08:30:59.543Z] 08:30:59     INFO - GECKO(3685) | #04: mozilla::dom::indexedDB::(anonymous namespace)::OpenDatabaseOp::DoDatabaseWork() [dom/indexedDB/ActorsParent.cpp:21337]
[task 2020-05-14T08:30:59.543Z] 08:30:59     INFO - GECKO(3685) | #05: mozilla::dom::indexedDB::(anonymous namespace)::FactoryOp::Run() [dom/indexedDB/ActorsParent.cpp:21068]
[task 2020-05-14T08:30:59.544Z] 08:30:59     INFO - GECKO(3685) | #06: nsThread::ProcessNextEvent(bool, bool*) [xpcom/threads/nsThread.cpp:1211]
[task 2020-05-14T08:30:59.544Z] 08:30:59     INFO - GECKO(3685) | #07: NS_ProcessNextEvent(nsIThread*, bool) [xpcom/threads/nsThreadUtils.cpp:501]
[task 2020-05-14T08:30:59.545Z] 08:30:59     INFO - GECKO(3685) | #08: mozilla::ipc::MessagePumpForNonMainThreads::Run(base::MessagePump::Delegate*) [ipc/glue/MessagePump.cpp:332]
[task 2020-05-14T08:30:59.546Z] 08:30:59     INFO - GECKO(3685) | #09: MessageLoop::RunInternal() [ipc/chromium/src/base/message_loop.cc:315]
[task 2020-05-14T08:30:59.546Z] 08:30:59     INFO - GECKO(3685) | #10: MessageLoop::Run() [ipc/chromium/src/base/message_loop.cc:291]
[task 2020-05-14T08:30:59.547Z] 08:30:59     INFO - GECKO(3685) | #11: nsThread::ThreadFunc(void*) [xpcom/threads/nsThread.cpp:446]
...
Flags: needinfo?(sgiesecke)

Sorry, I mixed up patches when landing these, I thought I had try-d these. I have fixed the issue now, and try looks fine: https://treeherder.mozilla.org/#/jobs?repo=try&revision=e0ce3b402aa354ddaf65a4edd0ee56c64cd09230

Flags: needinfo?(sgiesecke)
Pushed by sgiesecke@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/fddd01727ad2
Use MovingNotNull in ActorsParent. r=dom-workers-and-storage-reviewers,janv
Pushed by sgiesecke@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/c86f2337fbc4
Use mozilla::Span instead of pointer/length pair in Key. r=dom-workers-and-storage-reviewers,janv
Pushed by sgiesecke@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/abd728a13d82
Use mozilla::Span instead of pointer/length pair in Read* functions. r=dom-workers-and-storage-reviewers,janv
Status: ASSIGNED → RESOLVED
Closed: 1 month ago
Keywords: leave-open
Resolution: --- → FIXED
Regressions: 1652409
Target Milestone: --- → mozilla79
You need to log in before you can comment on or make changes to this bug.