Closed Bug 1623287 Opened 7 months ago Closed 7 months ago

Perma [tier2] 0:31.08 tools/lint/test/test_file_license.py::test_lint_license TEST-UNEXPECTED-FAIL

Categories

(Firefox Build System :: Lint and Formatting, defect, P5)

defect

Tracking

(firefox76 fixed)

RESOLVED FIXED
mozilla76
Tracking Status
firefox76 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: Sylvestre)

References

(Regression)

Details

(Keywords: intermittent-failure)

Attachments

(2 files)

Filed by: ccoroiu [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=293643774&repo=autoland
Full log: https://firefox-ci-tc.services.mozilla.com/api/queue/v1/task/JMiOUH_fQseF5Q0GqkRd9A/runs/0/artifacts/public/logs/live_backing.log


[task 2020-03-18T10:26:39.471Z] 0:30.16 platform linux -- Python 3.6.9, pytest-3.6.2, py-1.5.4, pluggy-0.6.0 -- /builds/worker/checkouts/gecko/obj-x86_64-pc-linux-gnu/_virtualenvs/gecko-QUm8IANb-3/bin/python
[task 2020-03-18T10:26:39.471Z] 0:30.16 rootdir: /builds/worker/checkouts/gecko, inifile: /builds/worker/checkouts/gecko/config/mozunit/mozunit/pytest.ini
[task 2020-03-18T10:26:39.471Z] 0:30.16 collecting ... collected 4 items
[task 2020-03-18T10:26:39.471Z] 0:30.17
[task 2020-03-18T10:26:39.472Z] 0:30.17 python/mozlint/test/test_editor.py::test_no_editor PASSED
[task 2020-03-18T10:26:39.472Z] 0:30.17 python/mozlint/test/test_editor.py::test_no_issues PASSED
[task 2020-03-18T10:26:39.472Z] 0:30.17 python/mozlint/test/test_editor.py::test_vim PASSED
[task 2020-03-18T10:26:39.472Z] 0:30.17 python/mozlint/test/test_editor.py::test_generic PASSED
[task 2020-03-18T10:26:39.473Z] 0:30.17
[task 2020-03-18T10:26:39.473Z] 0:30.17 =========================== 4 passed in 0.05 seconds ===========================
[task 2020-03-18T10:26:40.379Z] 0:31.07 /builds/worker/checkouts/gecko/tools/lint/test/test_file_license.py
[task 2020-03-18T10:26:40.379Z] 0:31.07 ============================= test session starts ==============================
[task 2020-03-18T10:26:40.379Z] 0:31.07 platform linux -- Python 3.6.9, pytest-3.6.2, py-1.5.4, pluggy-0.6.0 -- /builds/worker/checkouts/gecko/obj-x86_64-pc-linux-gnu/_virtualenvs/gecko-QUm8IANb-3/bin/python
[task 2020-03-18T10:26:40.379Z] 0:31.07 rootdir: /builds/worker/checkouts/gecko, inifile: /builds/worker/checkouts/gecko/config/mozunit/mozunit/pytest.ini
[task 2020-03-18T10:26:40.379Z] 0:31.07 collecting ... collected 1 item
[task 2020-03-18T10:26:40.390Z] 0:31.08
[task 2020-03-18T10:26:40.390Z] 0:31.08 tools/lint/test/test_file_license.py::test_lint_license TEST-UNEXPECTED-FAIL
[task 2020-03-18T10:26:40.390Z] 0:31.08
[task 2020-03-18T10:26:40.391Z] 0:31.08 =================================== FAILURES ===================================
[task 2020-03-18T10:26:40.391Z] 0:31.08 ______________________________ test_lint_license _______________________________
[task 2020-03-18T10:26:40.391Z] 0:31.08
[task 2020-03-18T10:26:40.391Z] 0:31.08 lint = <function lint.<locals>.wrapper at 0x7f9b1ca21ea0>
[task 2020-03-18T10:26:40.391Z] 0:31.08 paths = <function paths.<locals>._inner at 0x7f9b19a35a60>
[task 2020-03-18T10:26:40.391Z] 0:31.09
[task 2020-03-18T10:26:40.392Z] 0:31.09 def test_lint_license(lint, paths):
[task 2020-03-18T10:26:40.392Z] 0:31.09 results = lint(paths())
[task 2020-03-18T10:26:40.392Z] 0:31.09 print(results)
[task 2020-03-18T10:26:40.392Z] 0:31.09 > assert len(results) == 2
[task 2020-03-18T10:26:40.392Z] 0:31.09 E assert 1 == 2
[task 2020-03-18T10:26:40.392Z] 0:31.09 E + where 1 = len([Issue({\n "linter": "license",\n "path": "/builds/worker/checkouts/gecko/tools/lint/test/files/license/bad.c",\n "mes...l,\n "source": null,\n "level": "error",\n "rule": null,\n "lineoffset": null,\n "diff": null,\n "relpath": "bad.c"\n})])
[task 2020-03-18T10:26:40.392Z] 0:31.09
[task 2020-03-18T10:26:40.393Z] 0:31.09 tools/lint/test/test_file_license.py:11: AssertionError

Flags: needinfo?(sledru)
Flags: needinfo?(sledru)
Regressed by: 1622328
Assignee: nobody → sledru
Pushed by sledru@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/3d42ea0f1741
mozlint/license: Remove a string which valid GPLv3
Status: NEW → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla76
Duplicate of this bug: 1623790
Pushed by nbeleuzu@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/dd487acc995d
mozlint/license: Fix test for real by generating an incorrect license

This is a different issue but I will have a look

Flags: needinfo?(sledru)

Moved in bug 1624038

You need to log in before you can comment on or make changes to this bug.