paragraphs interrupted by page breaks indent both parts

RESOLVED DUPLICATE of bug 45694

Status

()

Core
DOM: CSS Object Model
RESOLVED DUPLICATE of bug 45694
16 years ago
16 years ago

People

(Reporter: Eric Hortop, Assigned: jst)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0.0) Gecko/20020530
BuildID:    2002053012

When printing http://www.rocler.qc.ca/ehortop/shape_grammar/ShaGrInS.html,
Mozilla indents parts of paragraphs at the top of new pages as if they were
whole paragraphs.

Reproducible: Always
Steps to Reproduce:
1. Load http://www.rocler.qc.ca/ehortop/shape_grammar/ShaGrInS.html
2. Print it

Actual Results:  pp 2 and 5-9 all suffer the paragraph-fragment-indent,
resulting in a confusing mid-sentence jump.

Expected Results:  Lines in the middle of a paragraph should not be indented as
forst lines, even if they are at the top of a page.

Tested on MacOS 9.1; MacOS 10.1.4; Win2k.

Relevant css:

p {
	text-indent: 3em;
	margin-bottom: 0em;
	margin-top: 0em;
	line-height: 150%;
	page-break-inside: avoid;
}
This is fixed on the trunk and the fix will be in 1.1.



*** This bug has been marked as a duplicate of 45694 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.