Mozilla process hangs on exit

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
17 years ago
11 years ago

People

(Reporter: jquinn, Assigned: mscott)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Basically, there have been several occasions recently where I have tried to open
Mozilla and it has not opened. When I investigate with ctrl-alt-del I see no
mozilla in the "apps" tab but a mozilla process still alive (and intermittently
accessing the disk or going up as high as 24% processor although it mostly lives
at 0%). I kill this process and Mozilla starts as normal. 

I'm filing this under mailnews because I don't have a lot to go on. I think this
might have to do with mailnews because as far as I can remember it's only
happened when I've been using mail. I have an IMAP account which I tunnel
through SSH to my server. Often I just unplug my modem without bothering to shut
mozilla, ssh, and dialup in that order. I think this may have to do with the
"empty trash on exit" pref which I do have set in mail. Another symptom is that
sometimes my inbox is corrupted; I'm not sure if this comes from my irregular
shutdown, but I'm about to file it as a different bug.

Oh, one more symptom, which may or may not be mozilla's fault. Recently, about
contemporaneous with the beginnings of this moz problem, my laptop will
sometimes hang completely when I try to hibernate it. I see that the same 2secs
on 2secs off disk access __typical of the hung mozilla__ is still spinning.
Maybe XP is giving me a "do you want to force this process to close" dialog but
since my screen is already off I can't see it.

Im currently using the 200208071718 nightly.

Sorry, this isn't a lot to go on but at least it's in the system now.

Updated

17 years ago
QA Contact: gayatri → esther

Comment 1

17 years ago
Reporter, you mention "Empty Trash on Exit" set.  Can you look at a fixed bug
(106479) that sounds similiar to yours to see if you have a scenario close to
it.    If so, then I need to test that bug again for possible regression.  
If not, could you please try exiting Mozilla in a typical way (using our UI)
instead of unpluging the modem to see if the process quits?  Another test is to
uncheck "Empty Trash on Exit" and then try your modem unplug routine?   One
other test, if Quick Launch is Enabled, please disable it and continue in your
usual manner to see it that makes a difference?  Trying these will help us to
narrow this down.  Looking forward to your response.  Thanks.

Comment 2

17 years ago
I have the same problem, though I am exiting mozilla using your UI.
The mozilla process is still there and mozilla won't start until I deleted the 
process manually in task manager.
This happens every time I use mozilla.

Secondly the mailclient does not start when I started the browser.
Reporter: Did/does this happen with with a current Mozilla build?
no response-->resolving wfm
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.