Closed Bug 1623817 Opened 5 months ago Closed 5 months ago

Dynamic minimum size of event and task dialogs is broken

Categories

(Calendar :: Dialogs, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 76.0

People

(Reporter: darktrojan, Assigned: darktrojan)

References

(Regression)

Details

Attachments

(2 files)

In bug 1480338 I added a check to see if the dialog was too small for its contents and added minwidth/minheight attributes if it was. With bug 1598050, the attributes are now added to the wrong element and consequently not enforced.

Moved the attributes to the root element again. I've also tested that they are on the outer element, and removed some of the Mozmill-ness of the test.

Assignee: nobody → geoff
Status: NEW → ASSIGNED
Attachment #9134579 - Flags: review?(paul)
Comment on attachment 9134579 [details] [diff] [review]
1623817-dialog-min-size-again-1.diff

Review of attachment 9134579 [details] [diff] [review]:
-----------------------------------------------------------------

Changes look good.  I tested it and it does keep the dialog from shrinking past the minimum size.  Test passes locally.  r+

I noticed something that's happening with or without this patch: resizing the height of the dialog causes some jumping/flickering where between the top menu bar and below the title bar in the dialog you can briefly see through to the window behind before the gap closes up again.
Attachment #9134579 - Flags: review?(paul) → review+

I've filed bug 1624010 for the flickering issue.

Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/4297a939121c
Fix minimum size check on event/task dialog. r=pmorris

Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → 76

Oh hell, this test is failing on Mac, which I knew but forgot about. Will fix … uh … soon.

Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/b09bd153c9cd
follow-up - Stop defining dialog min-width with CSS. rs=bustage-fix DONTBUILD

I'd better have this reviewed despite already landing it. This CSS has been redundant since I originally fixed the bug, only now that the test checks for attributes it's causing a problem. With the CSS in place the dialog never overflows and never gets a min-width attribute.

Attachment #9134940 - Flags: review?(paul)
Attachment #9134940 - Flags: review?(paul) → review+
You need to log in before you can comment on or make changes to this bug.