Closed Bug 1623958 Opened 8 months ago Closed 8 months ago

Search Interventions show additional border on keyboard selection

Categories

(Firefox :: Address Bar, enhancement)

Desktop
All
enhancement
Not set
normal

Tracking

()

RESOLVED INVALID
Tracking Status
firefox-esr68 --- unaffected
firefox74 --- disabled
firefox75 --- wontfix
firefox76 --- wontfix

People

(Reporter: aflorinescu, Unassigned, NeedInfo)

References

(Blocks 1 open bug)

Details

(Keywords: polish)

Attachments

(1 file)

[Environment:]
  • Windows 10, Mac 10.13, Ubuntu 18.04

  • 75.0b6 20200319224147

  • 76.0a1 20200320095353

[Steps to reproduce:]
  1. Open Firefox.
  2. In the address bar type an Intervention trigger keyword: e.g. update firefox
  3. Once the intervention is triggered press "Tab" to select the Intervention.
  4. Press again "Tab" to select the "?" Get help button.
[Actual result:]

3.+4. The keyboard selection has two borders. check screenshot

[Expected result:]

Not entirely sure what the expected result should be here, but it looks a bit weird with the double border selection.
TBH, I'd probably opt-in for an alightment for the same keyboard selection as in the case of the one off's buttons & the setting button, unless especially intended to be different for some reason.

[Note:]

This issue is not applicable to Search Tips, since Search Tips are focused by default and cannot be selected by keyboard.

Attached image border.jpg

Since the screenshot doesn't have any sensitive information, I'm posting it here so it's publicly accessible in the bug.

I'm thinking this is a WONTFIX, since this is how Verdi wanted the borders to look. Still, I'll ni? him to make sure.

Flags: needinfo?(mverdi)

Yes this is what the focus state should look like. If anything, it's the one-offs and settings button that have the wrong focus state. I don't know what went into that decision. We should investigate and consider a followup in Update 2.

Flags: needinfo?(mverdi)
Status: NEW → RESOLVED
Closed: 8 months ago
Resolution: --- → INVALID

(In reply to Verdi [:verdi] Best to slack me from comment #2)

Yes this is what the focus state should look like. If anything, it's the one-offs and settings button that have the wrong focus state. I don't know what went into that decision. We should investigate and consider a followup in Update 2.

Michael, seems I forget to follow up on this, should I still log a new issue in regards to the above and block Update2, or are you tracking it somewhere else already?

Flags: needinfo?(mverdi)
You need to log in before you can comment on or make changes to this bug.