Closed Bug 1624038 Opened 5 months ago Closed 5 months ago

Perma [tier2] 0:31.08 tools/lint/test/test_shellcheck.py TEST-UNEXPECTED-FAIL

Categories

(Firefox Build System :: Lint and Formatting, defect, P5)

defect

Tracking

(firefox-esr68 unaffected, firefox74 unaffected, firefox75 unaffected, firefox76 fixed)

RESOLVED FIXED
mozilla76
Tracking Status
firefox-esr68 --- unaffected
firefox74 --- unaffected
firefox75 --- unaffected
firefox76 --- fixed

People

(Reporter: Sylvestre, Assigned: Sylvestre)

References

(Regression)

Details

(Keywords: intermittent-failure, regression)

Attachments

(1 file)

+++ This bug was initially created as a clone of Bug #1623287 +++

[task 2020-03-19T23:05:47.752Z]  0:35.53 ----------------------------- Captured stderr call -----------------------------
[task 2020-03-19T23:05:47.752Z]  0:35.53 23:05:47.388 shellcheck (710) | Command: ['/usr/bin/shellcheck', '-f', 'json', '-e', '1090,1091', '-s', 'sh', '/builds/worker/checkouts/gecko/tools/lint/test/files/shellcheck/bad.sh']
[task 2020-03-19T23:05:47.752Z]  0:35.53 Exception in thread ProcessReader:
[task 2020-03-19T23:05:47.752Z]  0:35.53 Traceback (most recent call last):
[task 2020-03-19T23:05:47.752Z]  0:35.53   File "/usr/lib/python3.6/threading.py", line 916, in _bootstrap_inner
[task 2020-03-19T23:05:47.752Z]  0:35.53     self.run()
[task 2020-03-19T23:05:47.752Z]  0:35.53   File "/usr/lib/python3.6/threading.py", line 864, in run
[task 2020-03-19T23:05:47.754Z]  0:35.53     self._target(*self._args, **self._kwargs)
[task 2020-03-19T23:05:47.754Z]  0:35.53   File "/builds/worker/checkouts/gecko/testing/mozbase/mozprocess/mozprocess/processhandler.py", line 1099, in _read
[task 2020-03-19T23:05:47.754Z]  0:35.53     callback(line.rstrip())
[task 2020-03-19T23:05:47.754Z]  0:35.53   File "/builds/worker/checkouts/gecko/testing/mozbase/mozprocess/mozprocess/processhandler.py", line 1009, in __call__
[task 2020-03-19T23:05:47.754Z]  0:35.53     e(*args, **kwargs)
[task 2020-03-19T23:05:47.754Z]  0:35.53   File "/builds/worker/checkouts/gecko/tools/lint/shell/__init__.py", line 44, in process_line
[task 2020-03-19T23:05:47.754Z]  0:35.53     results.append(result.from_config(self.config, *res))
[task 2020-03-19T23:05:47.754Z]  0:35.53 TypeError: from_config() takes 1 positional argument but 7 were given

https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=293960658&repo=autoland&lineNumber=516

Summary: Perma [tier2] 0:31.08 tools/lint/test/test_file_license.py::test_lint_license TEST-UNEXPECTED-FAIL → Perma [tier2] 0:31.08 tools/lint/test/test_shellcheck.py TEST-UNEXPECTED-FAIL
Duplicate of this bug: 1624049
Duplicate of this bug: 1623811
Pushed by ahalberstadt@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/2acacebdd474
mozlint/shell test - Fix a regression in the lint r=linter-reviewers,ahal
Status: NEW → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla76
You need to log in before you can comment on or make changes to this bug.