Closed Bug 1624239 Opened 2 years ago Closed 1 month ago

Comments missing in youtube Nightly 76.0a1 (2020-03-22)(64-bit)

Categories

(Core :: Networking, defect)

76 Branch
defect

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: dougskis, Unassigned, NeedInfo)

References

(Blocks 1 open bug)

Details

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:76.0) Gecko/20100101 Firefox/76.0

Steps to reproduce:

Open youtube.com, watch video, comments missing have spinning circle. I can view comments with FF 75.0b6 (64-bit) and Chrome Version 80.0.3987.149 (Official Build) (64-bit)

Do not have any addons or add blockers enabled, security settings same on both versions of FF I have.
FF Nightly 76.0a1 (2020-03-22)(64-bit)
Windows 10 Pro 64 bit 8GM RAM i5 processor.

Actual results:

Have spinning circle where comments should

Expected results:

Should be able to view comments.

Hello Doug,

I tried to reproduce this issue but I couldn't since it's working fine on Nightly 76.0a1 (2020-03-25), beta 75.0b9 or the release version 74.0.

Can you update to the latest version and see if it's still happening?

Flags: needinfo?(dougskis)

Andrei,

I do know what changed, but today comments are now visible, they were not visible yesterday.
76.0a1 (2020-03-25) (64-bit)
Issue is resolved.

Flags: needinfo?(dougskis)

I can reproduce this issue on 76.0a1 (2020-03-26).

Console logs Some cookies are misusing the “sameSite“ attribute, so it won’t work as expected, youtubeapi return 401 likely due to missing cookies.

Works for me on 76.0a1 (2020-03-26). Please test again.

Flags: needinfo?(dougskis)

Today spinning circle is back for comments.
76.0a1 (2020-03-26) (64-bit)

Flags: needinfo?(dougskis)

After my earlier post today I checked if comments were viewable in FF 75.0b10 (64-bit) and I could view comments. Then I clear history in Nightly and comments are now viewable.
Thought I would add what I did today to view comments in Youtube.

Couldn't reproduce it on 76.0a1 (2020-03-27).

Comments are visible today. 76.0a1 (2020-03-28)

77.0a1 (2020-04-19) (64-bit)

Still having trouble with comments not being visible in Youtube. Tried pasting spinning circle.
Comments are visible with 75.0 (64-bit).

What can I do to try and find out why comments won't show up in YouTube with Nightly?
77.0a1 (2020-04-22) (64-bit)

Because this bug's Severity has not been changed from the default since it was filed, and it's Priority is -- (Backlog,) indicating it has has not been previously triaged, the bug's Severity is being updated to -- (default, untriaged.)

Because this bug's Severity has not been changed from the default since it was filed, and it's Priority is -- (Backlog,) indicating it has has not been previously triaged, the bug's Severity is being updated to -- (default, untriaged.)

Because this bug's Severity has not been changed from the default since it was filed, and it's Priority is -- (Backlog,) indicating it has has not been previously triaged, the bug's Severity is being updated to -- (default, untriaged.)

Severity: normal → S3

The severity of these bugs was changed, mistakenly, from normal to S3.

Because these bugs have a priority of --, indicating that they have not been previously triaged, these bugs should be changed to Severity of --.

Severity: S3 → --

Hey Doug,

Try updating to the latest Nightly and see if this fixes the issue. Download the build from : https://www.mozilla.org/en-US/firefox/nightly/all/

Also please see if you can test the issue while in Safe Mode. You can find helpful info here : https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode .

A fresh new profile could help. You can find more about creating a new profile here : https://support.mozilla.org/en-US/kb/troubleshoot-and-diagnose-firefox-problems#w_6-create-a-new-firefox-profile .

Flags: needinfo?(dougskis)

My problem is intermittent, today when I viewed Youtube comments were visible, left and went back to same site and comments were missing again, just a spinning circle. As I have stated in earlier post, I don't have this problem with regular version of FF or Chrome.

Nightly build 78.0a1 (2020-05-12) (64-bit)

https://www.youtube.com/watch?v=SRUQfoXFAc4 ((I tried other Youtube sites as well, same problem))

I was on Youtube and comments were showing up, I also checked FF 76.0.1 (64-bit) and had comments.
When I reopen Nightly and went back to the same Youtube page, comments were missing. I opened developer tools and I found

Some cookies are misusing the “sameSite“ attribute, so it won’t work as expected 52
Source map error: Error: request failed with status 404
Resource URL: https://www.youtube.com/yts/jsbin/webcomponents-sd-vflU6Ffk_/webcomponents-sd.js
Source Map URL: webcomponents-sd.js.sourcemap

Source map error: Error: request failed with status 404
Resource URL: https://www.youtube.com/yts/jsbin/custom-elements-es5-adapter-vflsrwHZH/custom-elements-es5-adapter.js
Source Map URL: fast-shim.js.sourcemap

Source map error: Error: request failed with status 404
Resource URL: https://www.youtube.com/yts/jsbin/web-animations-next-lite.min-vflKXbQMP/web-animations-next-lite.min.js
Source Map URL: web-animations-next-lite.min.js.map

FF 76.0.1 (64-bit)

I have comments and always had comments when not using FF Nightly build.

https://www.youtube.com/watch?v=SRUQfoXFAc4

Some cookies are misusing the recommended “sameSite“ attribute 40
MouseEvent.mozPressure is deprecated. Use PointerEvent.pressure instead. desktop_polymer_inlined_html_polymer_flags_v2.js:1338:45
Autoplay is only allowed when approved by the user, the site is activated by the user, or media is muted. base.js:6040:33
This site appears to use a scroll-linked positioning effect. This may not work well with asynchronous panning; see https://developer.mozilla.org/docs/Mozilla/Performance/ScrollLinkedEffects for further details and to join the discussion on related tools and features! UCHkYOD-3fZbuGhwsADBd9ZQ
Source map error: Error: request failed with status 404
Resource URL: https://www.youtube.com/yts/jsbin/custom-elements-es5-adapter-vflsrwHZH/custom-elements-es5-adapter.js
Source Map URL: fast-shim.js.sourcemap

Source map error: Error: request failed with status 404
Resource URL: https://www.youtube.com/yts/jsbin/webcomponents-sd-vflU6Ffk_/webcomponents-sd.js
Source Map URL: webcomponents-sd.js.sourcemap

Source map error: Error: request failed with status 404
Resource URL: https://www.youtube.com/yts/jsbin/web-animations-next-lite.min-vflKXbQMP/web-animations-next-lite.min.js
Source Map URL: web-animations-next-lite.min.js.map

I don't see how running in Safe Mode or creating a new profile would make any difference when I do not have any problems with regular version of FF or Chrome.

Uncle

Flags: needinfo?(dougskis)

Bugbug thinks this bug should belong to this component, but please revert this change in case of error.

Product: Firefox → WebExtensions

From comment 0:

Do not have any addons or add blockers enabled

Product: WebExtensions → Firefox

Can you please try to clear cookies and site data? Let's see if this might fix the issue.

Flags: needinfo?(dougskis)

I do not have any addons or add blockers enabled. I have cleared cookies, sometimes it works sometimes it doesn't.

You can close this, I find it hard to believe I am the only one with this problem using Nightly. As I stated in previous post I do not have the problem with released version of FF or Chrome. I do not have to clear cookies with them. Thought it was a bug with Nightly.

Doug

Flags: needinfo?(dougskis)

Setting a component for this issue in order to get the dev team involved.
If you feel it's an incorrect one please feel free to change it to a more appropriate one.

Component: Untriaged → Graphics: Text
Product: Firefox → Core

Not Graphics related, moving to networking due to sameSite "clue".

Component: Graphics: Text → Networking

baku, can you look at this is mentions same-site cookies. Let' me know if you are not the right person

Flags: needinfo?(amarchesini)
Status: UNCONFIRMED → RESOLVED
Closed: 1 month ago
Resolution: --- → WORKSFORME

I had forgotten about this since I haven't been having problems, comments are working.
I should have stated issue is resolved.

You need to log in before you can comment on or make changes to this bug.