Closed Bug 1624533 Opened 3 years ago Closed 3 years ago

Webrender support windowed plugins

Categories

(Core :: Graphics: WebRender, enhancement, P3)

68 Branch
enhancement

Tracking

()

RESOLVED WONTFIX

People

(Reporter: wangqing-hf, Unassigned)

References

Details

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_14_0) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/62.0.3189.0 Safari/537.36

Actual results:

I want to run a windowed plugin under webrender,but the plugin does not display

Depends on: 1390440

1390440 Only support windowless plugin,windowed plugin only support OpenGL when disable webrender

I expect windowed plugin would be support in webrender, Because there are still many application scenarios, thanks!

Can you share the URL of the page that doesn't work?

Flags: needinfo?(wangqing-hf)

You can just open a video website and set the flash to windowed mode to play it.

Flags: needinfo?(wangqing-hf)

I completed the re-support of windowed plugin by 1338172.
You can just open a video website and set the flash to windowed mode to play it.

I don't know of any sites that still use flash for video. Can you give an example?

Flags: needinfo?(wangqing-hf)

you could set dom.mp4.enabled=false, and open any video sites.

Flags: needinfo?(wangqing-hf)
Blocks: wr-77
Priority: -- → P3

I want to run a windowed plugin under webrender,but the plugin does not display

1390440 Only support windowless plugin,windowed plugin only support OpenGL when disable webrender

Because there are still many application scenarios

This is not advisable. (Please wontfix.) From the perspective of Nightly, Flash support gets removed in 6 months in October (bug 1455897). With that, any support for windowed mode plugins will be removed, too. (bug 1296400 comment 10)
On Linux, WebRender is not enabled by default yet. Flash removal is also a blocker for enabling the Wayland backend by default. (bug 1543600)

https://developer.mozilla.org/en-US/docs/Plugins/Roadmap

In December 2020, Flash support will be completely removed from consumer versions of Firefox. Adobe will stop shipping security updates for Flash at the end of 2020.

Indeed.

Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.