Closed Bug 1624857 Opened 6 months ago Closed 4 months ago

AttributeError: 'timeout' object has no attribute 'with_traceback'

Categories

(Testing :: Mochitest, defect, P3)

Version 3
defect

Tracking

(firefox-esr68 unaffected, firefox76 wontfix, firefox77 wontfix, firefox78 fixed)

RESOLVED FIXED
mozilla78
Tracking Status
firefox-esr68 --- unaffected
firefox76 --- wontfix
firefox77 --- wontfix
firefox78 --- fixed

People

(Reporter: gbrown, Assigned: gbrown)

References

(Blocks 2 open bugs, Regression)

Details

(Keywords: regression)

Attachments

(1 file)

Should runtests.py / runtestsremote.py be run only with Py3? Or should those scripts be compatible with Py2 and Py3?

I suppose a Py3 venv for mozharness is needed in order to run a test harness in python 3. There is support for that at

https://searchfox.org/mozilla-central/rev/4d9cd186767978a99dafe77eb536a9525980e118/testing/mozharness/mozharness/base/python.py#746

but that's only currently used by Talos (!). And it seems to be conveniently applicable only to an entire mozharness script, not a subset of test suites.

So I think runtests.py / runtestsremote.py need to remain Py2 compatible for the time being.

The priority flag is not set for this bug.
:ahal, could you have a look please?

For more information, please visit auto_nag documentation.

Flags: needinfo?(ahal)
Flags: needinfo?(ahal)
Priority: -- → P3

Definitely looks like a bug, mochitest doesn't support Python 3 yet.. Seems worth fixing in the meantime.

Because this bug's Severity has not been changed from the default since it was filed, and it's Priority is P3 (Backlog,) indicating it has been triaged, the bug's Severity is being updated to S3 (normal.)

Severity: normal → S3
See Also: → 1640830
Assignee: nobody → gbrown
Status: NEW → ASSIGNED
See Also: 1640830
Duplicate of this bug: 1640830
Pushed by gbrown@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/cfdcb6fd0572
Resolve intermittent mochitest AttributeError on with_traceback; r=bc
Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla78
You need to log in before you can comment on or make changes to this bug.