If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

unread count not updated on collapsed news and mail threads

VERIFIED DUPLICATE of bug 74835

Status

SeaMonkey
MailNews: Message Display
VERIFIED DUPLICATE of bug 74835
15 years ago
13 years ago

People

(Reporter: Ric Cefis, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: DUPEME)

(Reporter)

Description

15 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; FreeBSD i386; en-US; rv:1.0.0) Gecko/20020607
BuildID:    0000000000

[Note: I'm using a FreeBSD port build of Mozilla 1.0; FreeBSD 4.5; I've also
verified this on nightly 2002080606]

Unread column is selected for display in news.

When a thread is selected, but still collapsed, pressing "r" to mark the thread
as read does not update the unread count. Subsequently expanding the thread will
update it.

Doing this on an already expanded thread will update the count appropriately.
Pressing the UI button for Mark thread as Read has the same effect as pressing "r".

This obviously is only a cosmetic fix, but it deserves some attention. (I've
left the severity as normal for now)

Reproducible: Always
Steps to Reproduce:
1. Open Mailnews
2. Select any newsgroup
3. Select the first message of collapsed thread.
4. Mark thread as read (press "r")

Actual Results:  Thread unread count is unchanged

Expected Results:  Thread unread count should be set to zero (should display a
blank under the Unread column)

Updated

15 years ago
QA Contact: olgam → laurel
Whiteboard: DUPEME
(Reporter)

Comment 1

15 years ago
I'd like to clarify some information in this bug.

First, the Unread count to which I was referring was in the Header pane. The
unread count in the Account pane is updated correctly and instantaneously.

Second, once the actions listed in the initial comment are performed, the unread
count for the thread hasn't changed; once any other action is performed
(expanding thread, selecting another message etc), the unread count is updated
correctly (it shows a blank in the Unread column).

Third, this happens in mail accounts also, not just in newsgroups (updating
summary to reflect this)

Fourth, I gained access to a WinXP machine with Mozilla 1.0 (build 2002053012);
it exhibits the same problem. Curiously, this behaviour did not occur if it was
the first time I downloaded headers for that group (ie - I just subscribed to
the group). That is, I subscribed to the group, downloaded 100 headers, and
selected a collapsed thread. I pressed "r" and the Unread count updated
successfully. I then selected another thread and pressed "r"; this time, the bug
manifested itself, and the Unread cound was not updated.
Summary: unread count not updated on collapsed news threads → unread count not updated on collapsed news and mail threads
(Reporter)

Comment 2

15 years ago
I tested this on Moz1.1 release for WinXP (it identifies itself as build
20020826), and the problem persists. Updating OS to all.

Hopefully the greater number of WinXP users (compared to FreeBSD) will result in
someone being able to DUPE this bug.
OS: FreeBSD → All

Comment 3

15 years ago

*** This bug has been marked as a duplicate of 74835 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 4

15 years ago
marking verified as a duplicate
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.