ign.com crashes mozilla if mozilla is not launched with a parameter (-P , -mail, ...) [@ _destroyJSDObject]

VERIFIED WORKSFORME

Status

--
critical
VERIFIED WORKSFORME
16 years ago
14 years ago

People

(Reporter: mozbug, Assigned: rginda)

Tracking

({crash})

Trunk
x86
Windows XP
crash

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
Trying to load ign.com crashes mozilla

2002081304 XP Pro on an Athlon XP2000+

1. launch mozilla.exe
2. Load http://ign.com
3. Crash

1. launch mozilla.exe -P my_profile_name
2. load http://ign.com
3. page loads

Talkback does not show up.
(Reporter)

Comment 1

16 years ago
With the -P options, Mozilla crashes when exiting.

Talkback id : TB9303494E
(Reporter)

Comment 2

16 years ago
Further tests show me that mozilla crashes if it is not launched with a parameter.
I tried -P, -mail and every time Mozilla loads ign.com without crashing.
Assignee: ccarlen → law
Component: Profile Manager BackEnd → XP Apps: Cmd-line Features
QA Contact: ktrina → sairuh
Summary: ign.com crashes mozilla if mozilla is not launched with -P → ign.com crashes mozilla if mozilla is not launched with a parameter (-P , -mail, ...)

Updated

16 years ago
Keywords: crash, stackwanted
Whiteboard: [has TB ID] TB9303494E

Comment 3

16 years ago
Incident ID 9303494
Stack Signature ntdll.dll + 0x215c (0x77f4215c) dc0b72fb
Email Address mozbug@durys.net
Product ID MozillaTrunk
Build ID 2002081304
Trigger Time 2002-08-13 09:49:06
Platform Win32
Operating System Windows NT 5.1 build 2600
Module ntdll.dll
URL visited
User Comments
Trigger Reason Access violation
Source File Name
Trigger Line No.
Stack Trace
ntdll.dll + 0x215c (0x77f4215c)
ntdll.dll + 0x1fbf (0x77f41fbf)
msvcrt.dll + 0x1ab2e (0x77bfab2e)
_destroyJSDObject [c:/builds/seamonkey/mozilla/js/jsd/jsd_obj.c, line 111]
jsd_ObjectHook [c:/builds/seamonkey/mozilla/js/jsd/jsd_obj.c, line 180]
js_FinalizeObject [c:/builds/seamonkey/mozilla/js/src/jsobj.c, line 1817]
js_GC [c:/builds/seamonkey/mozilla/js/src/jsgc.c, line 1292]
js_ForceGC [c:/builds/seamonkey/mozilla/js/src/jsgc.c, line 986]
js_DestroyContext [c:/builds/seamonkey/mozilla/js/src/jscntxt.c, line 243]
nsJSContext::~nsJSContext
[c:/builds/seamonkey/mozilla/dom/src/base/nsJSEnvironment.cpp, line 467]
nsJSContext::`scalar deleting destructor'
nsJSContext::Release
[c:/builds/seamonkey/mozilla/dom/src/base/nsJSEnvironment.cpp, line 499]
nsCOMPtr_base::assign_with_AddRef
[c:/builds/seamonkey/mozilla/xpcom/glue/nsCOMPtr.cpp, line 74]
nsXULPrototypeDocument::~nsXULPrototypeDocument
[c:/builds/seamonkey/mozilla/content/xul/document/src/nsXULPrototypeDocument.cpp,
line 261]
nsXULPrototypeDocument::`scalar deleting destructor'
nsXULPrototypeDocument::Release
[c:/builds/seamonkey/mozilla/content/xul/document/src/nsXULPrototypeDocument.cpp,
line 271]
nsProperties::ReleaseValues
[c:/builds/seamonkey/mozilla/xpcom/ds/nsProperties.cpp, line 70]
_hashEnumerate [c:/builds/seamonkey/mozilla/xpcom/ds/nsHashtable.cpp, line 205]
PL_HashTableEnumerateEntries [plhash.c, line 430]
nsHashtable::Enumerate [c:/builds/seamonkey/mozilla/xpcom/ds/nsHashtable.cpp,
line 369]
nsSupportsHashtable::~nsSupportsHashtable
[c:/builds/seamonkey/mozilla/xpcom/ds/nsHashtable.cpp, line 951]
nsXULPrototypeCache::~nsXULPrototypeCache
[c:/builds/seamonkey/mozilla/content/xul/document/src/nsXULPrototypeCache.cpp,
line 210]
nsXULPrototypeCache::Release
[c:/builds/seamonkey/mozilla/content/xul/document/src/nsXULPrototypeCache.cpp,
line 210]
nsXULPrototypeScript::ReleaseGlobals
[c:/builds/seamonkey/mozilla/content/build/../xul/content/src\nsXULElement.h,
line 331]
Shutdown [c:/builds/seamonkey/mozilla/content/build/nsContentModule.cpp, line 261]
nsGenericModule::Shutdown
[c:/builds/seamonkey/mozilla/xpcom/glue/nsGenericFactory.cpp, line 325]
nsDll::Shutdown [c:/builds/seamonkey/mozilla/xpcom/components/xcDll.cpp, line 394]
nsFreeLibrary
[c:/builds/seamonkey/mozilla/xpcom/components/nsNativeComponentLoader.cpp, line 309]
nsFreeLibraryEnum
[c:/builds/seamonkey/mozilla/xpcom/components/nsNativeComponentLoader.cpp, line 358]
_hashEnumerate [c:/builds/seamonkey/mozilla/xpcom/ds/nsHashtable.cpp, line 205]
PL_HashTableEnumerateEntries [plhash.c, line 430]
nsHashtable::Enumerate [c:/builds/seamonkey/mozilla/xpcom/ds/nsHashtable.cpp,
line 369]
nsNativeComponentLoader::UnloadAll
[c:/builds/seamonkey/mozilla/xpcom/components/nsNativeComponentLoader.cpp, line 949]
nsComponentManagerImpl::UnloadLibraries
[c:/builds/seamonkey/mozilla/xpcom/components/nsComponentManager.cpp, line 2961]
nsComponentManagerImpl::Shutdown
[c:/builds/seamonkey/mozilla/xpcom/components/nsComponentManager.cpp, line 861]
NS_ShutdownXPCOM [c:/builds/seamonkey/mozilla/xpcom/build/nsXPComInit.cpp, line 706]
main [c:/builds/seamonkey/mozilla/xpfe/bootstrap/nsAppRunner.cpp, line 1884]
WinMain [c:/builds/seamonkey/mozilla/xpfe/bootstrap/nsAppRunner.cpp, line 1894]
WinMainCRTStartup()
kernel32.dll + 0x1eb69 (0x77e5eb69) 

Comment 4

16 years ago
top is venkman, next is xul.
Assignee: law → rginda
Component: XP Apps: Cmd-line Features → JavaScript Debugger
Keywords: stackwanted
QA Contact: sairuh → caillon
Summary: ign.com crashes mozilla if mozilla is not launched with a parameter (-P , -mail, ...) → ign.com crashes mozilla if mozilla is not launched with a parameter (-P , -mail, ...) [@ _destroyJSDObject]
Whiteboard: [has TB ID] TB9303494E

Comment 5

16 years ago
I don't crash on the page, but if I close Mozilla down while viewing the page, I
get a crash at the following location:

nsEventListenerManager::`scalar deleting destructor'(nsEventListenerManager *
const 0x021c65c8, unsigned int 0x00000001) + 21 bytes
nsEventListenerManager::Release(nsEventListenerManager * const 0x021c65c8) line
190 + 24 bytes
nsCOMPtr_base::~nsCOMPtr_base(nsCOMPtr_base * const 0x021c65c8) line 65
PL_DHashTableFinish(PLDHashTable * 0x017a8989) line 322 + 7 bytes
nsGenericElement::Shutdown() line 759
Shutdown(nsIModule * 0x00f33060) line 235
nsGenericModule::Shutdown(nsGenericModule * const 0x021c65c8) line 323 + 3 bytes
nsTimerManager::Release(nsTimerManager * const 0x00f33060) line 501 + 32 bytes
nsDll::Shutdown(nsDll * const 0x021c65c8) line 383 + 6 bytes
nsFreeLibrary(nsDll * 0x01823478 `string', nsIServiceManager * 0x00000041, int
0x018059d8) line 309

Comment 6

16 years ago
Created attachment 95302 [details]
Stack of crash from debug build

I should have mentioned this was a trunk build from today. This looks like
mListenerManager was already destroyed somehow. The memory pointed to is filled
with 0xdd bytes.
(Reporter)

Comment 7

16 years ago
I still crash on that page (http://gamefaqs is another crasher) with 2002081409.

I tried nightlies up to 2002080419 and Mozilla 1.1a|b but still crash.
Mozilla 1.0 doesn't crash.
 

Comment 8

16 years ago
*** Bug 162832 has been marked as a duplicate of this bug. ***

Comment 9

16 years ago
WFM - Build ID: 2002121215 (Mozilla 1.3a) WinXP sp1 w/Flash installed

ie. page renders, no crash

Comment 10

15 years ago
worksforme with 2004021709 seamonkey build on winXP.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
Product: Core → Other Applications
(Reporter)

Comment 11

14 years ago
WFM too
Status: RESOLVED → VERIFIED
Crash Signature: [@ _destroyJSDObject]
You need to log in before you can comment on or make changes to this bug.