Closed Bug 162522 Opened 17 years ago Closed 17 years ago

[RFE] Allow detecting which newsgroups on a server have Unread messages in a Watched thread

Categories

(MailNews Core :: Backend, enhancement)

x86
All
enhancement
Not set

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 127692

People

(Reporter: knocte, Assigned: mscott)

Details

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.1b) Gecko/20020721
BuildID:    2002072104

Request for enhancement:
When you post a message on a newsgroup, you cannot know if anybody has answered
to that message, unless you check the newsgroup often and check on your own.
My proposal consists in creating a process to detect if there have been answers
to messages posted on newsgroups.

Reproducible: Always
Steps to Reproduce:
Post a message on a newsgroup. You want to know if there is an answer.

Actual Results:  You have to check the newsgroup to search replies (sometimes
you don't remember all the messages you have posted and you miss some replies!).

Expected Results:  For example, right click the newsgroup and select a command
like "Jump to next reply" or "Detect replies".

Logically, the process should detect the replies by searching the Identity of
the newsgroup account, and checking if there is a reply.
QA Contact: gayatri → stephend
This is basically a dup of 11048.
Knocte:
Please take a look at http://bugzilla.mozilla.org/show_bug.cgi?id=11048 and if
you agree that this is a duplicate, mark this bug as a dup.
If you think that this is different, please explain the differences.

Thank you
Alfonso Martinez, I have been reading the bug you proposed me and all the bugs
that are related to this one.
If I have understood well hte thing, I think that the feature
"View->Messages->Watched Threads with Unread" should fix my problem someway, but
I have tried this command personally on my build and it doesn't show me any
thread (!!), and of course I am sure that the newsgroup in which I tried it had
some Unread threads that were replies to threads already watched (read). (I am
supposing that, when you read a post, it is marked as watched, am I wrong? if
not, how can I mark a thread as watched?).

Anyway, my RFE would detect unread messages on all newsgroups in a server.
However, the feature "View->Messages->Watched Threads with Unread" would detect
unread messages on the newsgroup in which the user is located. So, I think this
is not exactly a dup.

What do you think?
Ok ok! I was wrong. I didn't understand the "Watch" feature, because I thought
that this option was on the contextual (right-click) menu when selecting a
message. Now I see that the option is on "Message->Watch Thread".

Well, this feature solves my problem only on one newsgroup, but my bug covers
all newsgroups in a server.

Now, I think I should change the title of the bug to something more related with
watched threads. Let me see...

And what about putting the option "Watch Thread" on the right-click contextual
menu, should I open a RFE related to this?
Summary: [RFE] Allow detecting replies to own messages on newsgroup servers → [RFE] Allow detecting which newsgroups on a server have Watched threads with Unread messages
Summary: [RFE] Allow detecting which newsgroups on a server have Watched threads with Unread messages → [RFE] Allow detecting which newsgroups on a server have Unread messages in a Watched thread
I don't think that a bug about adding an item to the context menu would be
succesful (but of course you can try) as there is already a shortcut 'w' to mark
a thread as watched and the general direction is try to clean up the interface,
not to add more options.

I think that your proposed behaviour is currently possible just by selecting
"View->Messages->Watched Threads with Unread" as you have pointed out, and
selecting this view for all the newsgroups. (and until bug 11048 is fixed you
have to manually watch the threads that you are interested in)
I disagree because if you are subscribed to 200 newsgroups on a server, and if
you want to know in which newsgroups are there unread messages on watched
threads, do you have to look in every newsgroup? inside 200 newsgroups?
(Supposing you don't remember where you have watched threads.)
My RFE solves this problem, hipothetically.
Can we mark the bug as new?
According to the last comments this is a dup of 127692
"Newsgroups with new messages in watched threads should be highlighted"

*** This bug has been marked as a duplicate of 127692 ***
Status: UNCONFIRMED → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
Yeah, now I agree ;) I'll vote for bug 127692.
Thank you very much for your comments.
verified dup
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.