Closed Bug 1625264 Opened 4 months ago Closed 4 months ago

The Firefox Monitor card flickers on about:protections load

Categories

(Firefox :: Protections UI, defect, P1)

defect

Tracking

()

VERIFIED FIXED
Firefox 76
Tracking Status
firefox-esr68 --- unaffected
firefox74 --- unaffected
firefox75 --- wontfix
firefox76 --- verified

People

(Reporter: itiel_yn8, Assigned: ewright)

References

(Regression)

Details

(Keywords: regression)

Attachments

(2 files)

Attached image Screencast.gif
No description provided.

This is reproducible on a new profile, even more so on a used profile.

(In reply to Itiel from comment #1)

This is reproducible on a new profile, even more so on a used profile.

Thank you for reporting the issue.
Does this regression on both 75 Beta and 76 Nightly?
Could you provide steps to reproduce?

Flags: needinfo?(itiel_yn8)

(In reply to Ethan Tseng [:ethan] from comment #2)

Thank you for reporting the issue.
Does this regression on both 75 Beta and 76 Nightly?

I haven't tested this on beta, but I believe it is also affected as bug 1612088 was fixed in 75.

Could you provide steps to reproduce?

Nothing special, just load about:protections, scroll down to the Firefox Monitor card and hit F5.

Flags: needinfo?(itiel_yn8)

I asked for STR because I didn't see this issue on the about:protections on Nightly 76.
My environment

OS: macOS 10.14.6
Firefox: 76.0a1 (2020-03-27)

Perhaps providing your environment would be helpful?

I don't see it on a new profile. But I think I see it on my existing profile, it's difficult to see because it's below the fold on my screen. I think those elements used to be hidden during loading and at some point were revealed. I can take this, I recall moving some things around there recently.

Assignee: nobody → ewright
Status: NEW → ASSIGNED

(In reply to Ethan Tseng [:ethan] from comment #4)

Perhaps providing your environment would be helpful?

I'm on Windows 10, using latest Nightly.

(In reply to Erica Wright [:ewright] from comment #5)

I don't see it on a new profile. But I think I see it on my existing profile, it's difficult to see because it's below the fold on my screen. I think those elements used to be hidden during loading and at some point were revealed. I can take this, I recall moving some things around there recently.

For me continuously hitting F5 would show this issue on a new profile.
Also zooming out and refreshing can help.

Priority: -- → P1
Pushed by ewright@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/98e0adb65668
Firefox monitor card does not flicker when loading. r=prathiksha
Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 76
Flags: qe-verify+

I've managed to reproduce this issue on an affected Firefox nightly from 2020-03-26 on Ubuntu 18.04x64.
This issue is verified fixed on Firefox 76.0b4 using Windows 10x64, Ubuntu 18.04x64, macOS 10.15.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.