Closed Bug 1625297 Opened 5 months ago Closed 5 months ago

[Direct3D 11 (Advanced Layers)] Graphics Compositing back-end changes to Direct 3D 11 from Direct3D 11 (Advanced Layers) after Trigger Device Reset

Categories

(Core :: Graphics: Layers, defect)

Desktop
Windows 10
defect
Not set
normal

Tracking

()

VERIFIED FIXED
mozilla76
Tracking Status
firefox-esr68 --- unaffected
firefox74 --- unaffected
firefox75 --- unaffected
firefox76 --- verified

People

(Reporter: alice0775, Assigned: sotaro)

References

(Regression)

Details

(Keywords: nightly-community, regression)

Attachments

(3 files)

Steps to reproduce:

  1. Observe Graphics Compositing from about:support
  2. Click [Trigger Device Reset] in about:support
  3. Reload about:support and Observe Graphics Compositing

Actual Results:
Graphics Compositing back-end is Direct 3D 11.

Expected Results:
Graphics Compositing back-end should be Direct3D 11 (Advanced Layers) as before TDR.

Regression window:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=5df10174a0ae5df64b5b937eefc725ca18e0ebfa&tochange=f220a983f0281fd87e662c649ae5cb596b4eceb6

Has Regression Range: --- → yes
Has STR: --- → yes
Assignee: nobody → sotaro.ikeda.g

When device reset happens, Feature::ADVANCED_LAYERS is reset by gfxWindowsPlatform::HandleDeviceReset(). Then gfxWindowsPlatform::InitializeAdvancedLayersConfig() needs to be called again.

Ideally, it seems better to call InitWebRenderConfig() in the HandleDeviceReset(). But it changes how WebRender config is set. Then in this bug, call InitializeAdvancedLayersConfig() in the HandleDeviceReset().

(In reply to Sotaro Ikeda [:sotaro] from comment #3)

Ideally, it seems better to call InitWebRenderConfig() in the HandleDeviceReset().

Created Bug 1625382 for the above.

Pushed by sikeda.birchill@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/846bb08e41e1
Add InitializeAdvancedLayersConfig() call in gfxWindowsPlatform::HandleDeviceReset() r=nical
Status: NEW → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla76
Flags: qe-verify+

Reproduced the issue using Firefox 76.0a1 (20200326213652) on Windows 10x64 using STR from comment 0.
The issue is verified fixed using Firefox 76.0a1 (20200331043143) from comment 7 on Windows 10x64. The Direct3D 11 (Advanced Layers) is displayed after hitting [Trigger Device Reset].

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.