Closed Bug 1625442 Opened 3 years ago Closed 1 year ago

[Wayland] Firefox takes time to load page - browser freeze

Categories

(Core :: Widget: Gtk, defect, P3)

75 Branch
defect

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: friedrichin, Unassigned)

References

(Blocks 1 open bug)

Details

Attachments

(2 files)

Attached image freeze.png

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:75.0) Gecko/20100101 Firefox/75.0

Steps to reproduce:

  1. Visit the page https://reinteractive.com/
  2. Try clicking on "Ruby on Rails" and "Salesforce Solution" for couple of times

Actual results:

The browser kind of freezes and loads after sometime. Or we should press any key to load the page completely. (try opening a tab when page is loading)

Expected results:

The page should not freeze and should load quickly.

Just to clarify: this is an issue with Firefox running on Xwayland (you can check if Window Protocol in about:support is set to X11) and you don't have this issue with Firefox running on X11?

Flags: needinfo?(friedrichin)

Bugbug thinks this bug should belong to this component, but please revert this change in case of error.

Component: Untriaged → Widget: Gtk
Product: Firefox → Core
Component: Widget: Gtk → Untriaged
Product: Core → Firefox

Yes, window Protocol shows "Wayland".

Works perfectly fine with Firefox running on X11.

Flags: needinfo?(friedrichin)

I tried on Debian Testing 11 running Wayland with Firefox Developer running in Wayland mode and didn't experience the freeze. I also tried with Firefox running in X11 mode (Xwayland) on Wayland and didn't notice any difference.

Wayland mode can be enabled with the MOZ_ENABLE_WAYLAND env variable and X11 mode can be forced with GDK_BACKEND=x11.

Window Protocol can be checked in about:support.

Please find the video clip where the browser freeze happens.

Can you please try latest nightly?
Thanks.

Flags: needinfo?(friedrichin)
Blocks: wayland
Summary: Wayland support for firefox takes time to load page → [Wayland] Firefox takes time to load page - browser freeze
Component: Untriaged → Widget: Gtk
Priority: -- → P3
Product: Firefox → Core

Tested with Firefox nightly and same issue persists. Thanks.

Flags: needinfo?(friedrichin)

Thanks for testing. Can you try to set "widget.wayland.use-opaque-region" to false at about config and try again?
Thanks.

Flags: needinfo?(friedrichin)

I have been testing it from yesterday by setting "widget.wayland.use-opaque-region" to false and it works without any major issues..

Only one small issue that is noticed is when the connection is very slow then the browser freezes until it is loaded completely. We cannot switch to other tabs or open new one by mouse click. We can only change the tabs from keyboard shortcut.

You can test this scenario by going to inspect -> Network. Switch No Throttling to GPRS.

Flags: needinfo?(friedrichin)

Because this bug's Severity has not been changed from the default since it was filed, and it's Priority is P3 (Backlog,) indicating it has been triaged, the bug's Severity is being updated to S3 (normal.)

Severity: normal → S3

Something similar happens to me just editing and moving around on https://hackmd.io/ and many other sites too.

Closing as WORKSFORME, please reopen if you still see it.
Thanks.

Status: UNCONFIRMED → RESOLVED
Closed: 1 year ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.