CTRL-click on multi-select scrollbar always causes crash

RESOLVED DUPLICATE of bug 137867

Status

()

Core
Layout: Form Controls
--
minor
RESOLVED DUPLICATE of bug 137867
16 years ago
16 years ago

People

(Reporter: Joe Grossberg, Assigned: rods (gone))

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
This bug has been around for months, but my latest version is Mozilla 1.0 ...
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0) Gecko/20020605

When I have a multiple-select box, and I CTRL-click the scrollbar (for example,
I've been control-clicking some items and then I try to scroll down), the
browser freezes up. This does not happen if I've released the CTRL button.

What I mean by this is that the browser, and all other mozilla tabs and windows
stop functioning. I can select/deselect and raise/lower the windows, but that's
it. To escape, I have to "kill" the process in question.

It has happened to me with both KDE and GNOME.

I can't give you the URL because it is a password-protected page. Let me know if
you need me to quickly throw together a sample page.
(Reporter)

Comment 1

16 years ago
clarification: it only happens when I click on the arrow (not the area between
them) and doesn't occur on http://bugzilla.mozilla.org/query.cgi, so I'm going
to check my HTML for problems
(Reporter)

Comment 2

16 years ago
Note: I changed the HTML from

<select name=attribute size="7" multiple="yes">

to

<select name="attribute" size="7" multiple="multiple">

and it no longer crashes.

Perhaps the crash was related to the "yes" value for the multiple attr?
Severity: major → minor

Comment 3

16 years ago
dupe of "hang after shift/ctrl while dragging listbox scrollbar"

multiple="multiple" is invalid AFAIK, so it probably defaults back to "no"

*** This bug has been marked as a duplicate of 137867 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 4

16 years ago
no, this is NOT a duplicate

this bug:
1) happens when clicking on the scrollbar of a multi-select
2) causes a fatal crash

other bug:
1) happens when clicking on an item in a multi-select
2) hangs for a short while

not the same thing! All they have in common is that the CTRL key and some part
of a multi-select are involved.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 5

16 years ago
your own description:
> What I mean by this is that the browser, and all other mozilla tabs and 
> windows stop functioning. I can select/deselect and raise/lower the windows, 
> but that's it. To escape, I have to "kill" the process in question.

you have described a hang, not a crash.

> other bug:
> 1) happens when clicking on an item in a multi-select
> 2) hangs for a short while

wrong on both counts.  the bug is that if you hit ctrl or shift while scrolling,
or if you scroll while holding ctrl or shift, that the browser hangs forever. 
This is the situation you have described in this bug.
(Reporter)

Comment 6

16 years ago
my apologies; it is a duplicate then.

thanks!

*** This bug has been marked as a duplicate of 137867 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.