Need ability to search on 'Label' criteria

VERIFIED FIXED

Status

SeaMonkey
MailNews: Message Display
VERIFIED FIXED
16 years ago
9 years ago

People

(Reporter: Scott MacGregor, Assigned: Scott MacGregor)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

5.42 KB, patch
Navin Gupta
: review+
(not reading, please use seth@sspitzer.org instead)
: superreview+
Details | Diff | Splinter Review
(Assignee)

Description

16 years ago
I want the ability to do a search for all my messages labeled "important" or
labeled "work".

I need this for another project I'm working on. I have a patch. Coming up.
(Assignee)

Comment 1

16 years ago
taking. 
Assignee: naving → mscott
(Assignee)

Comment 2

16 years ago
Created attachment 95167 [details] [diff] [review]
the fix

Note: this just adds the back end plumbing for searching by label so someone
could perform a search by label. It does not expose it in the advanced search
UI, so there is no impact to the UI team or QA.

Especially since right now no one but my prototype calls this new
functionality.

Comment 3

16 years ago
*** Bug 115614 has been marked as a duplicate of this bug. ***

Comment 4

16 years ago
Comment on attachment 95167 [details] [diff] [review]
the fix

looks ok, r=naving
Attachment #95167 - Flags: review+
Comment on attachment 95167 [details] [diff] [review]
the fix

sr=sspitzer
Attachment #95167 - Flags: superreview+
Now that we have this, should we spin up a seperate RFE bug about adding UI (to
advanced search) for labels?

Comment 7

16 years ago
> Now that we have this, should we spin up a seperate RFE bug about adding UI (to
> advanced search) for labels?

According to bug 115614 comment 7, bug 115614 will be used for the UI
implementation.
Blocks: 115614
(Assignee)

Comment 8

16 years ago
fixed
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Comment 9

15 years ago
marking verified... OK with oct14 commercial trunk, verified bug 115614.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey

Updated

9 years ago
Component: MailNews: Search → MailNews: Message Display
QA Contact: laurel → search
You need to log in before you can comment on or make changes to this bug.