Rendering simple HTML pages shifts 2 pixels down for each line in the page.

RESOLVED WORKSFORME

Status

()

Core
Layout
P2
normal
RESOLVED WORKSFORME
16 years ago
16 years ago

People

(Reporter: Moied, Assigned: Shanjian Li)

Tracking

({testcase})

Trunk
x86
Windows XP
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

16 years ago
Rendering simple HTML pages shifts 2 pixels down for each line in the page.

Rendering of a simple HTML pages is different when compared with different
branch builds, this is a regression bug since Build 2002-07-24-08-1.0. Open
attached test case with 2002-07-24-08-1.0 build renders fine, but when rendered
in any builds after 2002-07-25-08-1.0 we can observe there is a shit of 2 pixels
for each line in the HTML page, also we can notice that a vertical scroll bar
appears for this same testcase with all builds after Aug 25. Im attaching
Screenshot's  of builds from 24 and 25 to demonstrate this bug. 

Reproducible: Always
Steps to Reproduce:
1.open attached test case using 2002-07-24-08-1.0 branch build or earlier builds.
2.open attached test case using 2002-07-25-08-1.0 branch build or later builds.
2.Notice the difference in the height of page 


Actual Results:  The height of the page is different and we also see a vertical
scroll bar for this page.

Expected Results:  The height of the HTML page should be same in all the builds.
(Reporter)

Comment 1

16 years ago
Created attachment 95169 [details]
Test case demonstrate this bug.
(Reporter)

Updated

16 years ago
Keywords: testcase
Priority: -- → P2
QA Contact: petersen → moied
Summary: Shift → Rendering simple HTML pages shifts 2 pixels down for each line in the page.
(Reporter)

Comment 2

16 years ago
There is small typo with build numbers its 2002-07-23 instead of
2002-07-24-08-1.0 and 2002-07-24 instead of 2002-07-25-08-1.0, sorry about this. 

(Reporter)

Comment 3

16 years ago
Created attachment 95174 [details]
Screenshot  from  07-23 branch build or earlier builds.
(Reporter)

Comment 4

16 years ago
Created attachment 95175 [details]
Screenshot  from  07-24 branch build or later builds.
If I recall correctly, we fixed windows font metrics code to not be broken
recently..
(Assignee)

Comment 6

16 years ago
that's caused by line-height change. We now include external leading in normal
line-height. It is not a problem. 
Assignee: attinasi → shanjian
(Assignee)

Comment 7

16 years ago
mark it as wfm. 
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.